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Video window GUI

1.1 Video window GUI

Floating
oeng
Tabbed Document
Auto Hide
Hide

N

AB
»\\3 Close

Close All But This
File Properties...

Copy Full Path
Browse Containing Folder

Open Containing Folder

e

Video window GUI

Close All But This

File Properties...

Copy Full Path
Browse Containing Folder
Open Containing Folder

Folders
Undo/Redo
o

ITI Measurement

:AWM Browse Setup Capture Imm Measurements  Options Wm;:

(@Nv)

M 20%

M=l a

‘EFH &:H Micrometer (um) z X
Camera S

2H 4  Videof

foD,... E

| G v

Ia Measurement Sheet \
Joowwy

@Camera EFo[ders ‘OUndo/Redo lgLayer ‘ﬁMeasurem...\

Yy
|0¢<109

|2

R - - ///%\po(}-@d"’-é

Auto Grids
Manual Grids
Divide...
Remove All Grids

Add Preset...

Preset Management...

Preset

N

Frame Rate: 3.4; Frame: 18459 3072 x 2048

e

T -l

Pixel

Meter (m)
Centimeter (cm)

Millimeter (mm)

Micrometer (um)
Inch (in)

mil (mil)

Customize...

Angle Unit...

R S

3 4X: 048,00 ¢Micmmd i

|8 Diagnose

Property
Computer

0os

Version

CPU

Cores

Threads

Memory

Display

Software

Version

Device Name
Camera Id
Production Date
Revision
Hardware Version
Firmware Version
FPGA Version
Pixel Size

Still Image Capture
Still Image Width
Still Image Height
Video Width
Video Height

Value

Dell Inc. XPS 15 9550

Windows 10 Pro

1803 17134

Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
4

8

e AG
GDI, Rec.709, sRGB, 8 Bits

App(x64)

3.7.13716.20190105

yyyyy

TP181203130246571936AE866A48383
20181203

&

1.0
1.5.1.20180825
2.0

(2.400, 2.400) pm
Yes

3072

2048

3072

2048

A:The App title bar

B: Menu;
C:App toolbar

D:Camera Sidebar ;

E: Folders Sidebar ;

F: Undo/Redo Sidebar ;
G: Layer Sidebar ;

H: Measurement Sidebar ;
I: Measurement Sheet;

J:Statusbar;

Measurement /
Ge“e’al//'Unit Current Symbol Type Scale
th Pixel O px System NA
Meter O m System 1
Angle Unit Centimeter O o) System 100
Millimeter O mm System 1000
Sheet K a am System 1le+06
Magpnification X fn System 39,3701
mil System 39370.1
Name Resolution | oK |
X 2048.00
i 512000
20X 102400.00
40X 204800.00
.|
Delete.., [ awa. | [[oee
e ] o [ cancel | [ sy
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K: Auto Hide button

L: Horizontal ruler;

M:Vertical ruler

N:Frame Rate

O:Frames captured

P:Current Video sizes

Q:The selected microscope Magnification
R:Cooling Temperature

S: Current Unit;

AA: Sidebar right mouse button context menu;

AB: Video window right mouse button context menu;

AC: Browse window right mouse button context menu;

AD: Image window right mouse button context menu;

AE: Frame window right mouse button context menu;

AF: Double-click bring up Diagnose dialog;

AG: Double-click bring up Magnification dialog;

AH: Double-click bring up Measurement dialog;

Al: Horizontal Ruler or Vertical Ruler right mouse button context menu

1.2 How to close the video window?

[ 4

1 Double-clicking the tabbed video window title or clicking x on the title bar right side will close
the video window directly;
2. Choose Windows>Close All command to close the video window; .
3. Click the right mouse button on the video window title to invoke the 2 Activate Video Window 7o
context menu and choose Close to close the video window; File Propertis..

Copy Full Path
4. PreSS Ctr|+W buttonS. 7 Bl'cr-.\.-:ECcnteining Folder

Open Containing Folder

12



Image window GUI

2 Image window GUI

2.1 Image window GUI

A | App

File Edit View Browse Setup Capture Image Process Layer Measurements Options Window Help

B H E @ 85| Micrometer um) V] 4x Mo M|am ko2~ -

/4% L-000-0P-"NMemAaduz @ d.

Y-

Layer 28 |« Video [ Yyyyy
@ X|@ e

Visible Current  Name
%] [0  Background

Image Size

Width
‘ S File Properties...
Height
Copy Full Path

|7 Browse Containing Folder [ constrain Proportions

Open Containing Folder Scale method

(E
lCamera | T Folders | €3 Undo/Redo & Layer ﬁMeasurem/i Iz

Measurement Sheet

C D:\Testimage\Sample\14-2008-large.jpg E 700 x 500 G #® Zoom: 67%

14-2008-large.jpg”

Pixel

Inch (in)

N
K BPP: 24, Besolution: NA

D| & 14-2008-1arge.jpg Properties X H o o10% 3

Measurement /
- - - 20%
General Security Details Previous Versions 5% General Unit Current Symbol Type, Scale
I : Pixel [} px 5, NA
z . 50% Length Unit
@ | 14-20034arge jpg ‘ . Meter O m System 1
Angle Unit Centimeter O = System 100
Type offie:  JPG File (jpg) Ui Milimeter O M system 1000
[ 150% Sheet .
Openswih:  Photos e Micrometer O um System 18406
200% 5 Inch in System 39.3701
Object - ~
Location: D:\Testimage\Sample 300% m m System i
Size: 160 KB (164,569 bytes) 0%
Size ondisk: 164 KB (167.936 bytes) ELiCNI
Fit to Height
Created: Saturday, March 19, 2016, 11:18:48 AM Fit to Window
Modiffied: Sunday, February 6, 2011, 9:11:28 PM
Accessed: Saturday. March 19, 2016, 11:18:48 AM / 7Add J =
Atrbutes:  [JReadonly []Hidden Advanced... |
S Coc 1[0 con |1l
y 1
L Resolution X
Magnification: | Custom v
ok ][ comeel [ [
pixels / [inch () =
.

A: The App title bar;

B:The opened file right mouse button context menu on status bar;
C:The opened file name and directory;

D:Double-click bring up opened file Properties dialog;

E:Current image width and height;

F:Double-click bring up Scale Image dialog;

G:Image Zoom ratio, double-clicking will zoom the image to 100%;
H:Zoom ratio right mouse button context menu;

I:Currently selected Unit;

J: Double-click bring up Measurement dialog;

K:lmage BPP & Resolution;

L:Double-click bring up Resolution Setting dialog;

M: Unit right mouse button context menu;

N: Calibrated Resolution.

2.2 How to close the image window?

1. If user has modified an image before attempting to close it, double-clicking the tabbed image window

13
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Customize...
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Image window GUI

title bar or clicking x button on the title bar right side box

below:

will bring up a warning dialog as shown

2. If the image window is snapped or pasted with number as its title, double-clicking the tabbed image

window title bar or clicking x button on the title bar right side R will bring up a warning dialog as
shown below:

App X

o Image has been modified. Do you want to save changes?

Yes Ne Cancel

3. Clicking Yes will save the changes with its old name and close the window quickly, No will close the
file immediately with no changes and no warning, or Cancel will cancel the Close command and leave the
window there with no changes;

4. If the image window is snapped from the video window or Pasted as New File from the clipboard,
clicking Yes will bring up the Save As dialog (See Sec. 5.5 for details). In the Save As dialog, user can:

Save in: Select the driver and folder to which you want your image file saved in the Save in combobox and
enter the file name in the File name edit box;

Save: Click Save to save the new image with the specified directory and file name;
5. Click No on the warning dialog will close the file immediately with no changes and no warning;
6. Press Ctrl+W buttons.

Note: Choosing Window>Close All command can also close the tabbed image window. Please check the
Window>Close All for details.
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3 Ul toolbar

When the camera is started, the image is opened (or captured) or the image window is setup with Paste as
New File, most of the icons on the toolbar will be enabled for the quick operation of the video or image
window.

1 3 5 7 9 11 3 18 47 19 21 23 @8 27 29 31 33 35
B 4 4 & 5| Meter(m) | 10x V| 25% AW x 2+« /2 2% L-000-@R- Az Alag|aI | d.
2 4 6 8 10 12 14 16 18 20 22 24 26 28 30 32 34

1: Open (Ctrl + O)

2: Save (Ctrl +95)

3: Quick Save

4: Browse (Ctrl + B)
5: Thumbnail(CtI+T)

Folders is a browser to Browse all the image files on disk. It is also an important platform where users can
perform operations easily, such as Stitch, EDF, HDR, Color Composition and so on. But user cannot find a
temporary image files in Folders which are just captured from the software or pasted from the clipboard and
have not been saved to the disk.

4 Video [yl COLORDOT.TIF NUCSTAIN.TIF PROBE.TIF Thumbnail boX
A

r AR = e

02-2009-largejpg  04-2009-largejpg  06-2010-largejpg  08-2010-large,jpg  10-2008-large,jpg  10-2009-large.jpg

P

10x_02,jpg 11-2009-large,jpg  12-2008-large.jpg

10th2001exlarge....  10th2004exlarge....

v

Thumbnail is also a browser that could manage all the opened files, including the opened files on disk and
opened temporary files which are not on the disk yet. Many convenient operations can be done in
Thumbnail Browser, besides the operations on the opened files on disk (Stitch, EDF, HDR and Color
Composite), Quick Save and Batch Save could also be done for temporary files. Selection of multiple
images exported to Microsoft Word Report can only be done in Thumbnail Browser.

4 Videe lyyyyyl Browse COLORDOT.TIF NUCSTAIN.TIF PROBE.TIF | Tllumbnﬂl

d Quick Save... Ctd+Q
Batch Save...
Close

Close Others
Delete Delete

COLORDOT.TIF NUCSTAIN.TIF PROBE.TIF

File Properties...

Copy Full Path
=z Browse Containing Folder
Open Containing Folder

S Stitch... Shift+T
High Dynamic Range (HDR)...

:i| Color Composite...
p
< EDF.. Shift+F

6: Unit
7: Magnification
8: Zoom
9: Track(enabled only when the image/video size is larger than the window size)
10: Object Select(will be enabled when an object is overlaid on the background layer
11: Angle
15
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12:
13:
14:
15:
16:
17:
18:
19:
20:
21:
: Two Circles
23:
24
25:
26:
27.
28:
29:
30:
31:
32:
33:
34:
35:

22

Point

Line

Line(3 Points)
Parallel

Two Parallel
Vertical
Rectangle
Ellipse

Circle
Annulus

Arc
Text
Polygon
Scale Bar
Arrow
Calibrate (for both image/video window)
Gray Calibration (for video window)
Stitch(for image/video/Browse/ Thumbnail window)
EDF(for image/video/Browse/ Thumbnail window)
High Dynamic Range(HDR, for image/Browse/Thumbnail window )
Microsoft Word Report(F10)
External Application (Open the current image with the External Application)
Customize Toolbar
i [G]] | &

Add or Remove Buttons v| Toolbar 2

Customize...

16
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4 Camera Sidebar

The Camera Sidebar is used for the control of the camera, it includes many groups. The group can be
expanded by a) clicking the group name or b) clicking the Down Arrow at the right end of the group name.

I Camera List

v
L3

Bl Capture & Resolution

¥

Exposure & Gain
RS

£«

|5 White Balance
—

<«

(D Black Balance

<«

i Color Adjustment
s

<«

& Bit Depth

<«

® Power Frequency [Anti-flicker)

<«

+ Frame Rate

<«

:‘ Color/Gray

<«

b Fiip

£«

o,
<1, Rotate

<«

, @ Sampling

<«

izl ROI

<«

== Digital Binning

<«

i Histogram

<«

(=) Dark Field Correction

<«

(=) Flat Field Correction

<«

| Sharpen

£«

- Misc

<«

#» Parameters

<«

The camera Sidebar can be shown or hided by Option>Preference>Misc page and find Show or hide group
in the camera sidebar as shown below:

4.1

Preferences

Quick Save
Quick Record
File

Report

Grids
Capture

Metadata

Show or hide control in the camera sidebar
Capture & Resolution
Exposure & Gain

Auto Focus

Bit Depth

Pixel Farmat

White Balance

Black Balance

Color Adjustment

Power Frequency {(Anti-flicker)
Frame Rate

Bitrate (Mbps)

Color/Gray

Misc

Flip
Rotate
Sampling

ROI
Digital Binning
Histogram
-~ -

Cancel Apply

Camera List group

@ Camera List

Yy

Camera List will list all of the cameras connected to the computer USB ports that support
the App. Clicking the camera name yyyyy will start the camera video window.

4.2 Capture & Resolution group

BN Capture & Resolution

& -

Live: 5440 x 3648

Snap: 5440 x 3548

O

»

Record

~

Format: [reB24

v

Snap: Click it to continuously Snap images;
Record: Record video feed in mp4(H264)/mp4(H265)/wmv/avi(Deprecated) format;

Live: Set the Live video resolution;

Snap: Set the Snap resolution for image capture;
Format: Can be RGB24/RAW/RGB48 Format depending on the camera model for Snap.

For cameras that support more than 8 bits, please set the camera Bit Depth to more than 8 bits (10/12/14 bits) first to capture
a file with more than 8 bits. Click the Format list box’s drop down arrow in Capture & Resolution group, you can find 3 options
there, which are RGB24, RAW and RGB48. RGB24 means RGB888, and you could only get an image with 8bits per channel; RAW
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is the original image data; RGB48 means RGB161616 and you could only get an image with 16bits per channel.

If RAW is selected, clicking Snap button will bring up a Save As dialog, the 10bits/12bits/14bits RAW data will be transferred
to 16bits RAW data and will ask user directly to save the image into DNG or TFT file. No image window will be created.

If RGB48 is selected, for 10bit/12bit/14bit Bit Depth, clicking the Snap button will capture the corresponding Bit Depth into
image window. Choosing File>Save As command will transfer the Bit Depth to RGB48 Format and save it with tiff format.

Bl Capture & Resolution A
Live: 4632 x 3488 -]
Snap: 4632 = 3488 -]

Digital Negative (*.dng)
Format: RGE43 - — - dna) Tag Image File Format (" 1if;" tiff)

RGE24 (* ft) Image File Format {* i " 1iff)
RAW
(%4 Exposure F‘.GEHa

4.3 Exposure & Gain group

P = 1. When the Exposure & Gain group is expanded, a green rectangle marked with Exposure
] Auto Bxposure will be overlaid on the video window This marked region is a ROI for judging if the image
Exposure Target w| brightness reaches to the Exposure Target value or not. Drag the Exposure ROI to the darker

area will increase the video brightness and drag it to the brighter area will decrease the video
SpostreTime: brightness;

0
Gain w| 2. Uncheck the Auto Exposure box to switch the Auto Exposure mode to the Manual
0 Exposure. The Exposure Target slider will be disabled in this mode;

3. Turn the microscope light source to a brighter state, and then drag the Exposure Time
o = a slider left or right until the image brightness is normal;

! ! 4. If and only if the microscope light intensity is too low to meet the Exposure Time's up limit,
drag the Gain slider right until the video brightness is normal;

o a8 a

5. The exact Exposure Time can also be entered by clicking the edit box at the up right side
of the Exposure Time slider. This will bring up a dialog called Exposure Time. User can type

Rectangle for Auto Exposure the values in this edit box to set the exact Exposure Time;

6. When the 50HZ or 60 HZ is selected on the Power Frequency group and the Auto Exposure is checked, the Exposure Time will
be calculated automatically to eliminate the dark band effect for the video feed;

7. There is an Auto Exposure Policy setup to customize the Auto Exposure process, please check Sec.15.1.8.4 for details.

4.4 White Balance group

| White Balance £ ) ) . .
e 71 The White Balance controls allow user to adjust the White Balance ratios for Color

i Temperature/Tint or each of the RGB color channels in a specified rectangle area.
Tint: 1070

@ 1. Click the White Balance bar to expand the White Balance group and a pink rectangular
T e e Do R g aat marked with White Balance will be overlaid on the video window;

2. Drag or resize the red rectangle to a pure white or gray area and click the White Balance

l e Selonce J | pefoits l button to establish the video White Balance for future video feed process;
|, White Balance (Take effect after restarting Toupiiew) 3. If the automatic setting and the actual result still has deviation, drag the Temperature or

() Color Temperature/Tint

® RG Gan Tint slider to left or right to manually correct the White Balance;

4. The White Balance group can be switched to RGB Gain mode in the Options>Preference--- property sheet at the Misc page

under the White Balance item. A restart of the software is required when switching the White Balance adjustment mode. See
Sec.15.1.8.3 for details.

4.5 Black Balance group

Video cameras can possess a function called Black Balance which calibrates the signal for no light, just as they have a White
Balance function which gives reference to true white to the CCDs. Unlike White Balance, Black Balance is not adjusted every time.
This function is found in higher end professional cameras rather than in cameras for amateurs.

The main purpose of Black Balance is to eliminate any residual current being output from the pixel sites under conditions of
complete darkness, often referred to as thermal noise in different channel. This is why the camera automatically closes the iris
completely when it does the Black Balance.

Conditions under which Black Balance are typically done are when the camera experiences a large change in operating
temperature, especially from colder to warmer. Otherwise, it is a periodic thing to allow for other minor factors that could come
into play.

With CMOS sensor technology, Back Balance may not be as necessary as it is with CCD type devices. It is common to talk about
how clean and relatively noise free CMOS sensors are by design.

There is a lot of debate on whether it is necessary to do the Back Balance every time.
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The App suggests that the Back Balance be performed when:

The camera is used for the first time;

The camera is first used after a long period of disuse;

The ambient temperature changes greatly;

When switching to normal shutter or slow shutter;

When switching between progressive and interlaced modes;

(D Black Balance ES
Red: 1}
Green: o
Blue: 0

Black Balance Defanlts

1. Click the Back Balance bar to expand the Black Balance group and a pink rectangular
marked with Black Balance will be overlaid on the video window;

2. Turn off the microscope light;

2. Drag or resize the red rectangle to a black area and click the Black Balance button to
establish the video Black Balance for future video feed process;

3. If the automatic setting and the actual result still has deviation, drag the Red, Green or
Blue slider to left or right to manually correct the Black Balance.

4.6 Color Adjustment group

& Color Adjustment

B

i}

Hue: 0

Saturation: 128

Brightness: 0

Contrast: 0

Gamma: 100

1. Hue: Adjusts the Hue of the video. Drag the slider to the right to increase or to the left
to decrease Hue;

2. Saturation: Adjusts the Saturation of the video. Drag the slider to the right to increase
or to the left to decrease video Saturation;

3. Brightness: Adjusts the video Brightness. Drag the slider to the right to increase or to
the left to decrease the video Brightness;

4. Contrast: Adjusts the video Contrast. Drag the slider to the right to increase or to the
left to decrease the video Contrast;

5. Gamma: Adjusts the video Gamma. Drag the slider to the right to increase or to the
left to decrease the video Gamma;

6. Defaults: Click the Defaults to clear all the changes and reset them to default ones;

7. All of the settings will be saved for future applications.

4.7 Bit Depth group

& Bit Depth
()8 Bits

(®) 12 Bits

»

Switch among or between 8 bits/12 bits(/14 bits). 8 bits is the basic windows image
format. 12bits/14 bits will have higher image quality but moderate FPS;

The Bit Depth (Bits Per Pixel) is depending on the camera hardware.

4.8 Power Frequency group

'/ Power Frequency
@) AC (50 Hz)

") AC (60 Hz)

“pc

1. A CMOS sensor captures each row of pixels (from top to bottom) in sequential order,
creating a rolling effect, hence the name "Rolling Shutter". Instead of being relatively
constant, so for example, as the commercial main frequency in Europe is 50Hz,
fluorescent lights in Europe flicker at 100 times per second and as the main frequency in
US is 60Hz, so in the USA they flicker at 120 times per second;

2. This flickering problem is solved by capture row pixels in over the duration of integer number of n flicker periods;
3. Selecting 50HZ will delete the rolling dark band for the 50HZ light fluctuation;

4. Selecting 60HZ will delete the rolling dark band for the 60HZ light fluctuation;
5.

For DC power, no light fluctuation is existed and no compensation is needed.

When 50HZ or 60HZ is selected and the Auto Exposure is checked on the Exposure & Gain group, the Exposure Time will be
calculated automatically to eliminate the dark band effect for the video feed.

4.9 Frame Rate group

(5 Frame Rate b

Low High

Move the slider to the right to ensure that the camera plays live video at the
fastest frame rate that the computer USB hub supports. T live video fails to
display, move the slider to the left to decrease the frame rate.

Drag the slider to the right (High) to ensure that the camera can run the video at the
fastest Frame Rate that the computer USB hub supports. If the video fails to display, drag
the slider to the left (Low) to reduce the Frame Rate and this will enable the video feed in
a low speed state.

4.10 Color/Gray group
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2 Color/Gray ® If you wish to preview Color video, select the Color button;

©eray If you wish to preview Gray video, select the Gray button.

4.11 Flip group

If the video on the screen appears in different directions from what is viewed under the
microscope or direct view, check the Horizontal or Vertical box to set the video direction
to the right one.

A Flip
[ | Horizon tal

[ |vertical

4,12 Rotate group

“, Rotate &
®o°
Select the right one (0°(Default), 90°, 180° or 270°) to rotate the video to the desired
89°° angle.
180°
O 270°

4.13 Sampling group
Binning is a function that averages or adds multiple sensor pixels to obtain a single value:
If the pixel values are added, the image brightness increases; if the pixel values are averaged, the image noise is reduced.

This also reduces the amount of data to be transferred and enables higher camera frame rates. The captured image has a lower
resolution but still the same field of view compared to the full-resolution image.

j j ‘ﬂ j EEEN = | = HEC
nrnn B A= e
A AR 5= m=
AAAR o

2x binning (monochrome sensor) Color correct 2x binning (color sensor)

Color binning as performed by most color sensors, combines only pixels of the same color. For some monochrome sensors, the
camera also performs color binning, resulting in slight artifacts.

Most monochrome sensors and some color sensors combine neighboring Bayer pattern pixels; in this case, the color information
gets lost (mono binning).

Subsampling skips multiple sensor pixels when reading out the image data. This reduces the amount of data to be transferred
and enables higher camera frame rates. The captured image has a lower resolution but still the same field of view compared to
the full-resolution image.

H RN BE EEn e [ I [ = HOEC
= omm|g = | R . EEER
H B B n - | || - |||
D mE CHE
HE B BB | 1= ]|
| |
H R R E
2x subsampling (monochrome sensor) Colour correct 2x subsampling (colour sensor)

Color subsampling as performed by most color sensors, skips pixels while maintaining color. For some monochrome sensors, the
camera also performs color subsampling, resulting in slight artifacts.

Monochrome sensors and some color sensors ignore the Bayer pattern and the color information gets lost (mono subsampling).

Subsampling can also be done in the pixel preprocessing on the camera. This process reduces the data volume per image, but
does not increase the frame rate.

* Sampling
@ Bin

(©)skip

1. Bin: Pixel binning refers to the method of combining (averaging) pixels of blocks of
neighboring same color pixels to resize the video to the lower resolution, but higher signal
to noise ratio;

2. Skip: Also called Decimation (reduction of digital signal's sampling rate) means that a certain amount of pixels are not read out
but skipped (horizontally, vertically or in both axes). This reduces resolution of the resulting video and introduces subsampling

artifacts but higher frame rate;

4.14 ROI group

7l rol 2
5440 x 3848

Apply Defaults

ROI, Region of interest. This function can set the ROI on the video window. When the ROI
group was expanded, a dotted rectangle with Handles will appear around the video
window that will let user alter the ROI. Use mouse button to adjust the ROI size. If ROI is
ok, click Apply will set the video to ROI size, Defaults will return to the original size;
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Click the left or right number edit box will invoke the ROI dialog to set the ROI with keyboard.

4.15 Digital Binning group

|z Digital Binning
Methad
@ Additive
() Average

Number

»

1. Additive: Additive Digital Binning refers to the method of combining (Adding the
specified Number x Number of pixels) pixels of blocks of neighboring same color pixels to
resize the video to the lower resolution, but the higher brightness. The new resolution will
be (Width/n, Height/n, n is the Number);

2. Average: Average Digital Binning will add the specified Number x Number of

@1 neighborhood pixel values together and then divide it by Number x Number, means that
02 a certain amount of pixels are averaged (horizontally, vertically or in both axes). This
O3 reduces resolution of the resulting video and introduces higher signal-to-noise ratio. The
O new resolution will be Width/n, Height/n, n is the Number;

3. The Digital Binning is realized by the computer software not by camera hardware.

4.16 Histogram group

»

# Histogram 1. A Histogram illustrates how pixels in an image are distributed by graphing the humber
of pixels at each color intensity level. The Histogram shows detail in the shadows (shown
in the left part of the histogram), midtones (shown in the middle), and highlights (shown
in the right part). A Histogram can help you determine whether an image has enough

detail to make a good correction;

2. This group shows the Histogram of current active video. Two vertical line markers show
the upper and lower limits of the intensity levels. These markers can be dragged with
mouse. If you are looking at a color image, the Histogram will reflect the RGB(red, green
and blue channels histogram at the same time), R(red), G(green), and B(blue) values
with lines of the same color;

Left: |0
Right: |255

3. You can also enter directly the desired values in the Left or Right edit boxes below the Histogram chart for both Left and Right
Histogram boundaries;

T T T T
o 50 100 150 200 255
Linear R =

4. Linear or Logarithmic can be chosen to make the video in a rational display mode;
5. Clicking the Defaults button will return the Left and Right Histogram boundaries to its original ones;

6. Click the Auto button to locate the two boundaries automatically to get the best video quality.

4.17 Dark Field Correction group

Dark Field Correction is normally used to remove the background noise or fixed pattern
noise. Dark frames must be taken with no illumination.

»

Dark Field Correction

Encble For long time exposure application, dark current noise is obvious and users could remove

the dark current noise by Dark Field Correction process. It could also help to remove the
defect pixel when long exposure time is required.

Capture Quantity: 10 :

Cover the lens, and then push the "Capture" button to
capture the dark filed. Check the "Enable" button to enable

capture the dork fled. | To Enable the Dark Field Correction, one should capture the dark field images first. After

the images are captured, the Enable button will be enabled. Check it will enable the Dark
Field Correction. Uncheck it will disable the Dark Field Correction.

4.18 Flat Field Correction group

Flat Field Correction is used to correct the inhomogeneous background caused by the microscope or illuminations. Please remove
the sample first and capture the inhomogeneous background images. Then put the samples on the microscope xy stage and
enable the Flat Field Correction. Please be sure that the sample is removed when the background images are taking.

When condition is changed, including optical system, illumination, exposure time or gain, Flat Field Correction must be performed
again in the new condition.

1. Remove the sample first to get the inhomogeneous background;

2. Set the Quantity of the background images and these inhomogeneous background images are going to be averaged and used
as reference for Flat Field Correction;

»

=) Flat Field Correction

Enable
Capture Quantity: |5 |5

Inport... Export. ..

Remove the samples from the field of view, Click the "Capture™
button to obtain the background for flat field correction. Check
“Enable” button to perform the flat field correction function.

=

3. Click the Capture button and the App will capture the specified Quantity image. After the background images are captured, the
Enable button will be enabled;

4. Check Enable button and the Flat Field Correction will be effective, uncheck it will disable the Flat Field Correction;
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5. Put the sample back. Please check the results as show above for reference;

6. Click Export to export the current Flat Field Correction data to the ffc file for the future application;

7. Click Import to import the saved ffc file for the current video Flat Field Correction.

4.19 Sharpen group

i| Sharpen

0% (Disable)
]

o

500%

%

Sharpness determines the amount of detail an image can convey. Drag the slider to the
right will increase the image Sharpness and to the left will decrease the image Sharpness.

4.20 Misc group

Misc

[INegative

Tone Mapping: Logarithmic

Defaults

»

Negative will reverse the pixel values of the video feed without going through the lookup
table;

Tone Mapping is a technique used in image processing to map one set of colors to another
to approximate the appearance of high-dynamic-range images in a medium that has a
more limited dynamic range. In the App, user can choose Logarithmic or Polynomial.

4.21 Parameters group

& Parameters

Factory Settings

Load Save...

Oyerwrite Management. . .

& Parameters

MyParameters1

Load Save

Overwrite Management

»

»

Parameters group is used to save the camera control parameters adjusted for further
application;

Click Save will save the current camera control parameters in new parameter file (For
example MyParameters1), This file name will be attached to the end of the Factory Setting
list box. Then the Load and Overwrite buttons will be enabled;

Click Load will load the current item in the Factory Setting list box;

If the user saved Parameters is loaded (such as MyParameters1) in the Factory Setting list
box, the Overwrite button will be enabled. Clicking Overwrite will overwrite the current
camera control parameters to the current loaded active camera control parameters
file(MyParametersl);

Click Management will invoke a Management dialog and in this dialog, one can manage all of the saved Parameter files.
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5 File

5.1 Open Imageeee = Ctrl+O

Choose File>Open Image+ss command to open an existing image file. The Open Imagesss command can
also be used to preview an image in small size, or to view image’s statistics information without actually
opening the image itself. These capabilities can be used to locate a particular image quickly.

Open X

The App supports and can open many image
formats. These are identified in the Files of type ok | M Sorie ] 02 &
list box. One may also open the TFT (*.Aft) + Eh

format image file which can save Measurement | Quickecces
Objects (for simplicity, only Object or Objects
will be used to represent Measurement Object or petioy

Measurement Objects) overlaid on the image.

Libraries
More than one image can be opened with the App - R TR
simultaneously by a) with Ctrl + left mouse | .. = 3% Sy W
button; b) Shift + left mouse button; c) Draw a | o "7 v A -
rectangle with the left mouse button and d) edl] i ¥
Ctrl+A button to highlight the files to be opened. Honane:  [02209%ageipg ~| G
In this mode, the Preview window will be Resciiee: [MEee E Canee!
d |S ab I e d ] Image Information/Preview

Preview

Current File:

When opening an image, the App places it into a
new image window. It then becomes the active
image.

D:\DemoImage\Sample\02-2009-arge.jpg

Width: 700 Height: 500

Note: The App maintains, at File>Recent Files submenus, a list of the last 4(Can be 1-8, see Sec.15.1.8.18
for details) opened files. Any of these files can be accessed by simply clicking the submenu. If no files are
listed in File>Recent Files submenus, the Open Imagesss command must be used to open an image.

Also, the View>Browse can be used to view images in lcon mode under any selected directory. Brief
information can be found in the View>Browse command (See Sec.7.1 for details).

Windows Bitmap (*bmp
JPEG (*jpa:" jpeg:” jpe;" it ffif)

File name: From this list box, select the name of the file want to open. Either e (o pe 80
the type of the file name (with its entire path, if it is not in the current folder),  Tes mase e foma (i s

. . . . . ) ) ) CompgSer\re GIF {*.gif)
or selecting Files of type to obtain a list of file names. Double-clicking a file 7523,

Photoshop (* ped)

name in the large combobox (where both folder and file names are listed) i (o

Enhanced ‘.'\c'indnu\fs Metafile (" emf)

will automatically open it; Windows etafe { wr)

JBIG (" jbg)
Wireless Btmap (" wbmp)

Note: If user just type in the File name, be sure that the Files of type field & %00 cetemeant a0
Digital Imaging and Communications in Medicine (*.dcm)

correctly identify the format of the file to open. Otherwise error messages o esaive o
will bring up when the App tries to open the file. TFTCH)

Al subpurled formats
All Files (.7}

Files of type: In this list box, select the image format of the file to open. If one selects All supported formats,
the App uses the file's extension to identify its format. The App supported file formats are show above on
the right side;

If the image file does not use the standard format-identifying extensions, the file in the File name field must
be typed, and then select its format from the Files of type list box. Otherwise, the App will select a format
based on the file name extension.

Preview: Check this button to preview image in small size. In Preview mode, statistics information about
the image (i.e. image Width, Height and image location) will be displayed. The default is unchecked,;

Current File: Current File location on your computer;
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Width: Current File image Width;
Height: Current File image Height.

5.2 Open Videoeee =

The File>Open Videoes+ menu will be enabled only when there is no video file opened in the App frame or
no camera was opened with video feed.

1. Choose File>Open Video+es command to open an existing video file;

Open X
= v 4 « Data (D:) » Demolmage » Stack v O Search Stack £

Organize = Mew folder = -~ [ o

ImageCount &
Sample

SCMOS05100KPA

SEE 12(000DD2158-000

Stitch v 021222).avi

File name: ‘ 12(000002158-000021222).avi V| Video Files (*wmw*.asf;*.avi;*r ~

CEHCEI

2. Select the name of the file wish to open. If the file does not appear, select the option for showing all
files from the Files of Type list box on the right side of the File name list box. The video File of Type can
be:

Video Files ("wmv;*.asf:*.avi;* mpd* . mdv;* 3gp;* 392" 3gp2* 3gpp; ™ mov:* . mboe ™ fhvy iy = rmvb;* 264, % h264;*,.265;* h265)

3. Click Open to open a video file, this will create a video window and begin to start the video feed. The
video window will be associated a name called Video[yyy.ext] (i.e., its title bar will display Video
[yyy.ext], here, yyy.ext is the video file name);

4. Click Cancel to return to the App.

Note: Only a single video window can be created at a time. The App takes camera as a special video file,
if the camera is opened, the File>Open Videoess menu will be disabled.

5.3 Open Broadcasteee

In computer networking, telecommunication and information theory, Broadcasting is a method of
transferring a message to all recipients simultaneously. Broadcasting can be performed as a high level
operation in a program, for example broadcasting in Message Passing Interface, or it may be a low level
networking operation, for example Broadcasting on Ethernet.

Users could receive the Broadcasting video with the App from the other user by specifying the Address and
Port.

Open broadcast X

Address: ‘ |

Port: 2080

OK Cancel

For example, if user starts a broadcasting service via Address 192.168.0.20 and Port 2080, the other users
could receive the video that is broadcasted through 192.168.0.20 by inputting the right Address and Port in
the Open broadcast dialog. If the receiver and the broadcaster are in the same intranet, the performance will
be excellent. If not, the performance will depend on the network bandwidth.

About Capture>Start Broadcasteee, please see Sec.10.4 for details.

54 Save = Ctrl+S
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Choose File>Save command to immediately store the current window image to its file (the saved file name
is listed on the window's title bar) while leaving the image still active in its window.

If the image is untitled or titled with a number and there are no Calibrated Resolution for the captured
image, the App will issue the File>Save Ase+s dialog automatically (See Sec.5.5). The default Save as type
will be Window Bitmap (*.bmp,*.dib,*.rle) as shown below on the left side.

If there are Calibrated Resolution for the captured image, the default Save as types are shown below on
the right side:

JPEG (“jpg: Jneg IDe "I )
Portable Network Graphics (png) =%, ipes#. ipe sk
Tag Image File Format (4" ) Portable Network G-rapl'u cs % png

'T'gr;allptc;g} Taz Image File Format (% tif# t1ff)
JPEG 2000 Standard (" jp2) ﬁ Eg Q(Eﬂeeit?ndard (%, jp2)

JPEG 2000 Codestream (*j2k) TFT G .tft)p

Digital Imaging and Communications in Medicine (* dem) W1 e bed £ .

‘WebP (“webp) I supporte ormats

TFT ("t Files 0% #)

Save as Type without Calibrated Resolution Save as Type without Calibrated Resolution
This means the Objects can be saved as an image file’s separate layer in popular format, such as JPG, TIF,
PNG, WebP and TFT. The TFT(*.tft) is a special format defined by the App for the Layer Objects. All of
the formats allow for further editing of the Objects in the App.

If the captured image format is RGB48, the default Save as type is shown on
the right side. This is because the TIFF supports several depths ranging from 2
BPP to 32 BPP.

The File>Save command can be used to save the most recent changes to disk. It is often performed as a
precautionary measure during lengthy or involved processes to reduce the amount of reprocessing that
might be required in the event of a system failure or operational error. When an image is closed and not to
save its changes is chosen, the App discards all changes made since the last File>Save operation.

|Tag Image File Format {" ;" 1iff) -

Note: a). The File>Save command always saves the contents of the entire window, even if there is an AOI
(Area of Interest) defined on it;

b). The File>Save command will be disabled if the file is not changed or the changes have been saved.
5.5 Save Ageee

Save As X

Choose File>Save Aseee command to save the
contents of the current window to a specified file
format as show on the right side. At the end of a * 7 T
File>Save Asees operation, the image window | 2= = B
will be associated with the new file and the new 4
format (i.e., its title bar will display the new file R

name). = @ % ko . r.

Libraries 4x 02jpg  06-2010-la.. 6th2002exl... 7th2000exl... 08-2010-la...

Savein:l Sample v‘ @ -

02-2009-la... 2nd2003exl... 04-2009-la... 4th2007exl... 4x.jpg

The App supported file save formats are shown as =

below. Different file information will list different | riec B ¢ B ]

Save as type In the IISt bOX The App WI” arrange LQ‘ 10-2008-la... 10-2009-la... 10th2(;01exl.‘. 10th2004exl... ~10xjpg

the Save as type format group according to the Network 7
image information automatically. In the App, el < [

Save as type: JPEG (*jpg:" jpea:” jpe:” jif:" ffif) v Cancel

there are 4 groups for different image.

Option

‘.b p:".dib:
JPEG (*jpg: Jpeg * pe: i fff)
Portable Netwaork Graphics (" png)
Tag Image File Format (" iif,” &iff)
PCX (" pex)

j *jif;* ffif)
Pnrtahle Neiwmk Graphlcs (" png)
Targa (“ tga) Tag Image File Format (* tif;" tiff) Tag Image File Format (" tif:" tiff) gﬂa\ Negatlve { dng}
JPEG 2000 Standard (*jp2) ‘JISSJGPZI_P&[;E;a}ndard ip2) -

JPEG 2000 Codestream (*j2k)

Digital Imaging and Communications in Medicine {*.dem)
WebP (" webp)

TFT (" #ft)

All supported formats

Al Files (")

Al suppnrted formats
All Files (",

TFT ("#ft)
All supported formats
All Files (°.7)
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File format without Calibration File format with Calibration File format with Bit File format for
Resolution Resolution Depth >8bit(RGB48) RAW data

Save in: Find the folder where the file wishes to be saved. A new folder may be created using the Create
New Folder button "~ ;

File name: The file name to be saved. To specify the file's location, either enter its entire path (disk and
folder), or specify its location using the Save in list box;

Save as type: In this list box, select the format where the image wants to be saved,;

File>Save Aseee is also used to convert a single image from one format to another. For example, if a TIFF
file needs to convert to PCX format, open the TIFF image first, then choose Save Asess command with the
PCX format to save it to a new file. The default Save as type will be Window Bitmap (*.bmp,*.dib,*.rle). If
there are Objects overlaid on the image, the default Save as type will be JPG, TIF, PNG, WebP and TFT,;

The Save As command has several important uses beyond simply saving an image to a new file name.
Option: Click Option to select the different parameters to encode the file. Details are described below.

For JPEG (*.jpg,*.jpeg,*.jpe,*.jif,* jfif), Option has the following items:

Image quality: If one save an image in JPEG format (*.jpg), one may adjust image quality in the edit box or
drag the slide bar. The values for Image quality range from 0 to 100. Defaults value: 75;

Progressive: The default is unchecked; Check this to save the file | s x
in what's called Progressive or Interlaced formats. This label | ,..oay
changes depending on what file type you select. These image | e g =

quality

properties are only supported by certain file types, such as GIF or
JPG formats. This property lets viewers see the file quickly, with
more details appearing as the file is successively rendered. |HFeo=s= smotng [0 2
Commonly used for images on web pages, it's also generally |Zoetmes coang

used where the file must be viewed over a slow network
connection. GIF supports Interlaced, and JPG support |[Jssetesesiinssascefais

Progressive. Cancel Defouls

00 5

Optimize coding: The default is unchecked;
Smoothing: The values range between 0 and 100. Default value: 0;

Save these setting as defaults: When saving a file, if this item is checked, the current settings will be saved
as defaults for the next file save operation.

For Portable Network Graphics (*.png), Option has the following items:

Interlaced: The default is unchecked; Interlaced image loads an | e X
early degraded version of the whole image as soon as possible
and then progressively renders the image to clear state.
Interlaced will always be a bit bigger in file size;

interlaced

Non-interlaced image will load up in tiles showing clear image
in each tile as it progresses to load in the image;

Save these setting as defaults: When saving a file, if this item is
checked, the current settings will be saved as defaults for the |5 thesssetings = defauts
next file save operation. Cance Defauts

For Tag Image File Format (*.tif, *.tiff), the Option has the following items:

Appended pages: Determine whether the current image will be saved in multiple pages style or not;
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Compressions: Specifies a method for compressing the
composite image data. For saving a 32-bit TIFF file, one can
specify that the file be saved with predictor compression, but
have no option to use JPEG compression. Predictor compression
offers improved compression by rearranging floating point
values, and works with both LZW and ZIP compression;

Image quality: If choosing Compressions as "JPEG", the Image
quality can be adjusted by the slider bar. The values range
between 0 and 100. Default value: 75;

Save these setting as defaults: When saving a file, if this item is checked, the current settings will be saved

as defaults for the next file save operation.

For JPEG 2000 Standard, JPEG 2000 Codestream, Option has
the following items:

Lossless: Can check the Lossless or its right edit box with spin
button to choose the wished compress ratio. The default value is
100(1~100);

Save these settings as defaults: When saving a file, if this item is
checked, the current settings will be saved as defaults for the
next file save operation.

For WebP, the Option has the following items:

Lossless: Check Lossless will set all the parameters to the
values which can keep the image with the higher quality;

Preset: If Lossless is unchecked, the Preset item will be
enabled. User can select Photo, Picture, Drawing, Icon or Text
according to the image contents;

Image quality: If one save an image in WebP format (*.webp),
one may adjust image quality in the edit box or drag the slide bar.
The values range from 0 to 100. Default value: 75;

Save these settings as defaults: When saving a file, if this item is checked, the current settings will be saved

as defaults for the next file save operation.

For Digital Imaging and Communication in Medicine,(DCM

format) Option has the following items:

Compression: There are 3 terms in the dropdown box, they are
Lossless JPEG(default), RLE, None ,The default is Lossless JPEG;

Save these settings as defaults: When saving a file, if this item is
checked, the current settings will be saved as defaults for the next

file save operation.
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For PCX(*.pcx), Targa(*.tga), JBIG(*.jbg) and the App File Type(*.tft), there is no Option.

Note: a) Detailed information of the above academic terminologies can be found in books or internet about
image processing and image compression; b) The file saved directory can be restored for future use. To
keep the directory unchanged when the App is started again, choose Options>Preferencesess command,
click Misc page and check Restore the current directory when startup under the Privacy item.

56 Quick Save % CTRL+Q
The File>Quick Save menu will be enabled when a) a new image captured from
the camera; b) an image window is created by choosing File>Paste as New File | 2

command; c¢) an image window is copied from the Undo/Redo Sidebar with the Sl peton
copy button as shown on the right side.

File>Quick Save can save the file at quick way with no need to specify the file directory, file name and file
format. All those are specified in Options> Preferencesess, Quick Save property page (See Sec.15.1.1 for
details) If Show the rename dialog is checked in the Quick Save property page, choosing File>Quick Save
will pop up a Rename dialog as shown below on the right side. Enter the name to save the image file.

If Show the rename dialog is unchecked, choosing File>Quick "™
Save will save the file with the name specified in the Options> =
Preferencesees, Quick Save property page’s setting (S€€ | [ioontsnon the rename deog oter
Sec.15.1.1 for details.).

Cancel

5.7 Batch Saveeee

The File>Batch Saveess menu will be enabled when a) an image is opened and

modified; b) an image is captured from the camera; c) an image window is | Bge—————
created by choosing File>Paste as New File command; d)an image window is St S gg:f“m
copied from the Undo/Redo Sidebar with the copy button as show below:

1. If the image is modified, choosing File>Batch Saveses command will save o
the file with its opened file directory, including file name plus file extension; Parable Hetwerk Graphcs ( png

Tag Image File Format (" tif;* 1iff)
JPEG 2000 Standard (*jp2)

2. If the image is modified because of the Objects, choosing File>Batch Saveess  icrweos)

menu will save the file with its opened file directory and name with the right side & Lo i tomate

listed file extensions. Al Fles (-

If the image window has been created with b), ¢) or d) style, choosing File>Save Asess command to save
the multiple files one by one will be time-consuming. The Batch Saveees command will runs File>Save
Aseee command with the name automatically specified according to the paradigm specified in the Batch
Save dialog as shown below on the right side.

To start File>Batch Saveess command for b) style | ™ x

Directory:

image WIndOW, yOU have to Base: |D:\Testlmage's,5.ample &!8'|

1. Start the camera; S Nore v cance
File::

2. Snap at least an image first; Name Format: | nnnn (sequence) v

File Prefix: |'IT |

3. Choosing File>Batch Saveees command will
bring up a Batch Save dialog shown on the right
side.

File type: ipa (IPEG) ~

The sequence starts with: s0|

Sample: | D:\TestImage \Sample{TTO080.jpg ‘

Directory Base: Enter the name of the drive and directory where the new image will be saved. User may
either type the path, or use the Browse button "&¥ to locate it from a standard Browse Folder dialog;
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Directory Sub: The sub directory for the Quick Save under the Base directory. The
Sub can be None, Date(YYYYMMDD) or Year(YYYY)\Month(MM)\Day(DD). basprrmmon)
The default is None; Year (YYYY) Manth(MM)\Day (0D)

Name Format: The year, month, date, hour, minute and second or nnnn (sequence)
are used as part of the file name. If more files are saved with in a second, a (xx) [pmmanes.
yy-mm-dd-HH-MM-55

suffix is attached to the end of Name Format to avoid the possible name ‘-4 - S5
confliction. For the nnnn (sequence) Name Format, no suffix is needed;

File Prefix: Enter a file name prefix for Quick Save when generating files names for a series of images.
This prefix will be combined with Name Format to form a final file name naming paradigm;

File Type: In this list box, select the format in which you wish the image to be saved (can be JPG, PNG,
TIF). If the image Bit Depth is larger than 8-bit, the App with transfer the Bit Depth to 16-bit(RGB48)
format, the image will be always saved with tif format because only tif file could support RGB48 format;

The sequence starts with: Check this to specify the start number for the Batch Save sequence file number.
Unchecking will always start it with 1;

Sample: The final file name is shown at the right of the Sample item for reference;

4. If the setting in the Batch Save dialog was finished, click OK button to begin the file batch save process
or Cancel to cancel the Batch Save command and return to the application;

For the c) or d) style image window, only step 3 and 4 are needed.

Note: a) In the process of the File>Batch Saveees command, the title on the image tab or image window
will be modified according to the file name paradigm defined in the Batch Save dialog. b) The File>Batch
Saveees command will perform no saving operation if the file is not modified or unchanged.

5.8 External Application (F7)

The External Application will allow the opened images or pre-processed images to be opened directly by
the 3rd party software. Some standard program has this interface, such as Photoshop or Paint. The 3"
party application can be specified at Option>Preferencesess property sheet, Misc page in the External
Application item. The External Application command will be enabled only when the application is
specified in the External Application item. See Sec.15.1.8.11 for details.

If the image is modified, newly captured or Pasted as New

File created, choosing External Application command will |~ x
pop up a Rename dialog and asked to save it first.
. . . . [J o't show the rename dialog later
After the image is saved, then it will be opened by the
External Application for further processing. Cencel

5.9 Paste as New File

The File>Paste as New File command will be enabled only when there is valid image data on the clipboard
first (see the Edit>Copy and Edit>Deep Copy commands). If there is no image data on the clipboard, the
File>Paste as New File menu will be disabled.

Choose File>Paste as New File command to paste the contents of the clipboard image into a new active
image window.

The new image type will be the same as that of the original image. The App will accept image data from
the other application via the clipboard as long as it is in BMP/Windows Bitmap (DIB) format.

Note: The App will assign a number to the File>Paste as New File command created window title bar.
5.10 Microsoft Word Reporteee (F10)

The File>Microsoft Word Reportee« function is designed to export the images and other useful information
to a Word file according to the template format.

The report template is a Word format file that contains different type of placeholders and it uses placeholder
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to represent the content to be replaced.

Now 3 different type of placeholders are supported, which are Time Placeholder, Image Placeholder and
Measurement Table Placeholder respectively.

Time Placeholder: {{YYYY}H{mm}H{DD}H{HH}}H{{MM}}H{SS}} are time placeholder that
represent Year, Month, Day, Hour, Minute and Second respectively; User does not need to set the content
for time placeholder because it will set to system by software automatically;

Image Placeholder: {{IP}} is the Image Placeholder. The image in this template whose title item of
alternative text property is {{IP}} will be regarded as the image placeholder; When users want to export
images to the template, the images must be Opened /Snapped/Pasted as New File; created image windows;

Measurement Table Placeholder: {{MT}} is a table with one row and one column filled with content of the
Measurement Sheet. The properties of the Measurement Table are the same as the placeholder, such as the
border color, the alignment mode and so on. The width of every column is equal to the width of the
placeholder divided by the number of the columns. The height of the Measurement Table is equal to the
height of the placeholder; The Measurement Table Placeholder will be replaced by the measurement
information of the exported images. Users could manage the exported measurement information before
export in the Options>Measurementess command and click Sheet page. Please See Sec.15.2.4 for details;

When the Microsoft Word Report is generated, different placeholder in the template will be replaced by
corresponding content from the App. Users could define their own template and rearrange the placeholders
in their own template according to their requirement. Choosing Options> Preferencesees, clicking Report
page to Edit, Clone, Delete or Reset the Report Template. See Sec. 15.1.4 for details.

When the template is finished, users could select the content in App to replace the placeholders in template.

You can export the Word Report on the image window (Only the active image can be export in this mode)
/Browse window/Thumbnail window. The rear two methods are strongly recommended to generate the
Word Report;

The basic steps is described below:

1. Choose View>Thumbnail command or press the 85 button on the toolbar/Choose View>Browse

command or press the @ button on the toolbar to active the Thumbnail/Browse window;

2. Select the images you want to export in Thumbnail/Browser window and choose File> Microsoft Word
Reportees command to generate. The replacement of multiple pictures in template will depend on the image
selection order in the Thumbnail /Browser Ul.

Log o Imaging-Solution

Image-Analysis-Report.

Author: _—+» =~ Title:» - - i - - - v

Sample-Name:» -  sampleType:> - |

Date:-2018-12-23-20:36:30+

4 14-2008-largejpg 2006-7-large.jpg 2006-hm-36-large.jpg 2006-hm-42-large.jpg Thumbnail <—

File | Edit View Browse Setup Captu
(5 OpenImage.. Ctrl+0

! |[Fl Open Video...
Open Broadcast...

[ External Application 7

Paste as New File

[}i} Microsoft Word Report... F10
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| Image selection for the Microsoft Word Report in the Thumbnail window | Microsoft Word Report of the selected images |

5.11 Print Setupeee

Choose File>Print Setupess command to access the setup panel for the printer that has been selected. The
App will present the standard setup panel for the particular printer (this is the same panel one would receive
if one was setting up the printer from the All Settings>Device>Printer). Change printer's setup to satisfy the
requirements, click OK button to return.

5.12 Print Previewseee Ctrl+Shift+P

Choose File>Print Previewsss command to see the real-time effect of the printer without actually printing it
out.

5.13 Printese v Ctrl+P

Choose File>Printess command to print one or more copies of the current image to the selected output
device. The File>Printees command lets one take full advantage of the printer's capabilities. If the printer
has built-in half-toning or color dithering capabilities, use them or instruct the App to perform these
processes before sending the image to the device.

The File>Printeee command also has facilities that let one adjust the size and position of the image on the
printed page.

5.14 Twain: Select Deviceeee

Twain is a cross-platform interface for acquiring images captured by certain scanners, digital cameras, or

frame grabbers. The manufacturer of the Twain Device must provide a Source Manager and Twain Data
Source to work with the App.

Select the active device for the Twain: Acquirees* menu from all devices available in the device combobox
which are enumerated by the App.

One must install the Twain Device hardware and its driver first.
Please read the documents provided by the device manufacturer
for the installation instructions.

Select Source X

Sources:

Before begin to start the Twain: Acquire at the 1% time with the
App, choosing File>Twain: Select Devicesee command will Corce

invoke a Select Source dialog as shown on the right side.

Source: Choose the right device from the Source window (Highlighted);

Select: Click the Select button to select the device. User does not need to repeat this step for subsequent
choosing of the Twain: Acquireses command.

Note: All of the provided cameras are integrated into single Source called Twain Camera. This will greatly
reduce the listed item and easy to choose for the user.

5.15 Twain: Acquirgees

There are basically two techniques used to capture the video images from video devices such as a PC
camera, digital camera, and scanner. They are the Twain: Acquireeee technique and the DirectShow
technique (previously called VFW).

The most obvious characteristics of the Twain technique is that it previews the video in smaller resolution
but captures the image with higher resolution. Most of the cameras we provided support all of these two
video preview techniques.

Here we illustrate how to capture the image using yyyyyy(6M pixels, USB3.0) camera as an example.
1. Install the camera Twain driver provide by the supplier (for example driver for yyyyyy hardware);
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2. Install the App;
3. Plug the cameras yyyyyy (USB3.0) into the computer USB port;
4. Start the App;

5. Choose File>Twain: Select Deviceess command to select the device from the Select Source dialog (If
never selected before);

6. Choose File>Twain: Acquiresss command and there should be a dialog box like below:

|

Settngs...

Full Screen

3072* 2048
Sn2p:
3072* 2048
[resper
[CInegative

In this dialog, the Video Source Property can be set by clicking Settinge«* button and this will pop up a
Settings property sheet as shown below. The Settingsee* property sheet has many property pages which are
defined by the camera supplier. Please contact with your camera vendor for details.

Snap: Click the Snap button to snap an image. This

will create a new window and its title bar will be

assigned a digital number as the image window = ®ses Rt cdor tistogram Misc  Parameters
Exposure

name;

Auto Exposure Defaults
Full Screen: Click Full Screen will give user a Target: | 120
total-screen view of video. Press ESC to cancel — S
the full screen view;

Gain: 5.00

Live or Snap: The video Resolution can be chosen
in the Live list box and the captured image
Resolution in the Snap list box;

RGB/BGR: Check the RGB/BGR box to ensure
the correct color encoding format compatible with
your camera;

Negative: Negative will reverse the pixel values
of the active video without going through the
lookup table.

OK Cancel

Click x on the window’s upright corner to close the Twain: Acquire dialog.
5.16 Recent Files

The App maintains 4 (Default) most recently opened document files under the Recent Files menu.
Choosing one of these submenus will reopen that file immediately.
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Note. a) The maximum number of Recent Files can be modified by choosing Options>Preferenceseee
command and clicking the Misc page, locating the Privacy item (See Sec.15.1.8.18 for details). Here,
clicking the 4 (default) edit box will allow user to enter the number of the Recent Files submenus wanted.
The value ranges from 0 to 8;

b) One can also check the Clear the Recent Files when exit the application to clear the Recent Files after
exit the App application (See Sec.15.1.8.18 for details).

5.17 Exit

Choosing File>Exit command will close video window, all of the image windows and Browse/Thumbnail
window. After all of the windows are closed, the App will end itself.

Note: If an image has been modified before attempting to Exit, the App will first issue a warning dialog
to ask if user want to save the image or not.

Save Files >
App % File has been modified. Do you want to save changes?
o Image has been modified. Do you want to save changes?
Yes No Cancel
v N c | Yes to Al No to Al Batch Save
es o ance

If multiple images have been modified before attempting to Exit, the App will issue Save Files dialog to
direct the user to save changes in different ways.

See Sec.16.2 Window>Close All for details.
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6 Edit

6.1 Cut ® Ctrl+X

The Edit>Cut command will be enabled only when a) an Object or Objects on the Layer over the image is
or are selected; b) an image or images in the Browse window is or are selected.

Check the Measurements>Object Select X (Sec.14.1) and Edit>Select All menu (Sec.6.7) to find how to
select Layer Objects for the Edit>Cut command.

Choose Edit>Cut command to a) copy the selected Objects to the clipboard and b) delete the selected
Objects on the image window. Any data already exists on the clipboard will be replaced.

The Objects copied to the clipboard can be pasted into the active window or into another opened
image/video window on the layer overlaid on the image using the Edit>Paste command (when there is no
Layer overlaid on the Background Layer).

When the Browse window is active and the image files in the Browse window are selected, the Edit>Cut
command will be enabled. Choosing Edit>Cut command will delete the selected files and copy them to the
clipboard.

Note: The Edit>Cut command does not support Background Layer (image) Cut operation.

6.2 Copy 2 Cctrl+C

Choose Edit>Copy command to Copy a)the highlighted Objects (on the Measurement Layer); b) an image's
selected area on the Background Layer; c)The selected files in the Browse window to the clipboard.

Note: When a) the Object(s) is (are) highlighted; b) the Current Layer is the Background Layer and an
image ROI is selected or c¢) The files in the Browse window are selected, the Edit>Copy menu will be
enabled. Check the differences of Edit>Copy and Edit>Deep Copy commands

1. Select the image area using the Edit>Image Select L1 command/Edit>Select All/Ctrl+A. The
Edit>Copy menu will be enabled;

2. Choose Edit>Copy command to copy the selected image area to the clipboard.

1. For the Layer operation, see the View>Sidebar>Layer menu in Sec.7.4.5 and the Layer menu in Sec.13
for details;

2. For the Measurement operation, see the View>Sidebar>Measurement menu in Sec.7.4.6 and the
Measurements menu in Sec.14;

3. After the Measurement operations have been done, choose Measurements>Object Select command or
press the Object Select button X on the toolbar, the cursor will change to X inthe image/video window;

4. Move the mouse until the cursor becomes@, this means the cursor is right on the Object. Clicking it
will highlight the Object and the Object will be selected;

5. Option 1: Continue to move the mouse until the cursor becomesha again, this means the cursor is right
on another Object again. Clicking it with Ctrl+left mouse button and the second Object will be selected and
highlighted,;

6. Option 2: a) Move the cursor over the image, click down the left mouse button; b) Drag the mouse to
draw a rectangle on the image. A dotted rectangle will appear around the selected area; c) Release the
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mouse and all of the Objects within the dotted rectangle will be highlighted and selected,;
7. Option 3: Ctrl+A/Select All to select all the Objects on the Current Layer;
8. After the Objects are selected, the Edit>Copy menu will be enabled;

9. Choose Edit>Copy to Copy the Object(s) to the clipboard. Then the
Edit>Paste menu will be enabled. One can then Paste the objects onto the
Current Layer or onto the other Measurement Layer in the same image/video
window. If one switches to the Background Layer, the Edit>Paste menu will
be disabled, but if one returns to the Measurement Layer again, the
Edit>Paste menu will be enabled again.

When the Browse window is active and the image files in the browse window are selected, the Edit>Copy
command will be enabled. Choosing Edit>Copy command will copy the image files to the clipboard. After
the Edit>Copy command, the Edit>Paste and the Edit>Paste Shortcut menus will be enabled.

1. The copied Object(s) can be pasted into the active window or into another opened window using the
Edit>Paste command as long as the current window is not on the Background Layer (the Edit>Paste menu
will be disabled if the Background Layer is active). See the View>Sidebar>Layer command in Sec.7.4.5
and the Layer menu in Sec.13 for details;

2. The copied files on the clipboard can be pasted into the Browse window by choosing Edit>Paste
command.

Note: a) The Edit>Copy command will not delete the Objects over the image. Any data existing on the
clipboard will be replaced with the new data;

b) Click the icon/Ctrl+left mouse button/Shift+left mouse button/Draw a rectangle/Ctrl+A/Edit>Select
All on the Browse window to select file(s).

6.3 Paste be Ctrl+Vv

If &) there is (are) Object(s) on the clipboard and the Current Layer is not the Background Layer, or b) there
is (are) image file(s) on the clipboard and the current active window is Browse window, the Edit>Paste
menu will be enabled.

Choose Edit>Paste command to Paste Objects from the clipboard onto the active image's Measurement
Layer. One can also choose Edit>Paste command to transfer a layer's Objects from one image/video
window's Measurement Layer to another or current image/video window's Measurement Layer.

When the Browse window is active and there are the image files in the clipboard, the Edit>Paste
command will be enabled. Choosing Edit>Paste command will paste the clipboard files to the Browse
window.

Note: The Edit>Paste command does not support the image area Paste operation.
6.4 Paste Shortcut

This command is for Browse window only. This menu will be | *= .
enabled when the files in the Browse window are selected and the
Edit>Copy command is executed to copy the file shortcut to the
clipboard. Choosing this command will create the selected files
Shortcut (in *.Ink format) in the Browse window. = o

This folder already contains a shortcut named
"14th2006exlarge,jpg.Ink”.
Cverwrite, Cancel, or Abort?

Cancel

If the to be pasted *.Ink file has been existed in the current Browse window, the App will pop up a prompt
dialog as shown on the above right side.

35



Edit

One can click Yes, No or Cancel to Overwrite, Cancel or Abort the command.

6.5 Delete X Delete

The Edit>Delete menu will be enabled if a) the file(s) is (are) highlighted in the Browse/Thumbnail
window, b) the Object(s) on the image/video window are selected. This command is for
Browse/Thumbnail /image/video window only.

User can Delete or remove one or more files from the Browse window. The steps are as follows:
6.5.1 For Browse/Thumbnail window file delete

1. Select one or more files by a) Clicking the displayed file icons, a single file will be highlighted; b)
Clicking the file one by one with Ctrl + left mouse button, all of the clicked files will be highlighted; c)
Clicking the displayed file icons, the first clicked file will be highlighted, clicking the end file with Shift
+ left mouse button, all of the files among the first and last will be highlighted. d) Dragging the mouse to
draw a dotted line rectangle across the files you wish to delete, all of the files in the rectangle will be
highlighted; e)Ctrl+A /Edit>Select All to select all files in the Browse/Thumbnail window;

2. a) Press the Delete key or choose Edit>Delete | oeetrie %
command to delete the selected files; b) Click the right Pr T T S M TR T

mouse button to bring up a context menu, choose Delete % 201404201755 21 pg

command to delete the highlighted files. A confirm ' L s

Delete File dialog will bring up as shown on the right

side. Yes No

In the confirm Delete File dialog, click Yes to move the files to the desktop recycle bin, or No to cancel the
Delete operation.

6.5.2 For image/video window Object(s) delete

If the Objects on the image/video are selected, choosing Edit>Delete command or pressing Delete button
will remove the Objects from the image/video window.

6.6 Image Select Lt

The Edit>Image Select command can be used to mark ROI and Copy the selected ROI to the clipboard.
This command is only used to select the ROI on the Background Layer.

Choosing Edit>Image Select command will check this menu and the cursor will turn into +. The ROI
selection steps are described as below:

1. After the Edit>Image Select command is chosen, the Background Layer will be checked automatically
regardless of if the other Layer is checked or not;

2. Drag the mouse cursor across the image with the left button held down until the area is selected;

3. Release the left button and the area will be marked. Handles will appear on the area that will allow
altering the selection after it is marked;

4. CtrlI+A/Edit>Select All will select all the image area.

Layer - 1 B
RS |
Visible Current  Name

Background

O [Mo Mame]

6.7 Select All Ctrl+A
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When the image/video window is active and the Background Layer is checked, choosing Edit>Select All
command will select all pixels on the Background Layer within the canvas (shortcut: Ctrl+A).

When the image/video window is active and the Background Layer is not checked, choosing Edit>Select
All command will select all of the Objects on the Current Layer (shortcut: Ctrl+A).

When the Browse/Thumbnail window is active, choosing Edit>Select All command will select all of the
files or icons in the Browse/Thumbnail window.

6.8 Select None Ctrl+D

Deselect a) any selected area (ROI) on the image; b) the Objects on a Layer; c) the file listed in the
Browse/Thumbnail window.

When the Current Layer is the Background Layer and an image area is selected, the Select None menu will
be enabled. Choosing Edit>Select None command will delete the dotted rectangle representing the selected
area (ROI).

When the Current Layer is not the Background Layer and the Objects are selected, the Edit>Select None
command will be enabled. Choosing Edit>Select None command will deselect all of the selected Objects.

When the Browse/Thumbnail window is active and the image files in the browse window are selected, the
Edit>Select None command will be enabled. Choosing Edit>Select None command will deselect all of the
selected files in the Browse/Thumbnail window.

Note: See Edit>Image Select, Edit>Select All and Measurements>Object Select X commands to
understand how to perform select operations.

6.9 Deep Copy E Ctrl+z

The Edit>Deep Copy function, which will allow the image and Objects copy to the clipboard and users
can paste to word or other document directly with no need to execute Layer>Merge to Imagesss command
to merge the Layer Objects to the image first.

If there are Objects on the image, Edit>Deep Copy

function will pop up an Export Options dialog as | cponoption x
be I OW Label font default size: 7
Label font size: Used for the Object’s label font size, | === ’ Cancel
the default value is 7(1~28); ' Deas
Label font weight: Normal, Bold or Heavy. The default | ateifontweiont Bod v

is Bold;

Set the Label font size and Label font weight for the Objects over the image and click Ok to finish the Deep
Copy command. The user can use Paste command in other application or File>Paste as New File command
in the App with this Deep Copy data.
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7 View

7.1 Browse L Ctrl+B
7.1.1Open the Browse window

1. Choose View>Browse menu or click the Browse toolbar button“¥ to open or active Browse window
under the specified directory in the Folders Sidebar;

2. Click the Folders Sidebar to activate it and double-clicking the listed directory in the Folders Sidebar
will create the Browse window.

3. After creating the Browse window, the App will display a Browse window that looks like windows
explorer. The child window on the left part of the Browse window called Folders Sidebar is used to locate
the directory on the hard disk. Images in the current directory are displayed in Large Icons or Small Icons
mode on the right side of the Browse window.

4. Image file’s order can be set in Ascending or Descending order according to Sort by Name, Type, Size,
Width or Height et al.

7.1.2 Browse window right mouse button context menu

Clicking the right mouse button on the listed Icon in the Browse window will bring up a right mouse
button context menu as shown below:

Open

Cut Ctrl=X

Copy Ctrl=C

-y Paste Ctrl=V

Paste Shortcut

s
\\!!g
]

Delete Delete [ X

iy
g
o 5
e v Sort by Name

Sort N oua
Icons f’== Large Icons

Sort by Type
Sort by Size
Sort by Width

Properties... g Sort by Height
. Stitch... Shift=T g B8 &1 Ascending
| =y L Z i
i High Dynamic Range (HDR)... &i Al Descending

Color Composite.., -larg...  2010-hm-56-larg...  2010-hm-6-large.... 2!

[2] Refresh £ | 25 Smallicons

o

< EDF.. Shift+F
These context menu functions are described in

Browse>Delete File

Browse >Sort>Sort by Names
Browse >Sort>Sort by Type
Browse >Sort>Sort by Size
Browse >Sort>Sort by Width
Browse >Sort>Sort by Height
Browse >Sort>Forward
Browse >Sort>Reverse
Browse >Icon>Large Icons
Browse >lcon>Small Icons
Browse >Refresh

Browse >Properties

menus. See Sec.8 for details.
The other command can be found in the Process menu in Sec.12.

Note: The Folders Sidebar and the Browse window can be used to perform tasks such as creating new
folders, renaming, moving, and deleting files. Individual file information and import data from digital
cameras can also be displayed. Double-clicking the left mouse button on the icon will open the image as an
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active image in full size. See Image window GUI in Sec.2 for more details.
o+
7.2 Thumbnail o (Ctl+T)

Folders is a browser to Browse all the image files on disk. It is also an important platform where users can
perform file operations easily, such as Stitch, HDR, Color Composition, and EDF ital. But user cannot find
a temporary file in the Folders which has just captured from the camera and has not been saved to the disk.
The Browse window is shown below:

4 Browse Thumbnail 1.jpg 0006*

Thumbnail is also a browser that could manage all the opened files, including the opened files on the disk
and the captured image from the camera/Edit>Paste as New File created window image. Many convenient
operations can be done in Thumbnail browser, besides the operations on the opened files on disk (Stitch,
HDR, Color Composition, EDFee¢), quick save and batch save could also be done for temporary files.
Selection of multiple images exported to Microsoft Word Report can only be done in Thumbnail/Browse
window (See Sec.5.10 for details).

a4 Browse  Thumbnail 1jpg  0006°
i Quick Save... Ctrl+Q
Batch Save...
Close
Close Others
. Delete Delete
Tipg
File Properties...
Copy Full Path
& Browse Containing Folder
Open Containing Folder
Stitch... Shift+T
High Dynamic Range (HDR)...
f| Color Composite...
EDF... Shift+F
App - a X
File Edit View Browse Setup Capture Image Process Layer Measurements Options Window Help
i E @ 8| Piel v Mrx M@k s- 2% 1L-000-@P-NTEzA| @
Measurement vl « 2004-hm-14-large.jpg™ BLi
£ Appearance |0 | 100 | 200 | 300 | 400 | 500 | 600 | 700 | 800
Name ey
Label Type Length
Line Width 7
Line Color W ££o0000
Line Styl. s
Arrowl =
=
Arrow? S
Calculation
Start (478, 322)
End (621, 310) =
Length 145.50 S
Slope 0.08
Angle 4.73
Coordinat: —
Start. X 476 S
Start.Y 322 <
End X 621
End Y 30
=1
=
8
=
Measurement Sheet o g
)| Index  Name Center Diameter Area Length Angle Start End
= o 721.87
=2 P 49.37,52.35 83.02
)3 U (54850, 316.00) 145.50 473 (621.00, 310.00) (476.00, 322
=y
0}
@) Cam...| g Fold... @ Und... | Zlayer [oMea..| &)< R
D:\Testimage\Sample\2004-hm-14-large.jpg 700 x 504 & Zoom: 70% & Pixel
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Choosing View>Measurement Sheet or clicking Measurement Sheet title under the Sidebar will active
Measurement Sheet. The Measurement Sheet shows the Object's possible features, such as Name, Center,
Diameter, Area, Length, Angle, Start Point, and End Point ital. overlaid on Background Layer.

On the left of the Measurement Sheet, there is a toolbar with 5 buttons called Export to Html = , Export to

Excel = , Exportto CSV =Y , Append to CSVE4 Rest“" Auto Highlight © and Setting &. Their main
functions are explained as follows:

1_-s’|
Export all the Layer Objects to the *.html file in a tabbed format.

Layer
Name

Layerl 1 (124.86, 239.18) 218.54 37509.04 | 686.55
1 (578.19, 249.50) 205.15 33055.73 644.51

Index | Name Center Diameter Area Length Angle Start End Distance

Layer2

(579.00, [ (122.00,
252.00) 241.00)

Length Unit:Pixel, Angle Unit:Pi

(350.50, 246.50) 457.13 178.62

&

Export the Current Layer Objects to the *.xlsx file in a tabbed format.
Note: This menu will be enabled only when there are Objects overlaid on the Background Layer
(image/video).

=,

Export Current Layer Objects to the *.csv file in a tabbed format which can be opened by Excel.

Note: This menu will be enabled only when there are Objects overlaid on the Background Layer
(image/video). User could check Options>Preference... Misc page, File Format item’s Using UTF8
charset in CSV to prevent the messy code in the CSV file (See Sec.15.1.8.5).

Sy
Append Current Layer Objects to the *.csv file in a tabbed format which can be opened by Excel. If it is the

first time or the Reset = button is clicked, all the operation is just the same as Export to CSV =

command. After that, Append to CSV =4 will append the Current Layer Objects’ sheet parameters to the
CSV file automatically. This command is commonly used for those who wish to post process the
Measurement results on different image or on the video.

Note: This menu will be enabled only when there are Objects overlaid on the Background Layer
(image/video). User could check Options>Preference... Misc page, File Format item’s Using UTF8
charset in CSV to prevent the messy code in the CSV file (See Sec.15.1.8.5).

Begin a new Append to CSV 4 command;

Note: This menu will be enabled only when Append to CSV 24 command is excuted..
®

When the Auto Highlight button is pressed down, clicking the item in the Measurement Sheet will highlight
the corresponding Object overlaid on the Background Layer (image/video window).

o
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Click the Setting button will pop up a Measurement property sheet located at Object page. Detailed
information can be found in Options>Measurementsee command’s Objects page (See Sec.15.2.5 for
details).

7.4  Sidebar

There are 5 Sidebars in the App frame window in tabbed style. They are Camera Sidebar, Folders Sidebar,
Undo/Redo Sidebar, Layer Sidebar and Measurement Sidebar.

BA BB BC BD BE BF CACBCCCDCE DA DB DC DD DE DF

3%7 st WS

AA: Camera Sidebar;
AB: Camera Sidebar groups for the control of the camera.

BA: Folders Sidebar;

BB: Back to the previous folder;

BC: Forward to the next folder;

BD: Browsing the pictures under the application’s file directory;

BE: Open the Browse window if it is not opened (Double-clicking on the selected directory will perform the
same functions.);

BF: Folders to locate the Browse window’s file directory.

CA: Undo/Redo Sidebar;

CB: Forward to the previous step;

CC: Backward to the next step;

CD: Operation Copy: Copy the highlighted operation in the Undo/Redo Sidebar to a new image window;
User can also drag the selected operation in the Undo/Redo Sidebar to the window area to create a new
image window;

CE: Remove the highlighted operations from the Undo/Redo list (This button will be enabled only when
the operation(s) is (are) selected, the opened image(the first operation) cannot be removed,;

CF: Indicating the Current operation displayed in the image window;

CG: Operation Index;

CH: Operation name.

DA: Layer Sidebar;

DB: Make a New layer;

DC: Remove a layer;

DD: Set as the Current layer;

DE: Show/Hide a layer;

DF: Rename a layer;

DG: Visibility control of the layer items;

DH: The Current active layer for operations;

DI: The layer Name. The image layer is always named as Background.

EA: Measurement Sidebar;
EB: The Appearance of the highlighted Object on the Current layer; you can edit the Appearance by
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clicking its item and editing it;

EC: The Calculation of the highlighted item on the Current layer;

ED: The Coordinate of the highlighted item on the Current layer; you can edit the Coordinate by clicking
the item.

The Camera Sidebar is mainly used for the control of the camera, it includes many groups. Each group can
be expanded by clicking the group name or the arrow button at the right of the group name.

Checking the Sidebar>Camera menu will show/hide it on sidebar group.
Please check Camera Sidebar in Sec.4 for details.

The Folders Sidebar is mainly used for the image Browse control.

Checking the View >Sidebar>Folders menu will show/hide the Folders Sidebar. Clicking its tree can
navigate the file directories.

Double-clicking the directory in the Folders will create the Browse window. If there are image files under
the directory that the App supports to Browse, the image files will be displayed in Large or Small icons
mode.

Their orders can be set in Ascending or Descending styles according to Sort by Name, Type, Size, Width
or Height et al.

Clicking the right mouse button on the directory will bring up the right mouse context menu as shown
below:

Folders x| 8  Stop sharing
o 8| = DELTAOPTICAL
hs Music = UpdatusUser
&3 Photo 2 Specific people...
2 SW
=}, TestImage / Open
Composite Pt Stan Documents
i EDOF / : 4. Music
=R £00F 01 ST ’ S Pictures
E EDOF_02 Include in library » B videos
& EDOF_03 Send to E
i |, EDOF_04 | Create new library
#- | EDOF_05 E“‘
1 opy
T EDOE06 { Compressed (zipped) folder
- J, EDOF_07 Create shortcut
{‘; EDOF 08 Delete B Desktop (create shortcut)
i ). EDOF_09 = % Documents
4 ). EDOF_10 SIS & Faxrecipient
f“ EDOF_11 _J Mail recipient
i EDOF12 % MaximDL5
£ EDOF_13 Qs
- ). EDOF_14 kype
4} EDOF_15 v & DVD RW Drive (E)

Folders directory right mouse button context menu

This is the basic window explorer menu and will not be explained further in this manual.

The Undo/Redo Sidebar is used to list the Undo/Redo operations for the Image and Process menus’
command.

Checking the View>Sidebar>Undo/Redo menu will show/hide the Undo/Redo Sidebar.

The Layer Sidebar is used for the management of Layer operations. These operations include making a
New Layer, Removing a Layer or Renaming a Layer and Layer visibility controlling et al.

Checking View>Sidebar>Layer will show/hide the Layer Sidebar. See Sec.13 for detail.
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The Measurement Sidebar is used to check, set or edit the selected Object on the Layer.
Checking View>Sidebar>Measurement will activate/show the Measurement Sidebar.

In this Sidebar, the Object Appearance, Calculation and Coordinates characteristic are listed. The
Appearance and Coordinates can be edited. See Sec.14 for detail.

7.5 Grid
The Grid menu has 5 submenus, they are:

Choosing View>Grid>Settingees command, or choosing Option> Preference>+es command and clicking
the Grids page to realize the same function.

The Grids page can set the Line Style, Line Color, Preset Management for the Grid overlaid on the
image/video window (See Sec.15.1.5 for detail).

Choosing this command will remove both the Manual Grids and the Auto Grids overlaid on the
image/video window.

Choose Grids>Auto Grids command to overlay the Grids on the image/video automatically.
The Auto Grids can be set in the View>Grids>Settingess menu.

Choosing this command will display two small Right and Down Arrows overlaid on the top of the Vertical
Ruler and on the left of the Horizontal Ruler as shown below:

Down Arrow: Move the mouse over the Down Arrow will show a horizontal drag icon. Drag the Down
Arrow along the Horizontal Ruler to where ever you want. When it is dragging over the image/video,
there will be a Vertical line appeared to let you judge where to release this line on the image/video. User
can drag any lines to overlay them on the image/video. The overlaid lines can be adjusted by dragging the
specific Down Arrow again on Horizontal Ruler.

Right Arrow: Move the mouse over the Right Arrow will show a vertical drag icon. Drag the Right Arrow
along the Horizontal Ruler to where ever you want. When it is dragging over the image/video, there will
be a Horizontal line appeared to let you judge where to release this line on the image/video. You can drag
any lines to overlay them on the image/video window.

4 2008-hm-20-large.jpg P X |4 2008-hm-20-largejpg b X
l\ [0, ]2y, [200  [300  [400 [|500 ,[600 . [700 |80 1 [0 |10, [J200 |300 |40 500 ; [600 . |700 |80l

1 Right arrow or
down arrow for
Manual Grids

o z
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The overlaid lines can be adjusted by dragging the specific Right Arrow again on the Vertical Ruler.
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Choose Grids>No Grid command to remove the Manual Grids overlaid on the image/video window. The
menu will be checked.
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Choose Grids>Manual Grids command again (If it is unchecked) to display all the previous Manual Grids
overlaid on the image/video window. The menu will be checked.

Choosing Grids>Remove All Grids will Remove (Delete) all of the Manual Grids or Auto Grids overlaid
on the image/video window.

The Manual grids could be saved into Preset items for later use. Please follow the following steps:
1. Right click the mouse in the upright region in the image/video window as shown below:

q Videc

Tﬁ

2. Select the right mouse context menu’s Grids>Manual Grids;

Length Unit  »

Angle Unit...

Grids. » No Grids
i Settings.. Auto Grids

v |Manual Grids

Remove All Grids

Add Preset...

1 Preset Management...

3. Drag the blue arrow to image/video window (vertically or horizontally) to set the position of Grids;

~

4. Choose Add Preset command and input the name to add the current Grids to the Preset list or submenu;

Length Unit b i
EEeT _
Grids » No Grids

Auto Grids Mame X
+  Manual Grids

H# Settings...

| MyPresetGrid1

Remove All Grids

Add Preset...
conce

Preset Management...

5. Users could select the Preset Grids in the right mouse context menu item under Preset;
4+

Length Unit 4
Angle Unit...

Grids b Settings...

Mo Grids

Aute Grids
v Manual Grids
== Divide...
i Remove All Grids

Add Preset...

Preset Management...
Preset 3 MyPresetGrid]
MyPresetGrid2

To manage the saved Preset items, such as Rename, Remove, Up, Down, Import or Export, choose
View>Grids>Preset Management command and a dialog called Management will pop up:

9]
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4 4th2007exlarge.jpg ‘LManagement X
‘ 0

-‘k Length Unit 4 Index  Name Rename. .

1 MyPresetGrid1
2 MyPresetGrid2 Remove

Angle Unit...

Grids »| i Settings...

No Grids
Auto Grids

¥ Manual Grids

0ol |

00z

== Divide... Import...

i Remove All Grids
Add Preset... /
Preset Management...

Preset 3

Export...

00 |

Cancel

=]

MyPresetGrid1
MyPresetGrid2

00|

The Rename, Remove, Up and Down will be enabled only when the item is selected. If the Preset item order
is changed or the item is deleted, the submenu under the View>Preset will also be modified. The Preset
items can Export to or Import from a file in the View>Grid>Preset Managementees menu.

If there are items in the Preset Management, the —
items will be added to View>Grids>Preset ;E”glthu“_"t“ ’
submenu and user can load the Presetted Manual —

. . . . . Grids b HE Settings...
Grids directly by simply clicking the submenu. ) G_gd
User can also right clicking the mouse button on § ’;““Gl”zﬁd
the image/video window at up left corner and a = Divide..
content menu will pop up as shown on the right 4 Remove All Grids
side Add Preset...

. Preset Management...

Choose the right one under the Preset menu to load .
. _ Preset 3 MyPresetGrid1
It. C' MyPresetGrid2 |

7.6 BestFit Num *

Choose View>Best Fit command to automatically resize the image/video to fit in the window.

Note: Choosing this command will enable View>Actual Size menu.

7.7 Actual Size Num /

Choose View>Actual Size command to set the active image to its Actual Size (e.g. 100%).

Note: This option will be disabled if the image is currently viewed at 100%. At any other Zoom ratio,
View>Actual Size will be enabled.

7.8 Full Screen

Choosing View>Full Screen command will display the video window in full screen style. It should be
noted that this command is only for video window.

7.9 Pipette o

Pipette is used for the display image pixel color (RGB) values. Choosing View>Pipette and move mouse
over the image, the image RGB values will be shown on the Status Bar for reference.
710 Track

If the image/video's actual size is larger than the image/video’s window size, choose this command to
position the image/video that does not fit entirely within in the image/video window. Its function is similar
to the scroll bars. It is an alternative to using the arrows on the scroll bars for positioning the image/video
within the window.
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Choosing the View>Track menu or pressingw button on the toolbar will change the cursor o and the
button on the toolbar will be checked.

Then keep down the left mouse button to drag the region of interest on the image/video to any position
wanted.

Note: If the image/video size is smaller than the window size. The Track operation will be disabled.
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8 Browse
8.1 Sort

This command is for the Browse window only.
Sort the image files in order of names in the Browse window.

This command is for the Browse window only.
Sort the image files in order of file type in the Browse window.

This command is for the Browse window only.
Sort the image files in order of file size in the Browse window.

This command is for the Browse window only.
Sort the image files in order of image file width in the Browse window.

This command is for the Browse window only.

Sort the image files in order of image file height in the Browse window.
24

This command is for the Browse window only.

Sort the image files in order of the Ascending mode (i.e. 1, 2, 3 and 4) in the Browse window.
it

This command is for the Browse window only.

Sort the image files in order of the Descending mode (i.e. 4, 3, 2 and 1) in the Browse window.

The Sort settings are saved until they are changed. For example, if you sort images in the Browse window
according to the Type, the images will remain sorted according to Type until the Sort settings are changed.

8.2 lcon

This command is for the Browse window only.

The Thumbnail mode displays small preview images; you can select different view modes in the Browse
window.
Choosing Icons>Large Icons will display the image files in Large Icon mode in the Browse window.

This command is for the Browse window only.

The Thumbnail mode displays small preview images; you can select different view modes in the Browse
window.

Choosing Icons>Small Icons will display the image files in Small Icon mode in the Browse window.

8.3 Refresh 2] F5
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This command is for the Browse window only.

If the files under the Folders Sidebar’s directory are altered outside of the App, after switch back to the App,
one can Refresh the image files in the current directory to update the Thumbnails with Browse>Refresh
command.

8.4 Propertieseee

If an image file listed in the Browse window is highlighted. Choosing Browse>Properties command or
clicking the selected file in the Browse window with the right mouse button, a right mouse button context
menus will pop up, clicking context menu's Properties command will bring up a Properties sheet with 4
Properties pages. They are General, Security, Details and Previous Versions pages. These Property pages
may depend on the operating system and it will not be discussed in this help manual.
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9 Setup

9.1 Start/Pause Pause

If the video in video window is playing, one can choose Setup>Start/Pause command to pause the video
and choose Setup>Start/Pause command again to start the video continuously.

9.2 Video Overlayeee
9.2.1Video Overlay>Overlayeee
Choosing Setup>Video Overlaysss command

will invoke a Video Overlay property sheet. |- 8
Clicking the Overlay page on the Video 0 e Background:
Overlay property sheet can set Scale, | "™ | ™= Fon e
Magnification, Date Time and Clarity Factor to e o

. . Show [ show magnification
overlay them on the video window. .
The Position, Background, Font Size, Font o [ Tefault
Weight of the Scale, Magnification, Date Time, bete-Time
and Clarity Factor can be defined in this page. e [None |
Their Size, Type and Colors can be defined oo [ Tefanlt 7]
separately. Gty Factor
Clicking OK button and the Scale, - O S -
Magnification, Date Time, and Clarity Factor
will be overlaid on the Video window. | borly

The Clarity Factor can tell if the sample is in good focused state or not. The larger the Clarity Factor, the
better the sample focused.

Note: To enable the Scale Bar, the Magnificatioﬁ or Resolution mut be deinéd and chosen first in the Unit
combobox on the toolbar. The Unit can be any unit except Pixel. There are two methods to set the Unit,
they are:

a) Choosing Unit in the Unit dropdown list box (l Micrometer(um) [ 40% 100% |) on the toolbar
which is just on the left side of the Magnification dropdown list box;

b) Choosing Option>Measurementess command, a property sheet called Measurement will bring up, click
the Length Unit page and check the Unit in the Current to set the Unit.(See Sec.15.2.2 for details).

9.2.2Video Overlay>Markereee

Choose Setup>Video Overlayses command, this will invoke a Video Overlay property sheet. Click the
Marker page on the Video Overlay property sheet to set the Marker on the video window.

The Video Marker type can be None, Cross, Rectangle, Circle, Cross+Rectangle, or Cross+Circle. The
Video Marker page is shown as below:

49



Setup

Video Overlay

Qverlay

Marker

Color:

X
—|— Type: Cross ~ =
Cross
Rectangl
Cross Width (%) Cross Height (%%) C;cde nge
= Y Cross+Rectangle
100 ud 100 s Cross+Cirde
x Offset (36) y Offset (%)
] . 0 =
Rotate: 0 =
E Default V|
[ Show the graduated scale
Cancel Apply

Choosing Cross+Retangle in the Type list box and Video Overlay> Marker property sheet will change to

the following style:

Video Overlay

Overlay

Marker

Color:

—¢— Type:

Cross+Rectangle ~

Cross Width (%) Cross Height (%%)

[ 5 s

Rectangle Width (%%) Rectangle Height (%)
100 : E s

x Offset (%) y Offset (%)

- T E

Rotate E s

[ ] Default Y]

[ Show the graduated scale

Cancel

Apply

Edit the Cross Width(%) and Cross Height(%), Rectangle Width(%) and Rectangle Height(%), x Offset(%)
and y Offset(%), plus Rotate angle in their specific fields. Click Color to define the Video Marker color.
Check Show the graduated scale will show the graduate scale on the marker.

Click OK to end the Video Marker setup page and a Cross+Rectangle Marker will be overlaid on the video

window as shown below:

200000um
| |

4x
2018-12-24 10:26:30

JllllllllJlA T L

I R

lllIlAIl_IAllIIll

Click Cancel to cancel the Video>Overlay>Marker page setup and return to the application area, or Apply
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to overlay the Marker on the video window and keep the Video Overlay dialog there for further setup.
9.3 Video Watermarkeee

Fig.1 shows a micro ruler. The dark lines can be extracted as Video Watermark and overlaid on the video
window. The steps are as follows:

Snap

1. Choose Capture>Capture Image command or click )
in Fig.1;

to capture the micro ruler image as shown

2. Choose Process>Binaryees command to binarize the image as shown in Fig.2;

3. Choose Image>Adjust>Invert command to invert the image and choose Image>Color Quantizesee
command to convert the image to 24 bits as shown in Fig.3. Choose File>Save Ases command to save the
image in 24 bit BMP format;

o o

Fig.1 Captured Micro Ruler Fig.2 Micro ruler after being binarized

Video Watermark X
Image File:
|:J:\Test Image\Sample\VideoWatermark.bmp 4 |

Cancel
Transparent (3&): 50 L

Tips

Use Shift + Up/DownLeft/Right arrow key to move the watermark.
Use shift + Ctrl + Left/Right arrow key to rotate the watermark.

Fig.3 Inverted 24 bits image Fig.4 Video Watermark setup dialog
4. Choosing Setup>Video Watermarkess command and a dialog called Video Watermark will bring up as

shown in Fig.4. Click the .| button to locate the image saved in step 3. Use the defaults Transparent
(%)(50). If everything is ok, click OK button. The final Video Watermark overlaid on the video window is
shown in Fig.5.

10% 100micton
2012- 04 4,18 18:45:42

hm I

T
™

Fig.5 Video Window with Video Watermark overlaid
9.4 Move Watermark

9.4.1 Move toeee
If there is Watermark overlaid on the video window, this menu will be enabled.
Choosing Setup>Move Watermarkese command will bring up a Move dialog. Where one can enter the X:
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and Y: offset value in their fields for the desired pixel move distances. The default X and Y offsets are 0.

' ‘1 l]X ; 1 ﬁﬁmicron

2012-04-18 18:46:57

9.4.2 Move to zero

If the Watermark on the video window was moved, this menu will be enabled. Choosing this menu will
move the Video Watermark to its original coordinates (0, 0).

9.5 Rotate Watermark
9.5.1 Rotate toeee
If there is Watermark overlaid on the video window, this menu will be enabled.

Choosing Setup>Rotate Watermark>Rotate tos*» command will bring up a Rotate dialog, user can define an
Angle to Rotate the Video Watermark around the video center (0, 0).

1'0xv 100micron
2012-04-18 18:48:01

Rotate

9.5.2 Rotate to zero

If the Video Watermark was rotated, the Rotate to zero menu will be enabled. Choosing this menu will
rotate the Video Watermark to zero degree.

9.6 Gray Calibrationees

This function can make the image brightness to a desired value among various scenarios in a specified
area, achieving the continuity requirement of the observation. The Gray Calibration steps are summarized
as follows:

1. Click the Exposure & Gain group on the Camera Sidebar to expand the Exposure & Gain group,
uncheck the Auto Exposure box (If it is checked) as shown below:

(£ Exposure & Gain E
uto Exposure
Exposure Target: 120
Exposure Time: 10ms
1
Analog Gain: 1.00
1
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2. Choose Setup>Gray Calibrationees command and a dialog called Gray Calibration will be brought up to
display the current ROl Average Gray, there will be a red rectangle called Gray Calibration overlaid on the
video window;

3. This rectangle is adjustable and moveable with mouse. Now the brightness of the microscope or the
Exposure Time on Exposure & Gain group can be adjusted until the Average Gray reaches to the desired
value;

4. Click OK to finish the calibration and return to the application area. The current gray value here is
around 254.9.

Gray Calibration x

Average Gray: |254.9
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10 Capture

10.1 Capture Image ) F8

During the video preview, user can always choose Capture> Capture Image command to capture the video
image.

After the image is captured, the captured image created window will become the current active window,
but the Capture>Capture Image menu is still enabled, user can choose it again to continue the capture
operation.

Note: a) The Snap button & *  on the Camera Sidebar can continuously snap the image even if the
video window is not activated. User can click this button on the Camera Sidebar to capture image in a quick
and continuous style;

b) If the Live and Snap resolutions are different, the App need to switch the resolution from Live to Snap
resolution first to capture an image with Snap resolution. After the Snap is finished, the App will switch
back to the Live resolution to continus the video stream process. This will take more time to capture a
still image;

c) If many images are captured, user can choose Windows>Activate Video Window (F6) to return back to
the video window in a quick way (See Sec.16.1 for details).

d) If RAW in the Format list box is selected on the Capture & Resolution group, the 10bit/12bit/14bit RAW
data will be transferred to 16bits RAW data and saved in DNG or TFT file format. In the RAW Format,
clicking the Snap button will bring up a Save As dialog and ask user directly save the image into DNG or
TFT file directly, no image window will be created.

10.2 Start Time-lapse (Auto Capture)eee L)

Choosing Capture>Start Time-lapse (Auto Capture)see command will bring up Time-lapse (Auto Capture)
dialog as shown below:

Time-lapse (Auto Capture) X
e [ o ]
Base: |D:\Tesﬂmage$ample nCy |

Cancel

Sub: Mone
File:
Mame Format: nnnn {sequence) i
File Prefix: |'I'I' |
File type: ipa (JPEG) s
[+] The sequence starts with: a0

-
Sample: |D: {Testimage\Sample\TTO080.jpg |
Capture Mode
(") Capture every frame
(®) Time slot{second) [ :
Total Images 100

This command can capture a sequence of pictures with the specified time interval; user can precisely set the
Time slot (2 to 3600 seconds) and the Total Images (1 to 9999).

Directory>Base: Enter the driver name and dlrectory where the new image will be saved. User may either
type the path information, or use the Browse button ¥ to locate it from a standard Browse Folder dialog;

Directory>Sub: The sub directory for the Time-Lapse(Auto Capture) under the Base directory. The Sub can
be None, Date(YYYYMMDD) or Year(YYYY)\Month(MM)\ Day(DD). The default is None;

Date(YMMDD)
Year () Month(MM)\Day{DD)

File: The File name including Name Format, File Prefix and File type. It can be a combination of File
Prefix, Name Format and File Type and is shown in the Sample string;
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The sequence starts with: Check this to specify the start number for the Batch Save sequence file number.
Unchecking will always start it with 1;

Sample: The final file name is shown at the right of the Sample label for reference;
Capture Mode>Capture every frame: Select this item will capture every video frame to the specified file;
Capture Mode>Time slot(second): Time slot(second,1-3600S) is a time segment to capture an image;

Total Images: Checking Total Images will enable its edit box. User can enter the Total Images (1-9999) to
be captured. The App will stop the Time-lapse capture automatically when the Total Images are reached;

If Total Images is unchecked, the App will capture the images continuously until user choose
Capture>Stop Time-lapse (Auto capture) command again to stop the Time-lapse capture.

Click OK to begin the Time-lapse capture, or Cancel to cancel the Start Time-lapse(Auto Capture)eee
command.

After the Time-lapse capture is started, the Capture>Start Time-lapse (Auto Capture)sse menu will be
changed to the Capture>Stop Time-lapse (Auto capture) menu. Choosing this command will stop the
Time-lapse capture.

There are a variety of image formats available (they are bmp, jpg, png and tif) to save the captured image.
For example, when choosing jpg format, user can set the parameters of Option to adjust its compression
quality or encoding method. Please check the File>Save Asees menu for details (See Sec.5.5).

10.3 Start Recordeee F9

1. User can a) choose Capture>Start Recordsee command; b) click Record button H on the
Camera Sidebar; ¢) use the shortcut key F9 to start recording video. This will bring up a Video Format and
Encoder dialog as shown below:

Video Format and Encoder X

Please select the video format and encoder
®mp4 (H264)

O mp4 (H265)

) wmy

(O avi (Deprecated)

Tips

Available hardware (GPU) encoders:
1. Intel® Quick Sync Video H.264 Encoder MFT
2. MVIDIA H. 264 Encoder MFT
3. Intel® Hardware H265 Encoder MFT

Hardware (GPU) encoder can reduce CPU usage significantly, but if the resolution exceeds the
GPU's capability, it will be automatically replaced with software encoder.

Finish Cancel

2. The video format can be mp4(H264), mp4(H265), wmv or avi; Click Next to the next step, This will
bring up a Video File dialog as shown below:
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Video File

1. Set the name for the captured video file

[181215204445

| Auto ¥

2. Select the directory for the video file

‘ D:\Test Image\Sample

| Browse...

Tips

The file name extension .wmv or .mp4 or .avi will be appended automatically to the file name.

Auto ¥

Cancel

3. Enter the video file name under 1.Set the name for the captured video file field and click the Browsesee
button under 2. Select the directory for the video file item to locate the video file directory. Click <Back
button to the previous dialog, click Next> button to the next step, this will bring up an Encoder dialog as

shown below:

Encoder

Default Bitrate: 30.5 Mbps
Bitrate: 30.5 Mbps
1
Quiality (1-100): 100 =
Key Frames Spacing: 4 2| Second(s)

Defaults

100%

Cancel

4. Here user can select the Encoder format, set the Bitrate (Default 30.5Mbps, 7.63Mbps-122Mbps),
Quality (Default 100, 1-100) and Key Frames Spacing (4, 1-30). Click <Back to return to the Video File

dialog, or Next> to the Display Information dialog as shown below:

Display Information

Title: |Test |
Author: |‘|'|' |
Copyright: |'|-r |
Description: Just for test|only

Tips
All the display information is optional.

Cancel

4. In this dialog, user can enter Title, Author, Copyright, and Description about the record information ital.
into the edit box. All the information is optional. Click <Back to return to the Encoder dialog, or Next> to
the Start to Record dialog as shown below:
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Start to Record X

[ Time Limit {Second(s)}: &0

Timeapse
[]Frame Mumber: 1

[ Time (Second(s)): 1
Frame Rate: x1 [ |

Slowest: »x1/16 Fastest: =16
Summary

Format: wmv

Width: 3072

Height: 2048

File: D:{Test Image'Sample}181215204445. wmy
Encoder: Windows Media Video 9

Quality: 100%

Bitrate: 122 MbpsKey Frames Spacing (Second(s)): 4

< Back lext > Cancel

5. Here user can check Time Limit(Second(s)) (1-86400) and enter recording time; Input
Time-lapse>Frame Number(1-100) or Time-lapse>Time(Second(s)) (1-600). There is a Summary text to
display what user has been defined. Click Back to return to the Encoder dialog, or Finish to end the setup;

6. After the Video capture is started. The @ == putton on the Camera Sidebar>Capture and
= 1 (Also the Capture>Start Recordese menu will change to Stop

button on the Camera

Record

Sidebar>Capture & Resolution group will become
will be the same);

for the future Record process(The menu

7. User can choose File>Open Videoss command to display the recorded video file in the video window;
this command will be effective only when the camera video window is closed.

10.4 Start Broadcasteee

Start a network broadcasting service. The App will start broadcasting the video that is opened by the App
locally via the specified Port and Encoder. The other users could share the video by File>Open Broadcastes«
command.

Choosing Capture>Start Broadcastees will invoke a Broadcast Parameters dialog as shown below:

Broadcast Parameters x

Port: 2080

[]save the video to file simultaneously

Port: Set the Port for broadcasting;
Save the video to file simultaneously: Check to save the video to file at the same time;

Next>: Clicking the Next> button will invoke an Encoder dialog as shown below:
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Encoder X

Default Bitrate: 30.5 Mbps Defaults

Bitrate: 122 Mbps 400%

Quality (1-100): 100

Key Frames Spacing: 1 +| Second(s)

< Back Cancel

The Encoder dialog is used for the setup of video Encoder parameters for broadcasting. This setup dialog
IS just the same as those of Capture>Start Recorde«+’s Encoder dialog. Here user can set the Bitrate(Default:
30.5Mbps, 7.63Mbps-122Mbps), Quality (Default: 100, 1-100) and Key Frames Spacing (1, 1-30).

<Back: Clicking the <Back button will return to the previous Broadcast Parameters dialog;

Cancel: Clicking the Cancel button will cancel the Start Broadcastess command and return to the video
window;

Finish: Clicking the Finish button will start the broadcasting process and it will end up the process when it
reaches to the Time Limit. After the broadcast begin, the Start Broadcasteee menu will change to Stop
Broadcast menuees. Choosing it will stop the broadcasting process.

See File>Open Broadcaste+ to understand the Start Broadcast function in more detail (Sec.5.3).
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11 Image
11.1 Mode
11.1.1 Color Quantizeee*
The Color Quantizesss command is widely used to change the image bit. The App | colorsis x
supports the mutual transfers among 24 bits, 8 bits, 4 bits or 1 bit images. C;;";“;
When the Color Bits dialog is opened, the default selected Color Bits is the current Opstits i
image's Color Bits. Select the desired bit item and click OK to end the command. Ot
The image will be converted to the selected Color Bits in the image window. O1it

11.1.2 Gray Scale

Choose Gray Scale command to convert a color image (true color image or index color image) to a Gray
Scale image. If the original image is 24 bits, the new image will be 8 bits. Otherwise the bits of the image
will not be modified.

11.1.3 Contrast Preserving Decolorization

Choose Image>mode>Contrast Preserving Decolorization command can convert the color image into gray
image with contrast preserved. The following pictures (a) is the original microscopic image, (b) is the gray
image produced by traditional method, (c) is the gray image produced by Contrast Preserving
Decolorization.

\"..

(c) Contrast Preserving Decolorization

(a) age

11.2 Adjust
11.2.1 Brightness/Contrasteee

The Image>Adjustment>Brightness/Contrastess command offers simple adjustments to the tonal range of
an image. This command makes the same adjustment to every pixel in the image. The
Brightness/Contrastees command does not work with individual channels and is not recommended for
high-end output because it can result in the loss of image details.

Brightness: Dragging the slider to the left decreases the level and | Adust Erightness/Contrast x
dragging it to the right increases the level. The number on the right of | b =
the slider displays the Brightness value. Value can be inrange of -100 | " -
to +100. Default is O; 8

Contrast: Dragging the slider to the left decreases the level and dragging it to the right increases the level.
The number on the right of the slider displays the Contrast value. Values can be in range of -100 to +100.
Default is 0.

11.2.2 Coloreee -

Adjust Color x
Choose Image>Adjustment>Coloreee command to modify the |= (] | e
overall mixture of the colors in an image. . 2 — e
The command supports 4 color modules: RGB, CMYK, HIS and |, . —
HLS. -
@®)RGB Covvk OHsI OHLs
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RGB: The App uses the RGB model. It assigns an intensity value to each pixel ranging from 0 (black) to
255 (white) for each of the RGB components in a color image. For example, a bright red color might have
an R value of 246, a G value of 20, and a B value of 50. When the values of all three components are equal,
the result is a shade of neutral gray. When the value of all components is 255, the result is pure white; when
the value is O, pure black;

RGB images use 3 channels to reproduce up to 16.7 million colors on-screen. In addition to being the
default mode for the new App images, the RGB mode is used by computer monitors to display colors. This
means that when working in color modes other than RGB, such as CMYK, the App uses RGB mode for
display on-screen. Although RGB is a standard color mode, the exact range of colors represented can vary,
depending on the application or display device.

CMYK: The CMYK mode is based on the light-absorbing quality
of ink printed on papers. As white light strikes translucent inks,
certain visible wavelengths are absorbed while others are reflected
back to the eyes;

In theory, pure cyan (C), magenta (M), and yellow (Y) pigments
should combine to absorb all light and produce black. For this
reason these colors are called subtractive colors.

Adjust Color

C

M

Y

Color Modules

(@]

@ cvvk

OHst

o] Cancel

OHLs

Because all printing inks contain some impurities, these three inks actually produce a muddy brown and
must be combined with black (K) ink to produce a true black. (K is used instead of B to avoid confusion
with blue.) Combining these inks to reproduce color is called four-color process printing.

The subtractive (CMY) and additive (RGB) colors are

complementary colors. Each pair of subtractive colors creates an .
additive color, and vice versa. : (] Cance
HSI: Based on the human perception of color, the HSI model | (|

describes 3 fundamental characteristics of colors:

Adjust Color

Color Modules

OreB

[@])14

(®) Hst

(OHLS

Saturation, sometimes called chroma, is the strength or purity of the color. Saturation represents the amount
of gray in proportion to the hue, measured as a percentage from 0% (gray) to 100% (fully saturated). On the
standard color wheel, Saturation increases from the center to the edge;

Intensity is the relative lightness or darkness of the color, usually measured as a percentage from 0% (black)

to 100% (white);

HLS: The HLS model is very similar to the HSI color model.
The main difference between them is the calculation used to

H [
produce the brightness value. In the HSI model, a pixel's
brightness (1) is derived from its three (R, G and B) color values |° a cones
I=(r+g+b)/3. In the HLS model, a pixel's brightness (L) is |s Y

determined by the minimum and maximum values of its three
color values. L=(maximum of r,g,b - minimum of r,g,b)/2;

Adjust Coler

Color Modules

ORGB

O Mk

OHst

@®@HLS

The values beside the slider bar show the color changes in various color channels.

For RGB channel values, they are range from -100 to +100. Default is 0;

For CMYK channel values, they are range from -100 to +100. Default is O;

For HSI channel values, the H value can range from -180 to 180, the S value range from -275 to 275, and the

| value is range from -442 to 442.Default is O;

For HLS channel values, the H value is range from -180 to 180, the L value is range from -100 to 100, and

the S value is range from -100 to 100. Default is 0.
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Hightlight/Midtone/Shadow x
Choose Image>Adjustment>HMSe+» command to adjust the HL —
(Highlight), M (Midtone), and S(Shadow) parts of the image. " a P .
Each part's value ranges from -100 to 100. This command is only ™ [ 5
available for 24 bits true color image. s . ;

Curve X

Choose Image>Adjust>Curveee* to adjust the entire tonal range of
an image. But instead of making adjustments using only 3 Hahdights
variables (Highlight, Midtone, Shadow), one can adjust any point
on the curve along a 0-255 scale while keeping up to any other
values constant. One can also use Curve to make precise -
adjustments for individual color channels on an image. The Curve
dialog is shown on the right side:

Reset

Apply

OK

Cancel

Horizontal Axis: The horizontal axis of the graph represents the

original intensity values of the pixels (Input levels); | Sebaols
A Grid [ mmm ﬁﬂ

Vertical Axis: The vertical axis represents the new color values (Output levels). In the default diagonal line,
all of the pixels have identical Input and Output values;

Curve area: Area to setup a map between input and output;

a) When the Curve dialog is opened, perhaps surprisingly, not a curve but a straight line. As a default, the
input values are the same as the output, so there’s no change;

b) By clicking in the center of the line and dragging upwards, we make our first curve. Raising the curve
increases the overall brightness of the scene.

c) Conversely, clicking in the center and dragging downwards lowers the brightness, producing an image
that’s darker overall;

d) As well as clicking in the center, one can also adjust the endpoints. Clicking the top right point and
dragging down will limit the image's brightest, reducing contrast;

e) If we drag that top right point to the left rather than down, we produce the opposite effect—increasing the
contrast of the image. This is a very useful and controllable quick fix;

f) By dragging the top and bottom points towards the center, we create a stylized, posturized effect that
turns any photograph into more of a graphic object;

g) Click once in the center of the RGB curve to "pin" that midpoint; now drag just the top half of the curve
to make this S shape, and the result is to increase the overall contrast;

h) User can add up to any control points to the curve, locking those values. To remove a control point, 1)
drag it off the graph or 2) click the right mouse button on that point. User cannot delete the endpoints of
the curve.

Foy T e o e) et e o f) m/‘-..ﬁ ] ~ 7 g) ﬁ=:=< T ~ 7 h)

Grid: Check to overlay the grid on the Curve window;
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Channel |_!|—|!|: To adjust the color balance of the image, click the channel(R, G or B) from the
Channel button. Click the white button to select RGB channels at the same time, which is located on the left
of the R (Red), G (Green) and B (Blue) buttons;

Curve W Click the Curve with your left mouse button, a spline curve (straight line) will setup the initial
input-output relation. Click on the Curve will mark the Curve with a point. The point number can be any as
long as it can be inserted on the Curve. Drag the marked point until the image looks satisfactory. The point
can be deleted by move the mouse on it and click the right mouse button on it;

Pencil-ﬂ: Click the pencil button at the bottom of the dialog, and use your left mouse button to draw a
new arbitrary Curve in the Curve area;

Reset: Click the Reset button will reset the Curve to the initial straight line;

Apply: Apply current Curve map on the image.

Choose Image>Adjustment>Filter Color command to filter a special color | seictcolor X
channel from a color image. Select either Red, or Green, or Blue color to | ©«
filter. For every pixel, if select Red color to filter, only information about the | =
Red channel will be discarded, the Green and Blue information will remain | 9=
there. Osie

See Image>Extract Coloree* for another color operation.

Cancel

Choose Image>Adjustment>Extract Colorees command to extract a special | .ccowr x
color channel from a color image. Select either Red or Green, or Blue color to caor
extract. ®red

Ogreen Cancel

For every pixel, if selecting Red color to extract, only information about the :
Blue

Red channel will be kept, the Green and Blue information will be discarded.

See Image>Filter Colore* for another color operation.

Choose Image>Adjustment>Invert command to reverse the pixel values of the active image without going
through the lookup table.

Edge Preserving Smooth is an image processing | egepresening smeoth x
technique that smooth away textures whilst | e

retaining sharp edges. Examples are the Bilateral
filter, the Guided filter and Anisotropic diffusion.

(®) Recursive () Normalized Convolution

Choose Image>Adjust>Edge Preserving Smooth | seatelsoma: ] &0
eee command can smooth the entire image and
preserve the edge of image, as shown on the right
side. Cancel

Edge Preserving Smooth function provide two kinds of filters including Recursive and Normalized
Convolution filters, and the default filter is Recursive.

Range Sigma: . 40

The App uses Spatial Sigma and Range Sigma to define the filter kernel size. The bigger the two parameters,
the stronger the image smoothed, vice versa.
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Choose Image>Adjust>Detail Enhanceees command | detienhance X
to enhance the detail in the image, its dialog is shown | .
on the right side. .

The App chooses Spatial Sigma and Range Sigma to | runge sgns: o
define the kernel size for Detail Enhance algorithm. "

The bigger the 2 parameters, the stronger the

enhanced image and vice versa. Cancel

The following picture is the detail enhanced image for reference with default parameter.

a)Original image and b)Enhanced image

The Image>Adjustment>Auto Level command moves the level's sliders automatically to set highlight and
shadow. It defines the lightest and darkest pixels in each color channel as white and black and then
redistributes the pixels' color values proportionately. Since Auto Level adjusts each color channel
individually, it may remove or introduce color casts. The Auto Level command moves the level's sliders
automatically to set highlight and shadow. It defines the lightest and darkest pixels in each color channel as
white and black and then redistributes the pixels' color values proportionately. Since Auto Level adjusts
each color channel individually, it may remove or introduce color casts.

By default, this feature clips the white and black pixels by 0.5%--that is, it ignores 0.5% of the lightest
pixels and 0.5% of the darkest pixels when identifying the lightest and darkest pixels on the image. Choose
Options>Auto Correctioness command to modify this default setting. This ensures that white and black
values are representative without being determined by extreme pixel values. The Auto>Correctionee* setup
dialog can be find in Sec.15.6.

The Image>Adjustment>Auto Level command gives good results when an image with an average
distribution of pixel values needs a simple contrast adjustment or when an image has an overall color cast.
However, adjusting the Curves manually is more precise.

See Image>Adjustment>Auto Contrast for another auto adjust command.

The Image>Adjustment>Auto Contrast command automatically adjusts the overall contrast and mixture of
colors in an RGB image. Since it does not adjust channels individually, Auto Contrast does not introduce or
remove color casts. It maps the lightest and darkest pixels in the image to white and black, which makes
highlights appear lighter and shadows appear darker.

When identifying the lightest and darkest pixels on an image, Auto Contrast clips the white and black pixels
by 0.5%--that is, it ignores the first 0.5% of either extreme.

Choose Options>Auto Correctioness command to modify this default setting. This ensures that white and
black values are representative without being determined by extreme pixel values. The Auto Correctioneee
setup dialog can be find in Sec.15.6.

The Auto Contrast command can improve the appearance of many photographic or continuous-tone images.
It does not improve flat-color images.

See Image>Adjustment>Auto Level for another auto operation.

63



Image

11.3 Rotate(R)

Choose Image>Rotate command to rotate the entire image. One has the following submenus:
11.3.1 90(CW)

Rotate the image clockwise by a quarter-turn.

11.3.2 180(CW)

Rotate the image clockwise by 180 degrees.

11.3.3 270(CW)

Rotate the image clockwise by 270 degrees.

11.3.4 Arbitraryeee

Rotate the image by a specified angle. For the Arbitraryeee | imsgerotste X
operation, it will invoke an Image Rotate dialog as shown on the | #s- o
right side. — ]

oan
Enter an angle between 0 and 360 degrees in the Degree edit box, | Ocow
and select CW or CCW to rotate clockwise or counterclockwise. Qualty Binear .

Degree: The degree that the image to be rotated,;
CW: Rotate the image clockwise;
CCW: Rotate the image counterclockwise;

Quality: One can select one of the 2 methods for the image rotation, Bilinear or Bicubic. The default is
Bilinear.

11.3.5 Flip Horizontal d\

Reverses the image so that the top right corner of the original image is now the top left, and the top left
corner of the original image is now the top right corner.

- |

11.3.6  Flip Vertical -

Reverses the image so that the top right corner of the original image is now the bottom right corner, and the
top left corner of the original image is now the bottom left corner.

11.4 Crop Shift+C

Choose Image>Crop command to remove the portions of an image that does not want so that the focus is on
the part of the image that is left.

1. Choose Open Imagee+s command to open an image to Crop;

2. Choose Edit> Image Select command, the cursor will change to a small
Cross;

3. Move the cursor over the image to the desired location, click the left mouse
button and hold it down to mark the first position;

4. Drag the mouse over the part of the image to be kept, a dotted rectangle
appears around the selection and release the left mouse button;

5. Optional 1. To move the rectangle: a) Move the mouse over the selected area and when it becomes a
move cursor ‘%”, click and hold the left mouse button; b) Drag the selected area to the desired position;

6. Optional 2: To change the size of the rectangle: a) Put the mouse cursor on one of the handles that appear
on the edges of the selected area “*; b) Click and hold the mouse button; ¢) Drag the box to size it;

7. To Crop the image, choose Image>Crop command or press Shift+C buttons.
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Note: a) Each of the handles that appear on the edges of the box sizes the box differently; b) When there are
Obijects on overlaid on the image, The Crop operation will delete the Objects located totally outside of the
kept region.

11.5 Image Sizeeee

Choose Image>Image Sizeess command to change the image to specified size. This process actually
changes spatial resolution by adding (replicating) or removing (decimating) pixels to achieve the specified
dimensions.

Width & Height: When choosing Image Size command; the
dialog displays the dimensions of the original image in pixels. The | seleimege x
Width & Height can be set on the new image by adding or |,..
removing pixels. If Constrain Proportions is checked, the Width | [s2

& Height will stay proportionate to each other. If Constrain oo ot i
Proportions is unchecked, the Width & Height can set |~ .
independently, but this will distort the image;

Reset

Reset: Reset the image Width and Height to the original ones;

Constrain Proportions: To maintain the current proportions of pixel Width and Height, check Constrain
Proportions. This option automatically updates the Width as the Height is modified, and vice versa.
Otherwise, uncheck the Constrain Proportions button;

Scale method: There are 2 options for the Scale method, Bilinear or Bicubic. The default is Bilinear.

Note: Image Size operation will not modify the Calibrated Resolution. The Measurement results will be
wrong after the Image Size command.

11.6 Histogrameee Shift+H

A Histogram illustrates how pixels in an image are distributed by graphing the number of pixels at each
color intensity level. The Histogram shows whether the image contains enough detail in the Shadows
(shown in the left part of the Histogram), Midtones (shown in the middle), and Highlights (shown in the
right part) in order to make a good correction.

The Histogram also gives a quick picture of the tonal range of the image, or the image key type. A low-key
image has detail concentrated in the shadows, a high-key image has detail concentrated in the highlights,
and an average-key image has detail concentrated in the Midtones. An image with a full tonal range has a
number of pixels in all areas. Identifying the tonal range helps determine the appropriate tonal corrections.

Choose Image>Histogramees command | Hiegram X || Histogram x
to open the Histogram dialog as shown on | creme  |Lumnosiy v chamel  [red %
the right.

Depending on the image’s color mode,
choose R, G and B, or Luminosity to view
a composite Histogram of all the | ——

Level: Pixels: 352800 Level: Pixels: 352300

channels. Count: @erte

Percentile: Percentile:

If the image is RGB true color, choose
Luminosity to display a Histogram
representing the luminance or intensity
values of the composite channel.

Histogram X Histogram X

Channel Green > Channel Blue
If the image is RGB true color, choose R,

G and B to display a composite L:

Histogram of the individual color | e ek 352800 Level P
channels in color. Count: Counts

>

Percentile: Percentie:
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Do one of the following:
To view information about a specific pixel value, place the mouse pointer in the Histogram;

To view information about a range of values, click down the left mouse button and drag it in the Histogram
to highlight the range;

The dialog displays the following statistical information below the Histogram.

Pixels: Represents the total number of pixels used to calculate the Histogram;

Level: Displays the intensity level of the area underneath the pointer;

Count: Shows the total number of pixels corresponding to the intensity level underneath the pointer;

Percentile: Displays the cumulative number of pixels at or below the level underneath the pointer. This
value is expressed as a percentage of all of the pixels in the image, from 0% at the far left to 100% at the far
right.

11.7 Resolutioneee

Choose Image>Resolutionsse command to set the image Resolution to calibrate the spatial scale. By default,
the App expresses image measurements in terms of pixels. This Resolution (The better name should be
Calibrated Resolution) command is used to change the terms in which the App reports such measurements.
This command should be run first in order to measure Objects in terms of units other than pixels.

Resolution x

Magnification: Custom ki

3548 Piels / | Meter (m) ~

4%

10K

40X

The resolution can be Custom or set it according to the Magnifications defined by the microscope
calibration command. The Resolution will list all of the Magnifications in the Magnification dropdown box.
If Custom is selected, user has to enter the Resolution according to the real value, otherwise, just select the
corresponding Magnification and the Resolution value will be filled into the edit box automatically.

After the new Resolution is set, all of the Measurements will be calculated according to the new Resolution.
(See more in the Measurements (Sec.14) and Options> Measurementeee menus (Sec.15.2)).

11.8 DPleee

In printing, DPI (dots per inch) refers to the output resolution of a printer or image setter, and PP1 (pixels per
inch) refers to the input resolution of a photograph or image. DPI refers to the physical dot density of an
image when it is reproduced as a real physical entity, for example printed onto paper.

A digitally stored image has no inherent physical dimensions, measured in inches or centimeters. Some
digital file formats record a DPI value, or more commonly a PPI (pixels per inch) value, which is to be used
when printing the image. This number lets the printer or software know the intended size of the image, or in
the case of scanned images, the size of the original scanned object.

For example, a bitmap image may measure 1,000 =<1,000 pixels, a resolution of 1 megapixel. If it is labeled
as 250 PPI, that is an instruction to the printer to print it at a size of 4 <4 inches. Changing the PP1to 100 in
an image editing program would tell the printer to print it at a size of 10 <10 inches. However, changing the
PPI value would not change the size of the image in pixels which would still be 1,000 <1,000. An image
may also be resampled to change the number of pixels and therefore the size or resolution of the image, but
this is quite different from simply setting a new PPI for the file.

DPI menu can be used to change the DPI of the captured image for the display and print operation because
if one keep using resolution of the microscope image captured from the camera. The Calibrated Resolution
will make the image in small size in the Word file or on the printed paper.
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The value in the DPI dialog can be set to 150, 300,600 or 1200 for the print or display application.
11.9 Mosaiceee

Mosaic is a process that can combine the images opened into a new image. This will open Mosaic Property
sheet as shown below. It has two pages, they are is Image List and Parameters pages.

Mosaic Images X Mosaic Images X
Image List Parameters Image List Parameters
Available Images Selected Images Title |'ﬁﬁe |
DemoBlue. TIF DemoBlue, TIF
DemoGrn, TIF FLIEE DemoGrn, TIF Footer | |
DemoRed. TIF DemoRed. TIF
000g _ 0003 Arrangement
Add all= > .
Auto
Counns Colspeng
Font...
Clear System font
Page Size
() Default size Width 1024 Height | 1280
(®) Use printer's size 8257 x 11692 Change...
Use 1/4 Size
oK Cancel Apply Cancel Apply

Image List page:
Available Images: Images opened with the App;
Add>>: Add the opened images to the Selected Images list view;

Add AllI>> Add all the opened images to the
Selected Images list view;

Remove: Select the images and remove them
from the Selected Images list view;

Clear: Remove all the images from the Selected
Images list view.

Parameter page:
Title: The title wanted:;
Footer: The footer wanted;

Arrangement: The Mosaic Images distribution
on the page;

Page Size: The page size for the Mosaic Images;

If everything is set, click OK to end the Mosaic
Images operations and a new image window will
be displayed and the final results should look
like that on the right side.
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12 Process

12.1 Stitchees o Shift+T

Image stitching is the process of combining multiple photographic images with overlapping fields of view
to produce a segmented panorama or high-resolution image. Commonly performed through the use of
computer software, most approaches to image/video stitching require nearly exact overlaps between images
and identical exposures to produce seamless results. Some digital cameras can Stitch photos internally.
Image stitching is widely used in today’s world in applications such as Image Stabilization feature in
camcorders which use frame-rate image alignment, high resolution photo mosaics in digital maps and
satellite photos, medical imaging, multiple image super-resolution, live stitching and object insertion.

The App also integrated Live Stitch, Image Stitch and Browse Window Stitch into it.

Live Stitch allows real time stitching in video mode. Users could get an overview of the stitching area and
the stitching results could be updated immediately when frames in video mode is updating. Automatic
alignment and blend is applied during operation to achieve the best quality.

Before begin the Live Stitch (Video), the following preparations should be made first:

1. Good quality specimen: For Live Stitch imaging, it is important, that the specimen is of good quality.
Avoiding higher thickness variations of the specimen will speed up the stitching process by reducing the
need to refocus while scanning;

2. Structured scanning: Don't lose orientation while scanning a specimen. Look at the sample with low
magnification and memorize its contour or shape. When scanning in horizontal stripes from top to bottom,
locate the uppermost edge of the specimen and use it as starting point. For difficult specimens with
disjointed sample areas, simply take a picture of the whole slide with a smartphone first. This helps you to
remember all areas that have to be scanned;

3. Warm up the microscope light source first: Warming up the illumination is a crucial step especially for
the halogen light source, because the color and intensity of the lamp is changing significantly in the first few
minutes of operation. If the brightness and color keeps changing after a few minutes, this might be a hint to
replace the bulb;

4. Free resources of your computer: Live Stitch is hard work for computer. Close all other applications
before starting the App’s Live Stitch command. This ensures that everything works smooth;

5. A camera with global shutter sensor is preferred to get the best performance. The distortion of the image
taken with rolling shutter may result in failure or unsatisfied results;

6 It is strongly recommended that the Auto Exposure function in Exposure & Gain group on the Camera
Sidebar is unchecked during the stitching operation to guarantee the unique lightness;

7. High speed camera is preferred to achieve the best experience. Shorten the exposure time to guarantee the
high frame rate if the illumination is strong enough;

8. Users should move the slides in proper speed and guarantee that the camera is in focus. When the
rectangle in the stitching window is getting red or yellow, users should stop or move back a little bit until
the rectangle is green. The red or yellow rectangle during stitching operation means failure or warning on
the stitching or alignment. The reasons may result from the fact that the slides is moving too fast, in which
case the computer is not quick enough to finish the calculating, or the details of the content is not very clear
for alignment;

9. Stop the stitching window first before closing it;
Now user can begin the Live Stitch (Video) step by step as listed below:
1. Click the camera name in the Camera List group on the Camera Sidebar to begin the video feed;
2. Adjust the microscope and camera control parameter to get the best image quality;
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3. Choosing Process>Stitchess command or clicking down the Stitch button o the toolbar (Shift+T)
will invoke the Live Stitch (Video);

4. A stitching window will be shown as below. The border around the video turns green to show that the
scanning is active and working. The grids area is the background;

Video [E3CMOS02300kP8]  Stitch® ]

0 200 . |400 600

5. Move the slides with the microscope X-Y translational control knobs and user will see the stitching
results simultaneously. Move the slide to acquire horizontal or vertical stripes. If your camera has a very
wide aspect ratio (e.g. 16:10) it is recommended to scan vertical stripes. For standard aspect ratios (5:4 or
4:3) vertical and horizontal stripes are equally efficient. Make sure that adjacent stripes are overlapping by
at least to rows (or columns) of grids.

Meox Hiof@xs-- /2 7%1-000-0R- A2z 00w W @O0,
4 Video [E3CMOS02300KPB] ~ Stitch®
0 ... |20 1400 | 600 |800 | 1000 | 1200 | 1400 | 1600 | 1800 [2000 | 2200 2400 2600 2800 3000

o0ss | 0098 | oors | 00z8 | 0008 | 008z 009s]

0006 |

0026 |

00v6 |

=<

6. The area marked with Green Rectangle shows the real time video and the other area is the stitching
results. Please pay attention to the Green Rectangle. When the rectangle is green, the stitching function is
working as expected and users could move the slides continuously. If the scanner loses track (usually
because you are accidentally moving into an empty area of the slide that cannot be stitched or you are
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moving/accelerating the slide too fast for the camera), the border of the video turns to red or v!/0vv and you
can slowly return back to the last known position where the rectangle turns into green. After the rectangle is
green, users could continue the operation;

7. Click the Stitch (Shift+T) button again to stop the live stitching function. The stitching results will be
cropped from the background and the result image will be generated automatically;

_ Video [E3CMOS02300kPB]  Stitch® |

8. The stitching image could be saved or edited.

Some default setups about the Live Stitch can be find in Options>Preferenceses, Misc page’s Stitch(Video)
item in Sec.15.1.8.8.

12.1.2 Image Stitch

If images are opened in the App, for example 0001.jpg, 0002.jpg, 0003.jpg, 0004.jpg are opened as
shown below:

0003.jpg 0004.jpg

1. Choosing Process>Stitch command or clicking down the Stitch button M on the toolbar (Shift+T) will
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invoke the image Stitch dialog as shown below. Each item in the Stitch is described below:

Available Images: The images opened by the App; Here, 4 images are listed in the list box. One can click
the image file name to select the files to be added to the Selected Images;

Stitch X Stitch X
Available Images Selected Images Available Images Selected Images
add>> 000+ p
yu-0005.jpg
Add all>> yu0006.Ipg Add all>>
Remove Remove
Clear
MNext > Cancel < Back Finish Cancel
a)Available Images b) Selected Images

Selected Images: The images selected for stitching; Using Add>> or Add All>>to add Available Images to
this list box;

Add>>: When an image or images is or are selected and highlighted in the Available Images window, the
Add>> will be enabled. Clicking Add>> will add it or them into the Selected Images list box;

Add All>>: Clicking Add All>> will add all of the Available Images into the Selected Images list box;

Remove: When an image or images is or are selected and highlighted in the Selected Images list box, the
Remove button will be enabled, click Remove button will remove it or them from the Selected Images list
box;

Clear: Used to clear all of the images in the Selected Images list box. When no image in the Selected Images
list box, it will be disabled:;

Cancel: Click to cancel the current stitching process;

Finish: Click the Finish button will accept the other Default setup and begin to stitch the captured images
according to the above setup;

2. Next>: Clicking Next> will step to the Stitch method setup dialog;

Panorama Straighten: The image stitching direction. It
can be Horizontal, Vertical and None. Default is | <
Horizontal;

Panorama Straighten: Horizontal ke

Projection Type: For image segments that have been
taken from the same point in space, stitched images can
be arranged using one of various map projections. | ™ ShCi e
BMS_pix3 including Plane, Cylindrical, Spherical, Exposure Compensaton: Blods Gan v
Fisheye, Stereographic, Mercator or Transverse Bunde Acjust:
Mercator map projections. The Default is Cylindrical;

Projection Type: Cylindrical ~

Ray adjust ~
Seam Finder: Seam Finder method, BMS pix3
including None, Voronoi Diagram, Graph Cut Color or
Graph Cut Color Grad. Default is Graph Cut Color;

Exposure Compensation: Exposure Compensation is required between images to minimize exposure
differences. BMS_pix3 including None, Gain or Blocks Gain Exposure Compensation method. Default is
Blocks Gain;

Bundle Adjust: Bundle Adjustment can be defined as the problem of simultaneously refining the 3D
coordinates describing the scene geometry as well as the parameters of the relative motion and the optical
characteristics of the camera(s) employed to acquire the images, according to an optimality criterion
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involving the corresponding image projections of all points. BMS_pix3 including Ray adjust or
Reprojection error adjust method. Default is Ray adjust;

<Back: Click <Back will return to the previous setup page;

Finish: Click Finish will accept the other Default setup and begin to stitch images according to the above
setup;

Cancel: Click to cancel the stitching process.

3. Next>: Click Next> will step to the Stitch parameter dialog:
Match Confidence: 1~100, Default is 65;

Panorama Confidence: 1~100, Default is 100;

Match Strength: 0~100, Default is 25;

Blend Strength: 0~100, Defaults is 5; e %
Defaults: Click Defaults will set all the parameters to the | s confeene: 5
Default ones; ]

Panorama Confidence: 100
<Back: Click <Back will return to the previous Stitch 8
d i al Og , Match Strength: 25
Finish: Click Finish will begin to Stitch images according S . ;
to the above setup. After the Finish button is clicked, 8
the App will start to stitch and a progress dialog will be S
shown to indicate the Stitch state;
Cancel: Click to cancel the stitching process. <vade | et cance

The final stitched image will be created in a new image
window as shown below.

In the stitched image, there are some black areas, these N
are happened when there are translations among the
edge images in both directions.

Progress >

12.1.3 Browse/Thumbnail window Stitch

Click the Folders Sidebar to activate it. Double-click the right directory to show the images under the
directory in the Browse window.

o+

B8 on the

For Thumbnail window, choose View>Thumbnail command or click the Thumbnail button
toolbar, all the images captured/opened/Paste as New File created will be displayed in icon mode.

72



Process

Choosing the image files to be stitched and then clicking the right mouse button will display the context
menu, choose Stitch submenu to start the image stitch operation (One can also choosing Process>Stitch to
do the same operation after the images are selected in the Browse/Thumbnail window)

The App

- oEN

File Edit View Browse Setup Capture Image Process Layer Measurements Options Window Help

=" = = v| NA
Folders
00 8 &=
| &) EDOF
+- ). HDR
4§ ImageCount
@ J. Sample
@ ). Stack
=- ). Stitch
J, stitch_01
+- ). testl
+- b test2
H- b test3
f ). testd >
Bc. Hro [0 un. [Riay. |fFme

[ Measurement Sheet

v 90%

Sort

Icons

[£] Refresh

Properties.

% Stitch..

O
< 5

X Delete File

High Dynamic Range (HDR)...

Shift+T

Shift+F

24 bpp 1360 x 1024

S 4,4

After the Stitch command is selected, a Stitch dialog will be popped up as shown below:

Stitch

Panaorama Straighten:

Horizontal

X

Projection Type: Cylindrical ~
Seam Finder: Graph Cut Color ~
Exposure Compensation: Blocks Gain i
Bundle Adjust: Ray adjust ~
Defaults
< Back Finish Cancel
The Stitch dialog and the other Next> steps dialog are just the same as those of Image Stitch in Sec.12.1.2.
Stitch X
Match Confidence: 65
]
Panorama Confidence: 100
]
Match Strength: 25
]
Blend Strength: 5
]
Defaults
< Back Next > Cancel

The final stitched image will look like the above right side one:

In the stitched image, there are some black areas; these are happened when there are translations among

the edge images in both directions.

12.2 High Dynamic Range (HDR)eee

I .

High Dynamic Range can fuse a sequence of multi-exposure images into a high dynamic range image. The

user can capture the multi-exposure images by adjust the aperture of microscope or the Exposure Time and
the Analog Gain in the Exposure & Gain group on the Camera Sidebar.
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The App supports High Dynamic Range function in 2 modes, which is shown below.
12.2.1 Image window High Dynamic Range operation

When the image window is active, the user can choose images from opened window to generate high
dynamic range image. This mode will lead the system to overhead when many images were opened

%;2:;&"/0

D

(1.png (2).png
Opened image for HDR operation

Choose Process>High Dynamic Range<es command to fuse captured or opened images to High Dynamic
Range image, a dialog called High Dynamic Range(HDR) will be shown as below:

High Dynamic Range (HDR) X High Dynamic Range (HDR] X

Available Images Selected Images Available Images Selected Images

Elg-Pﬂg g.png g.png
2).png .png .png
(3).png Gk (3)-png (e (3).png

Add all>> Add all>>

Remove Remove

Clear Clear

o o Cancel

a)Available Images and b) Selected Images

We assumed that (1).jpg, (2).jpg, (3).jpg 3 images have been opened.

Available Images: The images opened by the App; Here, 3 images are listed in the list box. One can click
the image file names to select them and added them to the Selected Images list box

Selected Images: The images selected for stitching; Using Add>> to add the Available Images to this list
box;

Add>>: When an image or images is or are selected and highlighted in the Available Images window, the
Add>> will be enabled. Clicking Add>> will add it or them into the Selected Images list box;

Add All>>: Clicking Add All>> will add all of the Available Images into the Selected Images list box;

Remove: When an image or images is or are selected and hlghllghted in the Selected Images list box, the
Remove button will be enabled, clicking Remove will remove it or them from the Selected Images list
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box;

Clear: Used to clear all of the images in the Selected Images list box. When no image in the Selected Images
list box, it will be disabled:;

Cancel: Click to cancel the stitching process;

OK: Click OK will begin to fuse the selected images according to the above setup. The final result is shown
above.

In Browse/Thumbnail window, the user can choose images to be fused directly and there is no need to open
any image to save the system cost.

When the Browse/Thumbnail window is active, the user can choose low dynamic range images by:
a) Clicking the displayed file icons, a single file will be highlighted;
b) Clicking the file one by one with Ctrl + left mouse button, all of the clicked files will be highlighted;

c) Clicking the displayed file icons, the first clicked file will be highlighted, clicking the end file with
Shift + left mouse button, all the files among the first and last will be highlighted.

d) Dragging the mouse to draw a dotted line rectangle across the files you wish to delete, all of the files in
the rectangle will be highlighted:;

e) Ctrl+A /Edit>Select All to select all files in the Browse/Thumbnail window;

Clicking the right mouse button on the Browse/Thumbnail window will invoke the context menu. Choosing
High Dynamic Range (or choose Process>High Dynamic Rangeess command), the App will begin to
calculate according to the selected images. The high dynamic range image will be displayed in a new image
window when the progress bar reaches to the end.

12.3 EDFeee = Shift+F

I+l

Live EDF allows you to capture a fully-focused image for specimens whose thickness exceeds the
microscope depth of field. Available for any manual microscope, Live EDF solves the depth of field issues
that often plague Entomologist, Botanists, and Parts and Material manufacturers. Automatic alignment is
applied during operation to achieve the best performance in case there is a slightly FOV (field of view) shift.
The characteristics of Live EDF is listed below:

v No motor stage or focus drive needed

v" Works with any camera

v" Users need not be concerned about;
® Specimen Thickness

Focus direction or evenness

Starting or ending focus point

Z thickness

# of Z planes required

Camera/Stage orientation

® Stereomicroscope image shift
v" Prevents damage caused by specimen flattening
v" Works in Fluorescence applications

Live EDF is not designed to:
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® Retain Z axis information
® Produce a 3D image
The basic Live EDF steps are listed as below:
1. Click the camera name in the Camera List group on the Camera Sidebar to begin the video;
2. Choose Process>EDF command or click the EDF button in the toolbar to open the live EDF window;

Lo S L-O000- @R N & Al @ a[=)

A live EDF window will show as below. The left bottom window is the video preview window of the
camera and the right main window is the EDF results in real time.

q Video [E3ISPMOS000KPA] ~ EDFS* |

3. Rotate the microscope fine adjustment knob. The live preview of the specimen will be shown in the left
bottom small video window. The EDF results will be updated in the right large window in real time;
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Video [E3ISPM05000KPA] ' EDF7"

4. Click the EDF button again to stop the live EDF function.

Notes: Settings related to Live EDF is integrated in the Option>Preferences>Miscees page, EDF (Video)
item (See Sec.15.1.8.9 for details).

I+l

12.3.2 Image Window EDF Shift+F

Image window EDF is also a very useful tool to | == x
generate a clear image by combining a sequence of e Seleci=d:

previously captured or opened multi-focus images. | 22 S

Choosing  Process>EDFese  command, the | %=

following dialog will be brought up (assume 01.jpg | =5 eete

02.jpg *** 15.jpg are already opened in the App): 050 —

1lipg

Clicking on the image file name in the Open list | 3%
box will highlight the image, and then the Add>> | =5
button is enabled (Clicking on the selected images
will deselect them). Clicking the Add>> button, the
highlighted images will be added into the Selected

list box, which will be fused later.

< Back Next > Cancel

Clicking the Add all button will add all images in the Open list box into the Selected list box.
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If images in the Selected list box are highlighted,
the Delete button will be enabled. Clicking the
Delete button, the highlighted images in the
Selected list box will be removed.

Clicking the Clear button will remove all the
images in the Selected list box, including the
unselected ones. The button will be disabled if
there is no image in the Selected list box.

When the desired images are all selected (If more
than 2 images are added in the Selected list box, the
Next> button will be enabled), clicking on the
Next> button, a dialog called Select Method is
popped up as shown on the right side.

There are 3 EDF methods in the App, they are:

Maximum Contrast: Maximum Contrast method is
similar with weighted average method, and the
input images must be in Z order as well. The
difference is that the maximum contrast method
may lose some detail however the preserved details
will be sharper. Maximum Contrast method is a
preferred method in these three EDF methods.

Weighted Average: Weighted Average method
produces a soft fusion result but may lose detail.
This method often gives superior results to
FFDSSD method with deep stacks, such as images
produced by microscopy. It is worth noting that
images to be processed must be in Z order (Capture
a series images in closest to furthest or furthest to
closest order);

Choosing Maximum Contrast and Weighted Average in the Select Method dialog will pop up an Options

dialog as shown above.

Select Method

Maximum Contrast ~

Description

Weighted Average method produces a soft fusion result but may miss detail. This method
often gives superior results to FFDSSD method with deep stacks, such as images produced by
microscopy. [tis worth noting thatimages to be processed must be in Z order {dosest to furthest or
furthest to dosest with the microscope objective lens relative to sample on the stage).

Maximum Contrast method is similar with weighted average method, and the inputimages
must be in Z order as well. The difference is that the maximum contrast method may loose some
detail though what detail is preserved wil be sharper. Maximum contrast method is a preferred
method of EDF,

FFDSSD is a method that does filtering in the frequency domain using Fast Fourier
transform (FFT) and does synthesis in the space domain. FFDSSD can be used for images having
misalignment. Users can manually or automatically select reference images to make inputimages
aligned.

< Back Cancel

Options
Detail Clarity: . 107
Total Brightness: . 125
Background Brightness: . a3

Defaults

Description

The three values are not isolated. Detail darity affects the fine detail of the result. Background
brightness is the offset value that is used to add or subtract the background. These two settings will
result in the change of the total brightness. For that reason, the total brightness may also need to be
adjusted.

< Back

Cancel

Detail Clarity: Detail Clarity affects the fine detail of the result. Default: 107, Range: 10~240;

Total Brightness: Total Brightness is the overall brightness. The Detail Clarity and Background Brightness
will result in the change of the Total Brightness. For this reason, the Total Brightness may also need to be

adjusted. Default: 125, Range: 10~240;

Background Brightness: Background Brightness is
the offset value that is used to add or subtract the
background. Default: 93; Range: 10~240;

Default: This will set all 3 values to the Default
ones;

FFDSSD: FFDSSD is a method that does filtering
in the frequency domain using Fast Fourier
Transform (FFT) and does synthesis in the space
domain. FFDSSD can be used for images having
misalignment. Users can manually or automatically
select reference images to make images aligned.

FFDSSD related dialog is shown on the right side.

FFDSSD Options

Determine the reference image automatically

< Back Cancel
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Determine the reference image automatically: If this item is checked, the APP will determine the
reference image automatically. Otherwise, the first one will be the reference image.

Clicking Next> button will pop up an Auto Align dialog as shown below:

None: Considering no Shift+Scale+Rotate among | auo aiign x

the selected images in the fusion process; e
Shift+Scale: Considering Shift+Scale among the |
selected images in the fusion process; Rotation is

not considered in this option;

Shift+Scale+Rotate: Considering Shift+Scale+
Rotate among the selected images in the fusion L=

Select the proper Auto Align mode according to whether there is shift, scale or rotate among the

process; If this mode is selected, The Maximum | masestobeprocessed.

H H . The time consumption of EDF is related to the setting of the maximum angle. The time will increase
Ang I e SI |de bar Wl I I be enabled y when the maximum angle increases and the relationship between them is non-inear. The default

maximum angle is 1.0%,

() Shift + Scale

(C)shift + Scale + Rotate

Maximum Angle: The Maximum Angle is used to
set the upper limit in Rotate alignment. The Default
is 1 degree. Range: 0.1~10; <Back Cancel

User can select the proper Auto Align mode according to whether there is shift, scale or rotation among the
images to be processed or not. The time consumption of EDF is related to the setting of the Maximum
Angle. The time will increase when the Maximum Angle increases and the relationship between them is
non-linear. The default is 1.0

Clicking <Back will return to Option dialog and clicking Finish will begin the EDF operating according to
the previous setup. The App will display the EDF (Extended Depth of Focus) progress bar as follow:

EDF (Extended Depth of Focus) X

Progress: -

The final EDF result is shown as below:

»

Lpp x

Note: Images used for fusing must be the same size;
otherwise there will be a prompt when adding different sizes |, Image: ‘Di\Demolmage\EDOREDOF. 12116 Btrajpg’ s notof the
of image to perform the EDF operation. The prompt dialog o

indicates which image is not the same size with the others.

1«ll

12.3.3 Browse/Thumbnail Window EDF Shift+F

Click the Folders Sidebar to activate the Browse window/Click the Browse button on the toolbar or choose
View>Browse to activate the Browse window. Double-click the directory to display the images in the
Browse window in Icon mode.
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o+
Choose View>Thumbnail command or click the Thumbnail button "% on the toolbar, all the images
captured/opened/Paste as New File created will be displayed in Icon mode.

App - [m] x
File Edit View Browse Setup Capture Image Process Layer Measurements Options  Window Help

A& B rie v NA o 5% | E . E -z
Folders * 2 H ¢ Browse X
eoloe

I —
Composite ~ = - Open
=-| | EDOF
EDOF_01
EDOF_02
EDOF_03
EDOF_04
EDOF_03
EDOF_06
EDOF_07
EDOF_08
EDOF_09
EDOF_10
EDOF_11
EDOF_12
EDOF_13
EDOF_14
EDOF_15
EDOF_17
EDOF_18

Cut Ctrl+X
-y Copy Ctrl+C
. Paste Ctrl+V
Paste Shortcut
Delete Delete

Sort

lcans

Refresh
. _bug_{c)_t...
| Properties...
M Stitch... Shift+T

[sil High Dynamic Range (HDR)...

23] ColorCo;nw/
= EDF.. Shift+F

B-5-5-E-8-8-8-8-u-E-a-a-g- - E-Eey

JFRSHT WP gy

< >
@‘Ce... EFO... [« JIEWRE- T ﬁm.”

E Measurement Sheet

green_bug_(c)_t... Jgreen_bug_(c)_t...

24 bpp 1600 x 1071 > 13,13

a) Clicking the displayed file icons, a single file will be highlighted;
b) Clicking the file one by one with Ctrl + left mouse button, all of the clicked files will be highlighted,;

c) Clicking the displayed file icons, the first clicked file will be highlighted, clicking the end file with
Shift + left mouse button, all the files among the first and last will be highlighted.

d) Dragging the mouse to draw a dotted line rectangle across the files you wish to delete, all of the files in
the rectangle will be highlighted:;

e) Ctrl+A /Edit>Select All to select all files in the Browse/Thumbnail window;

Clicking the right mouse button will display a context menu, choosing EDF submenu to start the image
fusion process (One can also choose Process>EDF<es command to do the same operation after the image
files are selected in the Browse/Thumbnail window).

After the Process>EDF command is chosen, a dialog
called Select Method is popped up which is just the same
as in the Image Window EDF operations. Please refer it
in the previous section (Sec.12.3.2) for detail. The final
EDF result is shown on the right side.

12.4 Deinterlace

When interlaced cameras is used to take the images, a complete images is divided into 2, 3 or more fields.
Since different fields are exposed and output at different time, there is no problem for a still object. But you
will see an image with interlaced content when the object is moving. Deinterlace algorithm is used to
resolve this problem. This function could find the difference between different fields automatically, correct
the location difference as much as possible and Deinterlace the image. But vertical resolution will be lost to
some extent and there will be some small shift.
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12.5 Color Compositesss i

Use the Process>Color Compositeee« dialog box to create and configure color composites using gray-scale
source images. You can access the Color Composite dialog box through the Color Composite menu item
from the Process menu.

You can combine gray-scale images into a color composite. Any group of gray-scale images that are of the
same size can be mixed in a color composite. Images of 8-, 12-, 16-bit integer or floating point format are
combined into a 24-bit color composite. Each input channel will have individual LUT adjustments, as well
as a registration offset to line it up with the rest of the images.

You can also combine individual channels from a single image. Each channel will be listed separately, as
shown here:

Color Composite

Source Images: Adjust

DemoGrn. TIF v Oal (®) sSelected

Add Delete Registration Contrast

B C G
Colors:

M| DemoBlue, TIF

Set Colo Freset -
Background:

None i MNew

Source Images: The Source Images combo box displays the images available for color mixing. The Source
Image list is initially filled with a list of the gray scale images that are currently open. The size of the color
composite is determined by the first input image selected. Once this is entered, the list is filtered to contain
only images of the same size as the initial selection;

Add: Click the Add button to add an image to the mix. You will be prompted for the color to be assigned to
that image from the Set Color dialog;

Delete: Use this button to delete the selected image from the list;

Colors: The Colors combobox displays the images selected for color mixing;

Color Composite

Source Images: 3 Adjust

DemoRed. TIF

Colors:

Add Delete

8| DemoBlue. TIF
DemoGrn. TIF

Background:

MNone

Set Color Freset

Cal

Registration

(@) selected

Contrast
B C G
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Coler Composite

Source Images: == Adjust
Coal (®) Selected

Registration Conftrast
B C G
Colors:

8| DemoBlue. TIF
DemoGrn. TIF
M| DemoRed. TIF

Background:

Mone = New

To change the color within the list box, double-click to select the image name (the Select Color dialog box
appears) or highlight the name and click the Set Color button.

To delete colors/images from the Colors list box, first click on the | seectceter x
color/image to highlight it then press the Delete button within the | ro fie:bemoeme
Color Composite dialog box. - : I .

Color Bar: The picture item box on the left side of the Colors list
indicates the color associated with each image in the composite, | st | [Rec09, Gen 255 e o0 |
The Color Bar will scroll with the contents of the Colors list box; | eres |[Reé258 Geen 25 s 258 |

Set Color: This option determines the Color used for the selected HER |
channel in the final image display. Clicking on the Set Color ——— .
button brings up the Select Color dialog box. -

Directly select a color by:
1) Dragging the Color Value Slider to the desired color on the Color Bar (range of 0 to 3599: or

2) Clicking the appropriate Color button on the Color Palette. The Color Bar represents Color degrees in the
standard color wheel representation, and the Color Palette contains a subset of possible Colors (pure red,
green, blue, cyan, magenta, and white) or

3) Select a dye in the dye list, and click the Select Dye button.

Note: You can navigate through the Select Color dialog box by using the <Tab> and <Shift + Tab> keys to
cycle through the items in the dialog box.

Intensity is determined by the image the Color is applied to, and saturation will always be 100%.

The only exception to this is the white Color, which has by definition a saturation of 0%. Selecting a value
greater than or equal to 360 (dragging the Color Value slider over to the far right) is a choice of white, which
results in a non-tinted (gray) image.

The elements of the Select Color dialog box are:

Color Bar: The Color Bar shows a rainbow displaying the Colors underneath the appropriate point of the
Color Value slider.

Note: If Color Value Slider is the selected (highlighted) selected control, then you can also control the
slider with keyboard strokes: a) Use the left/right arrow <-> or <->keys to move the slider incrementally; b)
Press the <Page Up> and <Page Down> to move the slider in chunk sections along the Color Bar; c)Use the
<Home> and <End> keys to move the slider to the beginning and end of the Color Bar.

Selected: This color block displays the new Color selected by the Color Value slider bar or the Color
Palette.

Selected Color: The Selected Color text field displays the corresponding numeric Color value of the
Selected Color block described above. The Selected Color value is expressed as an HSV color, with the red
value first, followed by the green and blue values. If the color corresponds to a dye color, the dye name will
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be displayed. If the dye color corresponds to a color palette color, the name of the color will also be
displayed.

Current: The Current color block displays the starting Color of the channel.

Color Palette: The Color Palette proves an alternate method of selecting a Color. Clicking on an item in the
Color Palette will set the Color Value slider to the correct value and update the displays in both the Selected
color block and Selected Color text field.

For example, clicking on the white button on the Color Palette will set the Color Value slider to the right,
change the Selected color block to white, and cause the Selected Color text box to display White.

Adjust: The controls in this section are used to adjust the color composite contribution from each image, or
for the color composite preview itself. You can adjust the input image that is currently selected in the Colors
list by clicking the selected button. When you want to adjust the color composite preview, or you want no
image is selected in the Colors list, use the All button.

Registration: Registration allows you to correct for mis-registrations of images caused by filter-induced
optical shifts. Use the directional keys to shift the selected image in the x- and/or y- direction, with respect
to the rest of the input images. One click moves that channel one pixel in the direction indicated. Blank
areas are filled with black. The key labeled 0,0 will re-center the selected image.

The registration shift for the selected channel or the overall image is displayed in the static text box below
the directional keys.

Contrast: Use the BCG sliders along with the Best Fit and Reset buttons to adjust the contrast of the selected
image or the composite;

BCG sliders: The Brightness, Contrast, and Gamma sliders are the similar to the Contrast Enhancement
feature in the App. You can also adjust each channel individually or collectively by using the Selected or All
radio buttons (to the left of the BCG sliders in the Adjust group box);

Best Fit: Click this button to perform a Best-Fit contrast stretch on the selected input, automatically setting
the Brightness and Contrast settings accordingly (Gamma will be reset to 50.). This method is identical to
the Best Fit contrast adjustment under the standard Contrast Enhancement feature of the App. Best Fit is
useful for first pass adjustments;

Reset: Pressing the Reset button automatically resets the BCG settings. If the Adjust radio button is set on
All, the BCG settings for the overall color image will be reset;

Frame: Use the frame slider to adjust the frame of the selected image that is used for the preview, or the
active frame of the composite. (Please see the discussion of Color Composite and Image Sequences that
follows this section.)

Background: Select one of the available images to be the background color in this combo box. The rest of
the image planes are subtracted from the background image — effectively punching holes into it and
allowing the foreground colors to show without mixing with the background. This is most effective where
the background covers large areas and the other images have smaller objects within the background objects;

Background allows the other inputs to be displayed in front of the background inputs, minimizing color
mixing. For example, the App can display a red dot on a blue background without turning the dot to
magenta.

Selecting None causes all images to be equally mixed.
New: Click the New button to discard the current color composite image, and start over;

The Source Images combo box will reset to include all gray scale images (including floating point images).
Selecting an image from the list will create a new composite the same size as the initial selection. As
mentioned previously, the source images list will be filtered to contain only images of the same size as the
initial selection.

12.6 Segmentation & Counteee
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Choose Process>Segmentation & Count command to realize the segmentation and count of the interested
image. The arrangement of Segmentation & Count is very special and some explanations are needed here to
clarify it in details:

1. The function provides users with five methods which are Watershed (W), OTSU Dark, OTSU Bright,
RGB Histogram, HSV Histogram and Color Cube. Users can select any one of those 5 methods, but after
selecting any one of them, the others will be disabled:;

2. After segmentation, there may exist adhesions. Then what we should do is segment connected object
manually by choosing Split Objects function;

3. When the users get the expected results, they can choose Counting Results menu and get the statistics
and analysis results.

According to the counting result, you can go back from step 2 or 3 to step 1 or 2 to repeat segmentation or
split objects operation.

Note: If the users choose None in the Label button at the Count Options dialog, then regardless of the type
of Method set, there is no Label for Index, Area or Perimeter on the image. But the None, Circle and Ellipse
will show the segmentation results. That’s why the App name the menu as Segmentation & Count. That is,
this function can achieve either the image Segmentation or Count. In this regard, please refer to the
Process>Segmentation & Count > Watershed in the Count Options dialog.

12.6.1 Manualeee

Manual cell counting is still the golden standard method of cell counting in many labs but the time at the
microscope counting cells is both laborious and time-consuming.

The App’s Manual counting method is a “touch count” method. As a fact, the user “touches”, e.g. clicking
with the mouse every single object to be counted on the image. It is possible to count different object
categories and label them with different Types and Colors, in order to separate them in a proper way.

Open or capture an image and choosing Process>Segmentation & Count>Manualsss command will invoke
the Manual Count dialog as shown below:

Manual Count X

Current Type  Color Count  Percent Add...

Close

The current list box has no items. It means no count is performed. There are 5 red to be counted red object
on the above left image.

Addeee: Clicking Adde«* button will pop up the Add dialog as shown below on the left side, define the name

in the Type edit box and Color in the list box. Here, the name is Red Objects and the color is - Click
Ok to return to the Manual Count dialog. Move the mouse to the on the image and click it on the to be
counted objects continuously to mark the object with the defined Color.
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Add *
Type: |Red Objects |
Calor:

The final manual count results for the Red Objects are shown below at the first row in the list box. One can
find that the Count number is 5, the Percent is 100%.

Manual Count X

Current Type  Color Count  Percent Add...
Red Objects [N 5 100.00% Delete

Freset W

0 Eraze

Export

Close

Continue the above process and count all the objects with different color. The final results on the Manual
Count dialog are list as below:

Manual Count X

Current Type  Color Count  Percent Add...

O Red Objects [N 6 16.67% Delete
] Magenta Objects [N 4 11.11%
O Yelow Objects I 6 16.67% reseE
O Mauve Objects 9 25.00%
] Brown Objects 5 13.89% @ Erase
= Dark Green Objects [N 6 67%

Total 36 100%

Export v

Close

Delete: Delete the unwanted items(Always be the Current checked one);

Preset:

Saveeee: Save the current Manual Count results with the preferred name such as ColorDot_en. The
saved. The name will be attachment to the end of the Preset list box;

Managementees: Choosing Management can Rename and Delete the saved items;

Erase: Becomes active only when the Objects inside the images have been “touched”. By activating the
Erase key, mouse cursor changes its shape and clicking every single object will Erase it from the image
and from the Count sheet.

Export: Once the counting is finished it is possible to click on Export: all the count results will be directly
exported to an Excel sheet or clipboard by choosing Export to Microsoft Excel or Export to Clipboard.

Current: The active label for the object to be counted; Click on the checkbox beside the object to be
counted in Current and move the mouse in the image: the cursor will change its shape, allowing to “touch”
every single object belonging to that category.

Type: Definition or name for the object to be counted,;

Color: Label Color assigned to the object;

Count: The counting number made for that object;

Percent: Percentual calculation of that category (if more than one category has to be counted).

12.6.2 Watershed eee
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Watershed segmentation method is a mathematical
morphology segmentation method, which based on

topological theory. The basic idea is taking the image | countoptions x
as a topological geomorphology on geodesy, and each | asoxmaton: [rone Ul Owthhoes
image pixel gray value indicates the altitude, | *%= _

boundaries of each local minimum value and its impact | = *™= © ©~ =

Label

area called catchment basins and the formation of | ...
watershed catchment basins. So the formation of the
watershed concept can be illustrated by simulating the
immersion process. In each local minimum value of the < vea md _

surface, piercing a hole, then the entire model slowly i S
immersed in water, with the immersion of the g et

deepening impact of the domain of each local minima e[ ] remm[ ]
slowly expands outward in two catchments basin at the
confluence build dams that form the watershed.

Type: Index ~

Watershed is suitable for relatively simple background target object or target object with a relatively large
difference between the background images instead of the more complex application.

Choose Process>Segmentation & Count> Watershedee+, there will pop up the following dialog:

Note: Segmentation & Count function only works for 24 bits, otherwise all the sub-menu items will be
disabled. Users can change the Color Bits to 24 bits by choosing Image>Mode>Color Quantizesss.

Approximation: Approximation including 3 options: 1)None: drawn the actual outline of the segmented
object; 2)Circle: The actual outline fitting into a perfect circle, users can get fit Radius of each object in

the Count Result dialog; 3)Ellipse: The actual outline fitting into a ellipse, users can get fit Axis of each
object in the Count Result dialog;

With Holes: When checking With Holes function, the segmented object’s Outline will be marked with
Color. Meanwhile the holes are also marked with Color and its parameters will be output in the image (Hole
is defined as the target grayscale or the color close to the background pixels). The left figure below is the
segmentation result without checking With Holes; the right below is on the contrary. With Holes option is
usually used to get hole parameters;

Outline>Style: Including 3 options: 1)Outline: objects are
marked by outline, the color can be user-defined; 2)Filled: the
segmented objects will be filled with custom colors; 3)None:
no marked outline for the segmented object;

Color: Custom colors used to mark the Style;

Label: Method: Including 3 options: 1)XOR: with the current pixel's XOR color to mark the current object
segmentation; 2)True: marked with the specified Color; 3)False: no mark for the objects;

Note: If users choose False in the Label group box, then regardless of the type of Method, there is no
display for Index, Area or Perimeter. But the None, Circle and Ellipse will displayed on the segmented
image. That’s why the App call it Segmentation & Count;

Color: Custom Color used to represent the color of Label. When selecting XOR in the Method, the Color
selection will be disabled, but the App will automatically mark the segmented image with the current
pixel’s XOR color;

Type: Including 3 options: 1) Index: use numbers to mark the segmented object. 2) Area: the object area
is marked by outline area size. 3) Perimeter: the object perimeter is marked by the outline perimeter;

Area:
Minimum: determine the lower limit of the area, that is, if the object area is less than the lower limit ,
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it will not be included;

Maximum: determine the upper limit of the area, that is, if the object area is greater than the upper
limit , it will not be included;

L - L Count Options X
e ", o © P
® g O ) ° ® “ e Approximation: | Ellipse - [ with holes
° - -
L ) o r 3 6 5 Cutiine
. . .. 5 o ® ... Style: Outline ~ Color: Cancel
° ~
» L J e 5 ™ . ¢ L Label
53 @ & Py . 0 L - Method: True w Color:
. e ° » -
A J » Type:
- e ..n A.. ; ... ... ¥p Index ~
Y ‘o0
. ® ® "o - ' B [] area {um?)
. ' v ki ] L > ¢ - h .
R ., ) —
e 20 8o ® 0
® . . . . “ Perimeter (um)
* = ® 0 o0 ¢
T @ .1
* s °®

Perimeter:

Minimum: determine the lower limit of the perimeter, that is, if the object perimeter is less than the
lower limit, it will not be included;

Maximum: determine the upper limit of the perimeter, that is, if the object perimeter is greater than
the upper limit, it will not be included;

The figure above shows image Segmentation & Count results with Watershed method with setting in Count
Option dialog.

OTSU is proposed in 1979 by Japanese scholars, which is a method to determine the threshold of an
adaptive, also known as OTSU method, referred to as OTSU. It is based on the gradation characteristic of
the image, and divided the image into the background and the target. The bigger the OTSU is between
background and the target, the larger difference between the two parts images. The wrong part of the
background or the wrong part of the target will lead to smaller differences between the two parts. Therefore,
the maximum OTSU means the minimum probability of misclassification.

OTSU Dark segmentation method means segment the dark object from the bright background using OTSU
algorithm. Its Count Options dialog is exactly the same with the Watershed Count Options. Below are
bright background with dark object (bottom left) and its segmentation result (bottom right) for reference:

P o =
’ S O 'é; (g( C§ é d
“ 4 ‘,J e @0 61
e v P &2 Ci?
3 . b g6 éﬁ

' . g%éo 3

OTSU Bright segmentation method means segment the bright object from the dark background using
OTSU algorithm. Its Count Options dialog is exactly the same with the Watershed Count Options. Below

are dark background with bright object (bottom left) and its segmentation result (bottom right) for
reference:
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RGB Histogram segmentation is based on image histogram where image pixels between a specified
histogram upper and lower range will be color processed. The segmented area can be adjusted by mouse to
drag two vertical lines in histogram, or by inputting precise value in RGB upper and lower edit box directly
and clicking Enter to make it effective. The Color representing the segmentation area can be customized by
system palette. For a 24-bit true color image, segmentation can be realized by R, G, B channels
respectively.

Choose Process>Segmentation & Count>RGB Histogrameee shows Histogram dialog, each function is
specified as below:

° 5. Left Value in the currently selected region of histogram segmentation, corresponding to Left

Vertical Line position in histogram. Users can segment the pixels bigger than the Left value by inputting a
value in this edit box or dragging the Left Vertical Line in histogram. When input a Left Value in this edit
box, users should click enter to make the value effective. Meanwhile, the Left Vertical Line will move to
the place the Left Value represents. Left Value range: O~current Right Value. The current Left Value is O;

ENSE Right Value in the currently selected
region of  histogram segmentation, | iegram x
corresponding to Right Vertical Line position cancel

in histogram. Users can segment the pixels,
bigger than the Left Value and smaller than
Right Value, by inputting a value in this edit
box or dragging the Right Vertical Line in
histogram. When input a value in this edit
box, users should click enter to make the
value effective. Meanwhile, the Right Vertical

Options...

- ; ! : ; :
0 0 150 20
o 79 = Blue il [ show Al

Line will move to the place the Right Value _

represents. Range: The current Left Value ™%

~255;

Red . Ahistogram channel of the currently RGB histogram. It can be R histogram, G histogram or
B histogram;

mshoval 1 Show all channel RGB histogram. When uncheck Show All, only a selected histogram channel
will be shown;

. Used to identify the Color of the segmented pixels; the default is green;
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oens- - \When users click Optionsees button, a Count
Options dialog pops up as below. The setting of Count
Options dialog is the same as that of Waltershed’s Count
Options  dialog, details can be referred to
Process>Segmentation & Count>Watershed(\W) ees;

Example of RGB Histogram is as follows:

1. Open an image and then choose Process>Segmentation
& Counting>RGB Histogramee* menu, a Histogram dialog
shows as below. When the mouse moves in the image area,
the cursor will be displayed as Color Picker Cursor;

Approximation:

Outline
Style:

Label
Method:

Type:

Area (px)

None

Outline

True

Index

Count Options

v

v

D With holes

oK

Color: . Default v Cancel

Histogram

Cancel

Options...

T
200

255

Blue

Show Al

2. Move Color Picker Cursor to any pixel of the image, shown as above, RGB value of the current pixel will
be displayed in the bottom Histogram window. Here R is 249 , G is 51 , B is 31, showing the RGB value

of the ideal segmentation area, record the three values.

3. Move the mouse to the background area, the RGB value of Color Picker Cursor is 79, 79, 79. In order to
accurately segment out the target, users can set RGB values of the segmented pixels in the initial interval,
and those of background out of the initial interval. For example, the RGB values can be set to the initial
interval as follows: R is set to the initial interval: 200~255; G is set to the initial interval: 0~60; B is set to

the initial interval: 0 ~ 60;

When setting completed, the segmentation effect is shown
on the right side.

4. Move again the Color Picker Cursor to any other
unshadded pixels, then the RGB value shown in left bottom
of histogram is 236, 60, 41 as below:

Histogram

e |

T
200

255

RGB: 236, 62, 41

o 50
E = E = Green

Show Al

Cancel

0K

Options...

It’s easily found that here G channel, defined 60, is too small to get the pixel segmented. Then initial
interval for G channel can be adjusted from 0~60 to 0~80 to segment the pixels nearby. (Note: If the
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background pixels of a single channel is within the initial interval, no segmentation change will take place.
Only all three channels of the background pixels are within the initial intervals can the pixels be segmented)
The segmentation effect by readjusting G initial interval is shown as below:

5. Repeat step 4 and readjust initial interval of each RGB channel to achieve perfect segmentation.
12.6.6 HSV Histogrameee

HSV Histogram segmentation is based on

image histogram where image pixels between i - g
a specified histogram upper and lower range

will be color processed. The segmented area
can be adjusted by mouse to drag two vertical sl
lines in histogram, or by inputting precise
value in HSV upper and lower edit box

directly and clicking Enter to make it ||j )

effective. The Color representing the & o
segmentation area can be customized by |° [0 5 e _B R L
system palette. HSV:

For a 24 bits true color image, segmentation can be realized by H, S, V channels respectively.

Choose Process>Segmentation & Count>HSV Histogramess command shows Histogram dialog as above,
each function is specified as below:

° 5. Left Value in the currently selected region of histogram segmentation, corresponding to Left

Vertical Line position in histogram. Users can segment the pixels bigger than the Left value by inputting a
value in this edit box or dragging the Left Vertical Line in histogram. When input a Left Value in this edit
box, users should click enter to make the value effective. Meanwhile, the Left Vertical Line will move to
the place the Left Value represents. Left Value range: O~current Right Value. The current Left Value is O;

” =: Right Value in the currently selected region of histogram segmentation, corresponding to Right

Vertical Line position in histogram. Users can segment the pixels, bigger than the Left Value and smaller
than Right Value, by inputting a value in this edit box or dragging the Right \Vertical Line in histogram.
When input a value in this edit box, users should click enter to make the value effective. Meanwhile, the
Right Vertical Line will move to the place the Right Value represents. Right Value range: current Left
Value ~255. The current Right Value is 79;

Fue “I7 A histogram channel of the currently HSV histogram. It can be H histogram, S histogram or
V histogram;

ishowal - Show all channel HSV histogram. When uncheck Show All, only a selected histogram channel
will be shown;

: Used to identify the Color of the segmented pixels; The default is green;

oetons- - \WWhen users click Optionseee button, a Count Options dialog pops up as below. The setting of
Count Options dialog is the same as that of Watershed’s Count Options dialog, details can be referred to
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Process>Segmentation & Count>Watershedsee;

Count Options X
Approximation: [ with hales
- - Outline
Example of HSV Histogram is as follows: st coor: [l vebeis I | conel |
1. Open an image and then choose Process> -
. - - Method: Tue w olor: o
Segmentation & Counting>HSV Histogrameee oo [
menu, a Histogram dialog shows as below. When e
the mouse moves in the image area, the cursor will Barea )
be displayed as Color Picker Cursor; Mo [ ] Meamm [ ]
Perimeter {px)
Minirmurm: l:l Maximum: l:l
A. Histegram *
' J’\nlll.‘“.n. t‘llllf'.x n . .
| 0 B 23 He v/ Mshowal
%i ‘ 1;‘,‘?" E _‘, j,é{-: HSV: 182, 114, 174

2. Move Color Picker Cursor to any pixel of the image, shown as above, HSV value of the current pixel will

be displayed in the bottom Histogram window. Here H is 182 , Sis 114 , V is 174, showing the HSV value

of the ideal segmentation area, record the three values;

3. Move the mouse to the background area, the HSV value of Color Picker Cursor is 214, 87, 228. In order
to accurately segment out the target, users can set HSV values of the segmented pixels in the initial interval,
and those of background out of the initial interval. For example, the HSV values can be set to the initial

interval as follows:

: e PR * oA |
H is set to the initial interval: 60~200; ™%, N 9 &
S is set to the initial interval: 90~130; » ¥ .::101,' >
V is set to the initial interval: 0~210; | ;’ "‘,',:’. % et
: . . Q2% ¢ &9
When setting completed, the segmentation effect is shown as below: e “..; 6".' .ol
e % P s
4.Move again the Color Picker Cursor to any other unshadded pixels, * o o '.._.“4: 0:.‘1
then the HSV value shown in left bottom of histogram is 196, 67, 222 as co OQSP 9 s
of .09 Pre o
below: % e e, |
'..“ﬁf‘ﬂ. ‘é‘ ,‘3 i
® W " hot
? ! .. "o- é‘ s ,?. 3 Histogram X
". l-. .‘_,ak‘. ‘. ‘4‘ Cancel
%D 05,8 & L.
g’ e“:%2:%" o ©
pe etedieny L8
¢ ; . d o.. ‘ ]
@ & 9 . p .
U @b, o <0 n
< & ® /\.'Il.JIlJ'LrJII\J'L . .
. f ® & “'" .o o 100 150 200 ez
LT 51 00" B [E e J Estown
..O“ QQN! ‘éd ,.... | Hsv: 196, €7, 222
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It’s easily found that here S channel, defined 90~130, its lower limit is too g
bigl to get the pixel segmented. Then initial interval for S channel canbe | _ sy
adjusted from 90~130 to 60~130 to segment the pixels nearby. Q-

Note: If the background pixels of a single channel is within the initial
interval, no segmentation change will take place. Only all three channels
of the background pixels are within the initial intervals can the pixels be
segmented) The segmentation effect by readjusting S initial interval is
shown on the right side.

5.Repeat step 4 and readjust initial interval of each HSV channel to achieve perfect segmentation.

Open an image and choose
Process>Segmentation & Count>Color
Cubee++, a dialog called Color will pop
up as shown on the right side;

~ Cancel
oK

Options...

At this moment, the Colorizing Pipette
A

is checked by default. Click the image
will set the average color value in the
masked area as Basic Value.

The App will segment the image by choosing the pixel within Basic ValuetTolerance color range and mark
it with current selected Color. By clicking the target pixel repeatedly, the App can continuously add new
pixels within the Basic ValuetTolerance color range into the target and thus acquiring continuous
segmentation colorizing.

When some undesirable pixels have been added into the segmentation data, the De-Colorizing Pipette can
be used to wipe off the undesirable pixels. This operation process is the same as Colorizing Pipette, that is,
to set the average color value of the clicked-pixel’s Mask Area as Basic Value and wipe off the
segmentation data, which is within the Basic Value+Tolerance color range.

A Colorizing Pipette: Collect average color value of the clicked-pixel’s Mask Area as Basic Value and
add pixels which are within Basic ValuetTolerance color range into the segmentation data;

A De-Colorizing Pipette: Collect average color value of the clicked-pixel’s Mask Area as Basic Value
and wipe off the segmentation data, which is within the Basic Value+Tolerance color range;

373 ¥ Mask Area: When Colorizing Pipette or De-Colorizing Pipette is used to click the image, a
Mask Area is also needed to calculate the average color value of the clicked pixel. The Mask Area’s color
value will be used as Basic Value. Color values within the Basic Value+Tolerance range can be added to or
wiped off from the segmentation data. The default Mask Area is 3*3, other options are 1*1, 5*5, 7*7;

RGB: The average RGB values of the Mask Areg;

Count Opti *
Tolerance: There are 3 Tolerance values, they are R, G and B. @t teee v LW
User can make fast and accurate object segmentation by = sse i  ©  coor Cancel

selecting a proper Tolerance value according to their | -

experience. The default R, G and B Tolerance values are 10; ™™ ™~ =
Type: Indk ~
_Def. eV i [l Area (um®)
— : Used to mark the color of the segmentation womar: [ ] Maewm [
area; The default Color is green; Dlpermeter m)
Minimum: I:l Maximum: l:l
Options...

: When clicking the Options button, a Count Options dialog as below will pop up. This dialog
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is the same as that in Process>Segmentation & Count>Watershedee«. Please refer to Process>Segmentation
& Count> Watershedee+ for the detailed operation of this dialog;

Here is an example to demonstrate the Color Cubic
segmentation process:

1. Open an image as shown on the right side;

2. Because of the inevitable noise in the image, an image
smooth operation should be done first. There are many
algorithm$ t0 perform the image smooth operation and here we
are to process it as follows: choose Process>Filter menu and
click Morphological property page and a dialog will pop up
with parameters as shown in the figure below on the left side.
Click OK and the final smoothed image is shown below on

the right side;
Filters ps
Image Enhance  Edge Enhance  Morphological  Kernel
Filters Sample
(O Erode (O Gradient
(O pilate () Distance
(® Open (O Thinning
(O Close (Owatershed
(O Top hat
O well
Options
(0 2x 2 5quare ® 3x3Cross (O 11x 11 Circe
(3% 1Row (5% 5Crde Passes |1 =
() 1% 3 Colomn (7% 7Cirde
Undo Cancel Apply

i Cancel
0K

Options...

4. At this moment, the Colorizing Pipette is checked. Click the pixel wish to segment. That is to say, select
the color area which is interested in. If some undesirable color area is included in the segmentation area, just
check the De-Colorizing Pipette and click the undesirable pixels, thus the undesirable pixels will be wiped
off. When the segmentation process is completed, click OK and the Segmentation & Count operation will
be carried out;
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The result of segmentation after the first clicking at the pointed The result of segmentation after the second clicking at the
area with Colorizing Pipette pointed area with Colorizing Pipette

The result of segmentation after the second with the
De-Colorizing Pipette (slight difference exists as inaccuracy in
position)

5. Click Options to set Outline, Label and etc., the final results is shown below. So far the primary
segmentation is completed.

The result of segmentation after countless clicking with
Colorizing Pipette

12.6.8 Split Objects

It can be found out in this segmentation, particle #16 (located in the upper middle of the image) is not a
single object but actually two separate one. However they have been calculated as a single object. Choosing
Split Objects will correct this problem. Object splitting with Split Objects is discussed below.

As is shown in the image below, move the cursor onto target #16.
Click the left mouse button and draw a straight line.

When pressing down the left mouse button, the cursor should not
touch the target —— the starting point of the split line should be
off the target that is to be separated. Move the cursor to the
bottom right of the target—— the ending point of the split line
should also be off the target that is to be separated. Release the
left mouse button when this operation is completed. A split line
is shown between the two adhesive objects as shown below:

After the left mouse button is released, the App will re-count the whole image. The result of re-counting is
shown as below. The previous #16 turns out to be #12 and #17 now:
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Unchecking or choosing Split Objects menu again will hide the split line. The final result of hiding the split
line is shown as below. The whole Split Objects process is completed when the split line is hidden.

12.6.9 Count Resulteee

Count Result is a way to show count statistical result of the current image. Count Result dialog includes

Index, Center, Radius(major-minor axis or non), Area and Perimeter, as is shown below. The unit of

statistical result is the same as what the user selects in the Unit for the displayed image. Click Index, Center,
Radius (major-minor axis or none), Area and Perimeter and the statistical result will be automatically sorted
according to their data. Choosing a certain item can check the split object in the image. In the meanwhile,
Index (or Area and Perimeter) of the other targets will be hidden automatically.

The Center column in Result is relevant to the Approximation option in the Options dialog. When selecting
Circle, radius of the circle will be listed as Radius column and when choosing Ellipse, major-minor Axis of
the Ellipse will be listed as Axis column; when selecting None, no column shows up.

click Export and then the statistical result, together with the image of Segmentation & Count, will be
exported to an Excel sheet for further analysis and processing.

Result *
w v Index Center Area Perimeter =
‘. . i e 1 (435045.34, 510105.56) 262971304.25 96385.44
' ’ " . . 2 2 (58832165, 510550.62) 285897725.69 B8308.52
@ o 0 ‘J, } 3 (198188.79, 503401.51) 380718604.650 129547.81
S ‘ [ S . i 4 (1621265.44, 497422.19) 43350718750 114939.31
5 (338798.96, 485907.29) 392794353.30 110010.81
o - ‘ ‘ Y ‘ ‘ 'y ' ‘ . > & (98292.71, 477705.21) 10115627.17 3388140
' . 7 (535756.04, 482307.67) 394649468.32 103853.40
‘. 9. @ ‘ ‘. w . 8 (77787.50, 471619.79) 46632394314 135443.85
¢ . & (Y 3 (248046.87, 471487.50) 443777886.28 133444.57
@ 9 P - / 10 (46657. 18, 471369.13) 46689394748 215270.13
“ & ” 11 (218678, 12, 457200.00) 3640225.69 2471128
J @ (2 ® ' e 12 (35943646, 463946.87) 430631699.22 133198.79
o O, .9 @ © {113 (203580.40, 462205.22) 434271924.91 118616.89
3 f .'_' - 14 (146314.58, 451379.17) 3850238.72 31189.68
~ ) ‘ - & ‘ . 15 (127254.58, 462991.67) 50228114143 12953643
y ~ e { 1 (134414.58, 449130.21) 13545339.84 21434.48
9| . i . 17 (320220.70, 451830.08) 596681994.36 135224.66
) &‘-‘ w . o e o aemenn oo e o - v
{ - g S - <t
¥ % % o % ®6 o oo
@ - ;

12.7 Denoise

The App provides 3 types of noise removal methods, Adaptive Wiener Filter, Bilateral Filter and Non Local
Means. The processing speed of the 3 methods is from fast to slow, and the denoising quality is getting
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better and better. Each method is described in detail in the following:

The Adaptive Wiener Filter can preserve more image details than those of median filter, mean filter, Gauss
filter. The effect is more remarkable for additive noise (such as Gaussian noise) and multiplicative noise
(such as Poisson noise).

For the Adaptive Wiener Filter algorithm, please find its details in the relevant literatures, here only to
illustrate the improvement of Adaptive Wiener Filter over the classical Wiener Filter.

In the classical Wiener Filter, the image noise intensity requires the user to manually input, but it is difficult
to accurately enter the accurate value even for experienced users, because the value is usually very small,
such as 0.0036781. Therefore in the development of the Adaptive Wiener Filter, the noise level is
automatically calculated according to the image mean variance.

The process is quite simple, open an image, choose Process>Denoise>Adaptive Wiener Filter command to
denoise the image.

The Bilateral Filter is a nonlinear filtering method that considers image spatial proximity, pixel value
similarity, image spatial information and gray level similarity to achieve the purpose of edge preserving
denoising. The Bilateral Filter has the simple, non-iterative, local characteristics. The Bilateral Filter is
good to preserve image edge compare with Wiener Filter or Gauss filter.

Bilateral Filter x

Choosing Process>Denoise>Bilateral Filterses will
pop-up a dialog called Bilateral Filter shown on the | value comai: g
right side: ]

Space domain: 20

Value domain: the range of neighborhood pixel in
radius for considering, the greater the value, the f
slower the processing speed.

Cancel

Space domain: Sigma value, the higher the value, the more effective the denoising effect.

The traditional local mean filter is a pixels average method around the target pixel, but the Non Local
Means is a weighted average method to average all of the image patches over the search window. The
weight is determined according to the similarity between the target patch and neighborhood patches in the
search window.

Compared to other famous denoising algorithms,

such as Gaussian, Wiener Filter, total variation and | nenLocaiteans X
wavelet denoising, The Non Local Means method | svengtn 5
can get better effect. 'y

Choosing Process>Denoise>Non Local Meangees | et s 7
will pop-up a dialog called Non Local Means as A

shown on the right side. Search Window: 2t
Strength: The denoising strength, the greater the .

value, the more removal the image noise, but will Conee

lose more details;

Template Window: The template block size, used to calculate the weight, the recommended default value is
7

Search Window: The template patch search window size, used to calculate the weighted average value
among image patches. Large value will increase the processing time. The recommended default value is 21.
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Block-matching and 3D filtering (BM3D) is a 3-D block-matching algorithm used primarily for noise
reduction in images

BM3D x

Strength: 1
any other
. patch Q
Template Window: a n .l Kk
=
overlapping

Search Window: 16 patches

E
. n
Cancel Defaults

Strength: The denoising strength, the greater the value, the more removal the image noise, but will lose
more details, the defaults is 1;

search windows

Template Window: The template block size k x k, used to calculate the weight, the recommended default
value is 4x4; range: 1x1~1616;

Search Window: The template patch search window size n x n, used to calculate the weighted average value
among image patches. Large value will increase the processing time. The recommended default value is
16x16; range: 4>4~64>64.

12.8 Sharpen

Unsharp Masking (USM) is an image sharpening technique, often available in digital image processing
software. The "unsharp™ of the name derives from the fact that the technique uses a blurred, or "unsharp”,
positive image to create a mask of the original image. The unsharped mask is then combined with the
negative image, creating an image that is less blurry than the original one.

Open an image and then choose Process>Sharpen>USMeee command, a dialog will pop up as shown
below:

Unsharp Mask x

Radius: Affect the size of the edges to be enhanced,
so a smaller radius enhances smaller-scale detail. | o ) '
Higher Radius values can cause halos at the edges.

As a result, fine detail needs a smaller Radius. In | "~ h :
addition, Radius and Amount interact; reducing | amess 8 1
one allows more of the other. _ .

Threshold: Controls the minimum brightness change that will be sharpened. This parameter is important to
prevent smooth areas from becoming speckled. The Threshold setting can be used to sharpen
more-pronounced edges, while leaving subtler edges untouched. Low values should sharpen more because
fewer areas are excluded. Higher threshold values exclude areas of lower contrast.

Amount: is listed as a percentage, and controls the magnitude of each overshoot (how much darker and how
much lighter the edge borders become). This can also be thought of as how much contrast is added at the
edges. It does not affect the width of the edge rims.

A
LA.~"- 2 IV F) ". ;“, :“ 2 /(

a) Original image b) Sharpened image
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12.8.2 Laplacian Sharpen

The Laplacian operator is an example of a second derivative method of enhancement. It is particularly good
at finding the fine detail in an image. Any feature with a sharp discontinuity (like noise, unfortunately) will
be enhanced by a Laplacian operator. Thus, one application of a Laplacian operator is to restore fine detail
to an image which has been smoothed to remove noise.

Open an image and then choose Process>Sharpen>Laplacian Sharpen, no parameter is required for this
method.

a) Original image;

12.9 Color Toning

b) Sharpened image

12.9.1 Gammases

The Process>Color Toning>Gammases measures the brightness of

midtone values produced by a device (often a monitor). A higher | camms adusiment X
gamma value yields an overall darker image. A —
Gamma: Dragging the slider bar to the left decreases the level, while [

moving it to the right increases the level. Values can range from 0 to
3.0. Default is 1.0.

12.9.2 Histogram Equalizationeee Shift+Q

Adaptive histogram equalization (AHE) is a computer image processing technique used to improve contrast
in images. It differs from ordinary histogram equalization (HE) in the respect that the adaptive method
computes several histograms, each corresponding to a distinct section of the image, and uses them to
redistribute the lightness values of the image. It is therefore suitable for improving the local contrast.
However, AHE has a tendency to over amplify noise in relatively homogeneous regions of an image. A
variant of adaptive histogram equalization called contrast limited adaptive histogram equalization (CLAHE)
prevents this by limiting the amplification.

Open an image and then choose Process>Color
Toning>Histogram Equalizationees, a dialog
should pop up as shown on the right side. Strengih 10

Strength:  The Strength will affect the h
enhancement effect. The larger the Strength, the
more obvious the effect.

Histogram Equalization X
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a) Original image; b) Enhanced image
12.9.3 LCCeee

The Local Color Correction algorithm is calculated in 2 steps:

A mask image is calculated from the input image.

The mask image is calculated from the intensity component of the color image, defined as the average of R,
G and B values i.e. I=(R+G+B)/3. The use of intensity information avoids distortions of the chroma. The
mask image is obtained by inverting and then blurring the intensity component of the input image.

The input and mask images are combined to get the result.

The combination operation consists of a power function, where the exponent is calculated using the mask
value previously found. If the mask value is greater than 128, it will result in an exponent less than 1, while
if the mask value is lower than 128, it will result in an exponent greater than 1. Moreover, if the mask value
is precisely 128, the exponent will be 1, and it will have no effect on the input image. The operation is
equivalent to a pixel-wise gamma correction.

Please open an image and then choose Process>
Color Toning >LCCeee, a dialog should pop up as | teccelor Correction X
shown on the right side.

Strength: a9

Strength : The strength will affect the enhancement ]

effect. The larger the value, the more obvious the P
effect. Range: 1~100, default is 50.

a) Original image; b) Enhanced image
12.9.4 AMSR

There are limited dynamic range problems when real world scenes are captured from a digital camera and
displayed on monitors. Tone mapping algorithms are applied to image processing to reduce the dynamic
range of an image to be displayed on low dynamic range devices. Multi-scale Retinex is one of the most

popular methods for dynamic range compression, color constancy and color rendition. Here, we improve its
performance by adopting the adaptive weight functions, named Adaptive Multi-scale Retinex (AMSR).

Choosing Process>Color Toning>AMSR, the a) Original image; b) Enhanced image are shown as below:

{2y T

a) Original image; b) Enhanced image
12.10 Filtereee Shift+l

Choose Process>Filters=« command to apply one of the App's numerous filters on the active image. If you
are not familiar with the process and effects of filtering, some discussions about spatial filtering should be
reviewed. The App provides an extensive set of convolution and no convolution (morphological) filters.
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You can also create custom filter kernels and apply them with the Filter commands.

Choosing Process>Filter command will open the Filter dialog. Each group of filters has its own property
page or tab, where the Filter type and size can be selected. The filtered results are almost always written to
the active image. The Edit>Undo command can be used to remove Filter operations that have been applied.

Low Pass: Select this filter to soften an image by eliminating high-frequency information (this has the effect
of blurring sharp edges). The Low Pass filter replaces the center pixel with the mean value in its
neighborhood. The Low Pass filter can also be used to remove noise;

High Pass: Select this filter to enhance high-frequency information. The High Pass filter replaces the center
pixel with a convolved value that significantly increases its contrast from its neighbors. The High Pass filter
leaves only elements of high contrast;

Gauss: Select this filter to soften an image by eliminating high-frequency information using a Gauss
function. This has the effect of blurring sharp edges. The operation of the Gauss filter is similar to the Low
Pass filter, but it degrades the image less than the Low Pass filter;

High Gauss: Select this filter to enhance fine details. This | fiter X
operation is similar to the unsharp masking technique | maerance cdgecrhonce Morphobogial  Kerne
(see the Sharpness filter), but it introduces less noise into ;“fp oa e
the image. It uses a Gaussian curve type of kermel. | S o
Available in 7x7 and 9x9 kernel sizes; O Gauss OMedian
High Gauss Rank
Equalization: This filter is used to enhance the contrast gsqguauzamn °

based on the histogram of the local neighborhood (See option

Option below); @33

- - . . Os5xs Passesl::
Sharpness: Select this filter to enhance fine details, or O svensth [1 12
refocus an image that is blurred. The sharpen filter
sharpens the image using the unsharp masking technique; — aocly

Median: Select this filter to remove impulse noise from an image. The Median filter replaces the center
pixel with the Median value in its neighborhood. It will also blur the image;

Rank: Select this filter to remove impulse noise from an image. The pixels in the kernel are ranked by order
of intensity, and the pixel in that range at the rank percentage is chosen for comparison. For example, in a
5x5 kernel, there are 25 pixels. A rank percentage of 95% would choose second-brightest pixel for
comparison. If the difference between the selected pixel and the center pixel is greater than the threshold
value, the Rank filter replaces the value of the center pixel with the value of the selected pixel;

Option: 1. If one of the Enhancement filters is checked, the following options will be displayed:

3 x 3: Select 3 x 3 kernel will produce a more subtle filtering effect;
5 x 5: Select 5 x 5 kernel will produce a moderate filtering effect;
7 x 7: Select 7 x 7 kernel will produces a more extreme filtering effect;

Passes: Set the filter applied times on the image. When a filter is applied multiple times, its effect is
amplified by each pass. An image that has been softened by one pass of the Low Pass filter will be softened
further by a second pass;

Strength: Enter an applied value from 1-10 that reflects how much of the filtering effect on the image.

A value of 10 specifies the full strength (100%) of the filtered result applied to each pixel. Values less than
10 cut the full weight of the filter. A value of 1 indicates that only 10% of the difference between the filtered
pixel value and the original pixel value should be applied, a value of 2 indicates that 20% of the difference
should be applied, and so forth.

Rank: This value specifies which pixel in the sorted array will be used to replace the center pixel. Pixels in
the array will be sorted in ascending order. The pixels are indexed from 0 to Kernel Size x Kernel Size-1. In
the pixel index O corresponds to the lowest pixel value;
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The Rank will be specified in terms of a percentage of the indexes (Kernel Size x Kernel Size-1). A 50%
Rank means the middle of the array. 0% rank means the lowest index (lowest gray value), and 100% rank
means the highest index (highest gray value);

Option: 2. If the Equalization filter is checked, the options will relate to the histogram equalization. Local
Histogram Equalization modifies the contrast of an image based on the pixel values in a small window
surrounding each pixel;

Window: Image pixels statistics (min, max, histogram, mean, standard deviation, etc.) will be calculated on
a small Window of the image. These measurements are then used to derive the local contrast for that area of
the image. In short, an area of Window x Window around each pixel is all that is considered when
modifying the intensities in the image. Larger Window produces smoother results, while small Window
track small details more closely;

Best Fit: Choose Best Fit button to optimize the values for the particular image. The results are achieved by
stretching the local histogram to maximize the contrast between the brightest and darkest pixels in the local
window region;

Linear: This option distributes the histogram linearly across the intensity scale. This function produces a
high contrast image with the highest possible dynamic range;

Logarithmic: This option concentrates the histogram at the low end of the scale. This function produces a
high contrast image with little dynamic image. It will tend to darken the image overall. It is useful for
increasing the contrast in a very light image

Exponential: This option concentrates the histogram at the high end of the scale. This function produces a
high contrast image with little dynamic image. It will tend to lighten the image overall. It is useful for
increasing the contrast in a very dark image.

Sobel: Select this filter to enhance just the principal edges in an image. The Sobel applies a mathematical
formula to a 3x3 neighborhood to locate and highlight its edges.

Roberts: Select this filter to enhance fine edges in an image. The Roberts filter is not a convolution filter. It
applies a mathematical formula upon a 4 x 4 neighborhood to produce its effect. The upper left pixel in the
neighborhood is the one that is replaced.

Sculpt: Select this filter to apply a sculpted effect on the image;
Horizontal: Select this filter to detect and emphasize horizontal edges;
Vertical: Select this filter to detect and emphasize vertical edges;

Options 1. If one of the Edge filters has been selected, the
options will relate to kernel size and filtering strength. The
following options will be displayed: Fiters X

Image Enhance  Edge Enhance  Morphological  Kernel

3 x 3: Select 3x3 kernels to produce a more subtle Cltere

Sample

filtering effect; @ sobel
() Roberts
5 x 5: Select 5x5 kernels to produce a moderate filtering 8f;:::;
effect; O Variance
() Horizontal
7 x 7: Select 7x7 kernels to produce a more extreme Overteal

Options

filtering effect.

Passes: Enter the number of times that the filter will be
applied to the image. When a filter is applied multiple
times, its effect is amplified by each pass. An image that
has been softened by one pass of the Image Enhancement
Filter, will be softened further by a second pass;

Cancel Apply
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Strength: Enter a value from 1-10 that reflects how much of the filtering effect to apply to the image. A
value of 10 specifies that the full strength (100%) of the filtered result will be applied to each pixel. Values
less than 10 cut the full weight of the filter - a value of 1 indicates that only 10% of the difference between
the filtered pixel value and the original pixel value should be applied, a value of 2 indicates that 20% of the
difference should be applied, and so forth.

Option 2. If Sobel or Roberts is selected, no options are available.

Erode: Select this morphological filter if one wants to modify the size of objects in the image. The Erode
filter erodes the edges of bright objects and enlarges the edges of dark ones;

Dilate: Select this morphological filter if one wants to modify the size of objects in the image. The Dilation
filter dilates bright objects and erodes dark ones;

Open: Select this morphological filter if one wants to modify the shape of objects in the image. Assuming
the image contains bright objects on a dark field, the Open filter will smooth object contours, separate
narrowly connected objects, and remove small dark holes;

Close: Select this morphological filter if one wants to modify the shape of the objects in the image.
Assuming the image contains bright objects on a dark field; the Close filter will fill gaps and enlarge
protrusions to connect objects that are close together;

Tophat: Select this filter to detect and emphasize points, or | e x
gralns’ that are brighter than the background There are 3 Image Enhance  Edge Enhance  Morphological | Kernel
kernel sizes for this processing. Click the radio button to | == :

N (®) Erode () Gradient
change the kernel size to the value that most closely | oOoke Ouistance
matches the size of the grains to detect; 83"“ gx'z'“i )

Well: Select this filter to detect and emphasize points, or | =™
grains, that are darker than the background. There are 3

Options

kernel sizes for this processing. Click the radio button to Ozx2sque  O3x3cross O ttxticrde
change the kernel size to the value that most closely OsxtRaw  @sx5Crde passes [1_[2
matches the size of the grains to detect; Otxscdom  O7x7crde

Gradient: Select this filter to enhance edges in an image; p— p

Distance: The Distance filter is used to show the distances of pixels within blobs to the outer boundaries of
those blobs. After applying the distance filter, the background will be black (i.e. pixels with value 0). Only
the area within the blobs will have non-zero values (will be white). The values of each pixel within the blob
will be a count of the shortest distance from that pixel to the edge of the blob. Thus, all pixels along the
blob's border will have a value of 1 (since they are one pixel away from the edge of the blob); pixels that are
a distance of 2 from the border will have the value 2, and so on. This creates a distance map of the image.
The Distance filter will not operate upon True Color images. If one wants to use the Distance filter with a
True Color image, he must first convert it to Gray Scale;

Thinning: Select this filter to reduce an image to its skeleton. When choosing this filter, one must set the
threshold that determines whether a pixel is part of the subject or part of the background (see Options
below). The Thinning filter will not operate upon True Color images. If one wants to thin a True Color
image, he must first convert it to Gray Scale;

Watershed: Select this filter to separate objects that are touching. The Watershed filter erodes objects until
they disappear, then dilates them again, but will not allow them to touch. The Watershed filter will not
operate upon true color images. If one wants to separate objects in a true color image, he must first convert
it to Gray Scale (see Process Frame: Image>Gray Scale);

Options 1. If Erode, Dilate, Open, or Close filters is checked, the options will relate to the kernel size and
shape. The following options will be presented:

2 X 2 Square: Select to use the 2x2 square kernel configurations.
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3 x 1 Row: Select to use the 3x1 row kernel configuration.

1 x 3 Column: Select to use the 1x3 column kernel configuration.

3 x 3 Cross: Select to use the 3x3 cross kernel configuration.

5 x 5 Circle: Select to use the 5x5 circular kernel configurations.

7 x 7 Circle: Select to use the 7x7 circular kernel configurations. This is a two-pass filter, accomplished
using a 5 x 5 circle followed by a 3x3 cross.

11 x 11 Circle: Select to use the 11 x 11 circular kernel configurations. This is a three-pass filter,
accomplished using a 5 x 5 circle followed by another 5 x 5 circle, followed by a 3 x 3 cross.

Passes: Set the number of times iterate the filter.

Note: The circular kernels are especially effective on round objects (cells, grains and so on) because their
circular configuration preserves the circular shape of the objects better than square configurations.

Option 2. If the Tophat, Well, or Gradient filter is selected, the options will relate to kernel size and shape.
The following options will be presented:

3 x 3: Select to use the 3x3 square kernel configurations.
5 x 5: Select to use the 5x5 square kernel configurations.
7 x 7: Select to use the 7x7 square kernel configurations.

Option 3. If Watershed, Thinning, or Distance filter is selected, the options will relate to the threshold. The
following option will be presented:

Threshold: Enter a percentage value from 1-100 that specifies the intensity value to binarize the image. For
example, a Threshold of 50% on a Gray Scale image would set all values <127 to 0 (black) and all values
>128 to the maximum value for that image class (white).

The Kernel page allows edit the kernel files for morphological & convolution filters.

Filter type: Select to modify the kernel for a selected Filter type, either Convolution or Morphological
filters;

Editee: Invoke the Edit Kernel dialog to modify the selected filter kernel;

Nameeee: This combobox contains the name of the selected kernel file. If one wants to save the modified
kernel file to the same file, leave it as it is. If one wants to save the file to a new location, enter the new
filename here;

Kernel Size: Click the spin buttons or enter the number to change the size of the kernel. Either direction
may take into account one to nine pixels. As one modifies the Kernel Size, the shape of the kernel
representation changes accordingly. In the center of the dialog, there are white boxes containing
coefficients that will be multiplied with each pixel that will be taken into account by the filter kernel. One
can change any coefficient by clicking on it and adjust it as desired;

Fill: Click this button to Fill every element of the kernel | ™ x
with a particular value. The Fill kernel dialog appears. One imge Erenes Soeiotence Mottt Kerel

. - ilter type
may enter a value between 0 and 10. Using the Fill button ® canvoluton O Morphologicl

is useful for setting all coefficients to the same value. One Kernels
may then change the coefficients that require a different
value;

Offset: The pixel whose value is being modified is usually
the center-most pixel. One may, however, designate any

pixel. The App signals the pixel to be changed by putting a S:Qm%
box around it. Choose X and Y Offset spin buttons to )
apply, Undeo Cancel Apply

Neweee: Click to create a new filter kernel. The Edit Kernel dialog will appear. The functions of the dialog
are the same way as the dialog for Editee described above), with the exception that the file name for the
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new kernel file must be provided,;
Delete: Click to delete the selected filter kernel file;
Options: The choices in this group box will vary depending upon the kind of selected filter.

Note: The HiPass, LowPass, Laplacian and Unsharp kernel files are used by the HiPass, LowPass,
Laplacian, and Sharpen options listed in the Image Enhancement Filters page dialog window (i.e. there is
no difference between selecting one of these kernel files and selecting its Option button in the Filter
window -- the 2 methods ultimately do the same thing). Because these kernel files are essential to the
operation of these filtering options, they must not be deleted or renamed.

12.11 Image Stackingeee =

The Image Stacking method is a form of speckle imaging commonly used for obtaining high quality images
from a number of short exposures with varying image shifts or rotations. It has been used in astronomy for
several decades, and is the basis for the image stabilization feature on some cameras. The method involves
calculation of the differential shifts of the images. This is easily accomplished in astronomical images since
they can be aligned with the stars. Once the images have aligned, they are averaged together. It is a basic
principle of statistics that variation in a sample can be reduced by averaging together the individual values.
In fact, when using an average, the signal-to-noise ratio should be increased by a factor of the square root of
the number of images.

Image Stacking can also be used for biological microscope image and florescent microscope image to
increase the image SNR and dynamical ranges; this is why the App introduces Image Stacking function in
the Process menu.

The App’s Image Stacking introduced advanced image matching techniques for rotated, shifted and scaled
images. The user can record a short video to get a high quality stacked image at ease without considering
the image rotation, shifting and scaling between a series of images in the video. The steps of Image
Stacking are described as below:

1. Choose Processing>Image Stackingess command, an Open dialog will pop up as shown below;

Open x
&« v A « Data (D:) » Demolmage » Stack v @ Search Stack pel

Organize » New folder = -~ T @

ImageCount
Sample
SCMOS05100KPA
Stack

Stitch v 021222).avi

File name: |12(DDDDDE1 58-000021222).avi V| Video Files (*wmv;*.ash*avi;*r ~

2. Choose right video file recorded before in the Open
dialog, here we can open avi file for demonstration, | ™"

click Open to open the avi file [ —
3. Then an Image Stacking dialog will pop up to show

the progress of the each image’s stacking progress.

4. If Cancel is pressed, the Image Stacking will be canceled. After the stacking is finished, a stacked
image will be displayed in a new window for further application. The final image is shown on the right
side. One can find the stacked image signal to noise ratio is greatly improved. The stacked image has
some black edges, this is because the images in the video is moved and in the stacking process, the App
will added 0 to the image area that has no corresponding pixel in the reference image (The first image is
chosen in the video file as the reference image).
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Note: a) The App supports wmyv, asf, avi, mp4, mdv, 3gp, 392,
3gp2, 3gpp, mov, mkyv, flv, rm, rmvb for Image Stacking operation;
b) In the Image Stacking process, the App takes the first frame as
the reference image, this means the first frame is very important and
should be assure the first frame to be the right image scene and the
subsequent frames have a greater overlap region with the first
frame.

Video Files (*.wmv;*.asf:*.avi;*.mpd
All Files (*7)

12.12 Line Profileeee

Choose Process>Line Profileses command
to illustrate how pixels along a selected line
or curve are distributed by graphing the
number of pixels at each color intensity
level. Both video and image windows
support the Line Profile function. For video
window, the profiles will be updated
dynamically.

| X NA L i D
Choose Measurements>Line>Arbitrary Line, Line Horizontal Line, Vertical Line, Multipoint Connection,

Line(3 Points)>Arbitrary Line, Line Horizontal Line, Vertical Line , Curve>Random Connection,
Multipoint Connection command (shown below) to draw a line or curve on the image.

/" Arbitrary Line
— Horizontal Line / Arbitrary Line

| Vertical Line — Horizontal Line . Random Connection
#~ Multipoint Connection 1 Vertical Line 7 Multipoint Connection

Choosing Process>Line Profile will bring up a Line Profile dialog as shown below (The procedure can be
inversed):

In a Line Profile dialog, the horizontal axis represents the spatial scale, and the vertical axis represents the
intensity values range from 0 to 255. If the image is a gray scale image, only the gray value will be
profiled. If the image is a HSV color image, the R, G, B and the brightness values will be profiled
separately  with  the corresponding R, G, B and black colors. Its toolbar

H | A S+ l-FF e MM

Line Profile x

Hl Ty o+ l-|mmo B D

button functions are described as follows:

R e T S

20 40 60 80 00 120 140 160 180 200 220 240 260 280 30’0

%: Fit the current Line Profile window to the best scale;
105



Process

: Zoom in the current horizontal axis;

: Zoom out the current horizontal axis;

I+ Zoom in the current vertical axis;

I Zoom out the current vertical axis;

3. Copy the Line Profile window's content to the clipboard;

e. Capture the image in the Line Profile window as a new numbered image;

Ll“g: Save the Line Profile image in png or bmp format;

L : Export the current Y axis values of R,G,B and brightness to the *.txt file(check to select).

~!: Open the windows color dialog to set the background color of the profile window;

Only when the line is selected, the Line Profile can be painted in the window. Using Object Select button
% on the toolbar to select the line over the image or video window.

12.13 Surface Ploteee

The Process>Surface Ploteee (or 3-D Plot) tool creates a 3-D representation of the intensity of an image.
When choosing Surface Plot command, keep in mind that X=image width and Y=image height, and
Z=pixel gray value.

Image Background Color
=

In the viewpoint window, the elevation and rotation of the image can be adjusted by dragging the mouse on
the image.

Position Solid: The left edit control indicates the relative position of the entire image in the viewpoint
window, whose default value is 0.5. The right edit control indicates the relative height of the display of the
Z scale, whose default value is 1;

Reset: Set the Position Solid's two edit controls to their default values;

Image Background Color: Choose this command to display a color dialog where one can adjust the
background color of the viewpoint window;

Capture: Capture the active image in the viewpoint window as a new image;

Color Table: Select the colors to map the gray values found in the surface plot. The button at each end of the
Color Table brings up the color dialog, which allows select the start and end colors of the range. (Please
refer to Pseudo Color for more information)

12.14 Pseudo Coloreee
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Note: Image must be in Gray Scale.

Pseudo Color X

Choose Pseudo Color command to “colorize" the active
monochromatic image. This is used to highlight certain

Color Table

features in a Gray Scale image such as display all densities I .
above a certain point in red, or, the imaging device recorded
thermal information, all temperatures below a certain point Cancel

can be revealed in blue color.

When Pseudo Color a monochromatic image, a special palette need to be built with which the
monochromatic image is displayed. Pseudo Coloring an image does not modify the pixels' values in image
bitmap (it does not convert image to true color or palette). It simply associates a Pseudo Color palette with
the image that interprets the gray-level values in the image as color.

The Pseudo Color images are very similar in structure to palette class images, but they differ in a couple of
important ways. First, the pixels' values in a Pseudo Color image actually represent continuous-tone
intensity information, whereas a palette image's pixels carry no intensity significance. Secondly, a palette
image includes a palette table that is actually part of the image file.

The colors used to map the gray values can be selected. The buttons at each end of the color EEEEE

EREOOE
strips ( or ) will bring up the color dialog separately, which allows select the - gg®=
start and end colors of the range. Other. .
12.15 Rangeseee Shift+R
The Process>Rangesss command allows set the | " *
intensity levels of the image to increase the contrast reset (I J3[oss JT[ ueae
and enhance the display in low-light situations. pest it .

Choose Range command to open the Range dialog et 7
as shown on the right side. — .
g [ 1] i ' 100 200

Two vertical markers show the upper and lower limits of the intensity levels. These markers can be moved
with mouse through the drag and drop method. For a color image, the histogram will reflect the red, green,
and blue values with corresponding colors lines.

Two Edit controls indicate the values of the intensity levels. Choose the spin buttons to increase or decrease
these values. All values between 0 and the lower limit will be black and all values between the upper limit
and the upper end of the scale will be white. These two edit control values corresponding to the two
vertical markers show the upper and lower limits of the intensity levels. Defaults are o and 255
respectively.

Reset: The Reset button allows Reset the black and white levels to the high and low ends of the dynamic
Range;

Best Fit: The Best Fit button automatically sets the intensity levels to the Best Fit. Best Fit instructs the App
to optimize the brightness and contrast values for the particular image;

Invert: The Invert button reverses the color of the image;
Update: Update will refresh the display Range with the most current image information.
12.16 Binaryeee Shift+B

Binary is a kind of gray level process. If the | gy x
gray of the pixel is greater than the given w5 |3

threshold, the pixel's color will be changed
into white. Otherwise, the pixel's color will
be changed into black. Although the process Cones!
may lose some information, it is an important

Best Fit
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step of other processes.
The curve on the Binary dialog shows the gray distribution of the image.

The Line in the dialog indicates the threshold value. Drag the line to change the threshold, or change the
value in the Line position edit box (in the top left corner of the dialog) to move the Line.

The Line position Edit box shows the current position value of the Line; Modify the value will move the
Line at the same time;

Click the "Best Fit" button to apply the auto threshold process to the image. It uses an automatic threshold
to make the image Binary.
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13 Layer
13.1 About Layer

The App’s Layer is like sheets of stacked acetate. You can see through
transparent areas of a Layer to the Layers below. You add a Layer to
position the Objects content on the Layer, like sliding a sheet of
acetate in a stack. You can also hide/show a layer to make content
invisible/visible.

You use layers to perform tasks such as perform the Measurement on
the image without polluting the image and save it for the future
adjustment or further analysis.

13.2 Organizing Layers

A new image has a single Layer called Background layer. The number of additional layers you can add to an
image is limited only by your computer performance.

You work with layers in the Layers Sidebar. The Layer Sidebar help you organize and manage layers just
like the Layer menu.

13.3 Layers for non-destructive Measurement and label

Rather than edit image pixels directly, you can label the image with text and measure the image and leave
the underlying pixels unchanged. Because of the non-destructively to images, you can later tweak or
remove the label and the Objects.

13.4 Layer Sidebar

A: Make a New layer; e o

B: Remove a layer; 2 \j x|0®|d o New.  cuen
C: Set the Current layer; e gEiblei e [ ik

D: Show/Hide a layer; il T Ty / i
E:Rename a layer; L L2 E e I Rename.

F: Right mouse button context menu for the | * M- 1 New. S
Background layer; o ‘

G: Right mouse button context menu for the SRR e
Current not checked layer; = #c. [ [0u. B

H: Right mouse button context menu for the Current checked layer;
| : Right mouse button context menu in the blank area;

Note: a) Only one layer can be checked as Current Layer. If a layer’s Current is checked, the Visible will be
checked automatically; b). The Current and Background layers cannot be removed. Only the non-current
and non- background layers can be removed; c). All the Objects on the Current Layer can be selected,
edited or exported; d). The non-current Layer can be Visible (checked) or invisible (unchecked).

13.5 Layer menu and Layer Sidebar page context menu
Mew... Ctrl+M

The function of the Layer menu and Layer Sidebar right mouse button context menu femeve
are the same. They are described in the following section. Current

Show/Hide

Rename...

13.6 Newseee Ctrl+N

Setup a new layer. After the new layer is setup, it will be added to the end of the Layer Sidebar’s items and
the Visible and Current items will be checked. The first Layer will be created automatically when user
perform the Measurement operation.

13.7 Removeeee
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Remove the non-current Layer.

Note: the Background and Current Layer cannot be removed.

13.8 Currenteee

Set the selected Layer as the Current Layer. User then can edit the Object on the Current Layer or added
new Object to the Current Layer. The Current Layer will be always Visible.

13.9 Show/Hideeee

Set the non-current Layer visible or invisible. The Current Layer cannot be toggled between Visible and
invisible state. It is always Visible.

The Layer>Show/Hide<+* will be enabled only when there is a Layer over the Background Layer.

13.10 Renameeee

Rename a Layer.

The Layer>Renameee+ will be enabled only when there is a Layer on the Background Layer.
13.11 Export to Imageeee F2

Export all the Layers’ Objects to the image, this will pollute the image and the image cannot be recovered
anymore.

Export Options x
The Layer>Export to Images++ will be enabled only | “#™e=re= 7
when there is (are) Object(s) on the Layer(s) ' . anesl
Defaults
Label font weight: Bold e
13.12 Export to Microsoft Exceleee F3

Export the image plus all the Objects on different Layers to the Excel file.
Label font size: Used for the Object’s label font size, the

default value is 7(1~28); Export Options x
Label font weight: Normal, Bold, and Heavy. The ti:::d’“ ;
defaU|t iS BOld ’ Cancel

1
The Layer>Export to Microsoft Exceless will be | _.eness
enabled only when there is Layer on the image.

Defaults

Bold -

13.13 Export all to Microsoft Excelsee © F4

Export the current opened different images which have Objects on their Layer to a single Excel file. This
function can be used to capture images with Objects from different video frames who may have the same
characteristics. The output in the Excel file then can be processed to get the statistic properties.

Export Options X

Label font size: 20 =

Label font weight: Bold ~ Cancel

Choosing Layer> Export all to Microsoft Exceleee will
bring up an Export dialog shown on the right side.

Label font size: Used for the Object’s label font size, the
default value is 20(8~72);

Indude calibration information

Save as the default option

Label font weight: Normal, Bold, and Heavy. The default is Bold;

Include calibration information: If the images are calibrated, check this item will output the calibration
information to the Excel file;
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Save as the default option: If this item is checked, the current setting will be saved for the future application.

The Layer> Export all to Microsoft Excelsee will be active only when there is Layer on the Background
Layer.
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14 Measurements

The Measurements menu is mainly used for the image s
measurement. With this menu, you can measure the image with v / o o e
many geometrical shape at ease. The App uses Layer technique to = / — Horaanline
manage the measurement object. This will never pollute the image 8 V |
pixels. The Measurements menus and its submenus are shown Pt B g P
below. A | £t HodioniaiLne
About the Layer technique, please check the Layer menu and Layer A [= e
Sidebar in Sec 13. = \Z o

Two Circles N Two Points
About the Measurements setup, please check Options> 3 N2
Measurementees and Measurement Sidebar in View>Sidebar menu & '
in Sec.7.4.8 Sae T ey
About the Measurements menu’s toolbar buttons, please check the - il

App’s toolbar in Sec.3: Ul toolbar.

Note: a) To check or modify the parameters of the selected Object, just select a single Object and the
Measurement Sidebar will be activated and extended automatically. Here user can edit the corresponding
Object parameters to modify its properties; b) The Appearance, Coordinates on Measurement Sidebar will
be enabled only when a single Object is selected. The Calculation will be effective for a single selected
Object or multiple selected Objects. Its calculated items will depend on the selected Object type (The type
could be the same or different).

14.1 Object Select .

The Measurements>Object Select menu or the toolbar button . will be enabled only when a new
Measurement is made over the Background Layer.

After the Measurement is done on the specific layer, choose this menu to select the Objects.
1. The Object can be selected by clicking on it;

2. Select a group of Objects by including them in a rectangular area with Object Select command or by
press down the Shift key and clicking the Object with left mouse button until all the desired Objects are
selected.

14.2 Angle £

1421 Angle (3 Points) <

1. Move the mouse on the image to point 1, mark it by clicking the left
mouse button;

2. Move the mouse to point 2, mark it by clicking the left mouse
button;

3. Move the mouse to point 3, mark the final point by clicking the left
mouse button. A label 50.26° will be shown near point 2.

1422 Angle (4 Points) 4
1. Move the mouse on the image to point 1, mark it by clicking the left mouse button;

2. Move the mouse to point 2, mark it by clicking the left mouse button; Point 1 and point 2 will be
connected automatically to form L12;
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3. Move the mouse to point 3, mark the first point of the
second line;

4. Move the mouse to point 4, mark it by clicking the left
mouse button; Point 3 and point 4 will be connected
automatically to form L34;

5. After the above process, L12 and L34 will be extended to
form an angle between L12 and L34.

A label 34.40° will be shown near vertex.

14.3 Point

Move mouse to the point; click the left mouse to mark it. It will show
the point Label Ptn and its position x and y over the image.

14.4 Line

14.4.1 Line>Arbitrary Line /

Draw Arbitrary Line between the two points on the specified
layer.

1. Choose Measurements>Line> Arbitrary Line command,

2. Move mouse to the 1st point; click the left mouse button to
mark it;

3. Move mouse to the 2nd point, click the left mouse button to
mark it again, a line with L1 and its length will be shown.

14.4.2 Line> Horizontal Line - Ctrl+Left mouse button

Draw a Horizontal Line between the two points on the specified layer. When the 1st point is marked, the
2nd point’s y coordinate will be restricted to equal to the first point’s y coordinate automatically.

14.4.3 Line> Vertical Line | Shift+Left mouse button

Draw a Vertical Line between the two points on the specified layer. When the first point is marked, the
second point’s x coordinate will be restricted to equal to the first point’s x coordinate automatically.

14.4.4 Line>Multipoint Connection 7

Connect the left mouse button clicked points to form a straight line.

Ctrl+Left mouse button will draw a horizontal Multipoint Connection.

Shift+Left mouse button will draw a vertical Multipoint Connection.

14.5 Line(3 Points)

14.5.1 Line(3 Points)>Arbitrary Line

14.5.2 Line(3 Points)>Horizontal Line (Ctrl+Left mouse button)

14.5.3 Line(3 Points)>Vertical Line (Shift+Left mouse button)

All of these are just as Line>Arbitrary Line, Line>Horizontal Line Line>Vertical Line function, but the 3™
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point is used to locate the label position.

14.6 Parallel 7/
1. Choose Measurements>Parallel command; 5 Aonance
2. Move mouse and click to mark the 1st point; | %% .
'_\ Coordinates
3. Move mouse and click to mark the 2nd point; = B
. . Endl.X
4. Move mouse and click to mark the 3rd point; 1 TR Endl.Y
A ) Start2.X
5. Move mouse again, one will find the 4th point N> Sar2t
is always restricted to parallel to the line | BEXEEEmp
connecting point 1 and point 2. Click to mark the L SRR, IEZE,
4th point. Two parallel lines will be labeled and Angle 14368
Distance 16096.83 =
numbered. e

14.7 Two Parallels
1. Move mouse and click its left button to mark the 1st point;

2. Move mouse and click its left button to mark the 2nd point. Line 1 (the 1st line) connect these two points
will be overlaid on the image;

3. Move mouse and click its left button to mark the 3rd point;

4. Move mouse again, one will find the 4th point is always restricted to parallel to the Line 1 connecting
point 1 and point 2. Click to mark the 4th point. Line 2 will be drawn which is parallel to Line 1. A dot line
DL 1 located at the center of Line 1 and Line 2 will also be marked. Thus the 1% parallel is finished;

5. Repeated step 1~4 will draw Line 3 and Line 4. A dot line
DL 2 located between the center of Line 3 and Line 4 will
also be marked. Thus the 2nd parallel is finished;

6. The App will label the distance between DL1 and DL2 in
with Unit specified in the Unit combo box. The final result is
shown on the right side.

14.8 \ertical 1 -

14.8.1 Vertical>Four Points. X
1. Move mouse and click its left button to mark the 1st point;

2. Move mouse and click its left button to mark the 2nd point. A line (the
1% line) connect these two point be overlaid on the image;

3. Move mouse and click its left button to mark the 3rd point;

4. Move mouse again, one will find the 4th point is always restricted to
perpendicular to the line of point 1 and point 2. Click to mark the 4th
point. Two vertical lines will be labeled and numbered.
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14.8.2 Vertical>Three Points X
1. Move mouse and click its left button to mark the 1* point;

2. Move mouse and click its left button to mark the 2™ point. A line (the 1% line) connecting these two
points will be overlaid on the image;

3. Move mouse and click its left button to mark the 3" point. The 2™ line will be overlaid on the image
which is perpendicular to the 1% one.

14.9 Rectangle O

1. Move mouse to the 1st point; click its left mouse button to mark it;

2. Move mouse to the 2ed point; click its left mouse button to mark it.
A Rectangle will be overlaid on the image according these two
diagonal points.

14.10 Ellipse ~

1. Choose Measurements>Ellipse command,
2. Move mouse to mark the 1st point;

3. Move mouse to mark the 2nd point;

4. If it is not superposing with the shape on the image, choose Measurements>Object Select command to
adjust the position to adjust the Ellipse in order to coincide with the image shape.

B Appearance
Line Width 2
Line Color I oooort
Line Style
Fill False
Fill Color [ c0c0c0
B Coordinates
Start.x 209
Start.y 35
End.X 271
EndY 105
B Calculation
Center (40636.64, 11852.35)
Axes 5248.90, 5926.18
Perimeter 70215.07
Area 97722085.25

14.11Circle @~

14.11.1 Circle>Center+Radius @

Choose Measurements>Circle>Center+Radius command to draw a circle with Center+Radius method on
the specified Layer. Here, the circle is C1@33583.88um.

14.11.2 Circle>Two Points O

Choose Measurements>Circle>Two Points command to draw a circle with Two Points method on the
specified layer.
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14.11.3 Circle>Three Points {:}

Choose Measurements>Circle>Three Points command to draw a circle with Three Points method on the
specified layer.

14.12 Annulus

1. Find the Annulus center 1 and click mouse button to mark the Annulus
center;

2. Move mouse to let the 1% circle superpose with the image circle,
clicking the mouse left button;

3. Move mouse to let the 2" circle superpose the image circle, clicking
the left mouse button. Two radiuses with number and units will be labeled
on the Annulus.

14.13 Two Circles F -
14.13.1 Two Circle>Center+Radius(R)

Draw Two Circles with Center+Radius method on the specified layer. After the Two Circles are drawn, a
line connecting these two circle centers will be drawn.

14.13.2 Two Circle>Three Points(3)

Draw Two Circles with Three Points method on the specified layer. After the Two Circles are drawn, a line
connecting these two circle centers will be drawn.

14.14 Arc A
1. Move mouse to mark the 1st point;
2. Move mouse to mark the 2nd point;

3. Move mouse to mark the 3rd point, then an Arc with Label and its Length will be drawn connecting these
three points.

14.15 Text

1. Choose Measurements>Text command;
2. Move mouse to mark the 1st point;

3. Move mouse to mark the 2nd point, a rectangle with dash line restrict the Text window size. After the
mouse button is released, a dialog called Text will bring up for you to enter the Text;

4. Enter the Text and click the right mouse button to end the Text object.
Note: The Text, Text frame styles, and Text positions can be modified on the Measurement Sidebar.
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Text *

A

14.16 Polygon i

1. Choose Measurements>Polygon command;
2. Move mouse and click the left mouse button to mark the 1st point;
3. Move mouse and click the left mouse button to mark the 2nd point;

n. Move mouse and click the left mouse button to mark the nth point;

n+1. Click the right mouse button to end the Polygon command and the
n™ point will be connected with the 1% point.

If only 2 points are marked and the 3™ action is the clicking of right mouse button, then nothing will be
done.

14.17 Curve H Random Connection & :Cn MUltIFIIDIFIt Connection

14.17.1 Curve>Random Connection

1. Press down the left mouse button and move mouse
according to the requirement to draw any curve in Random
Connection format;

2. If the left mouse button is released and move the it to a
new position and then click the left mouse button again will
draw a line to connect the last point;

3. Release the left mouse button and click the right mouse
button to end Random Connection.

14.17.2 Curve>Multipoint Connection

The Model 2 Curve operation is almost the same as that of the
Polygon.

1. Choose Measurements>Curve> Multipoint Connection command,;

2. Move mouse to a point and click the left mouse button to mark the
1st point;

3. Move mouse to a point and click the left mouse button to mark the
2nd point;

4_ ooo;
n-1. Move mouse to a point and click the left mouse button to mark the (n-1)th point;

n. Move mouse to the final point and click the left mouse button to mark the nth point, then click the right
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mouse button to end the current Multipoint Connection process.
Choosing . button can adjust the finished Multipoint Connection.

14.18 Scale Bar

Choose Measurements>Scale Bar command will bring up a Scale
Bar dialog as shown on the right up figure.

Scale Bar X

|| | |Micromeber {um}) V|

Input the number in the length edit box to determine the Scale Bar
length. The Unit is chosen according to the current Unit in the o 5
Options>Measurement>Length Unit page. If the Unit is pixel, then
Scale Bar dialog will be change to the right bottom figure.

Change the default value (3000) to the desired length and directly [0 B e
click OK, a Scale Bar will be displayed on the image in
Measurement style. Cancel

Scale Bar X

One can move the Scale Bar to where ever he wants(Choosing Measurements>QObject Select after the Scale
Bar is displayed on the image/video window and move the mouse to the Scale Bar and click down the left
mouse button). The final result should be:

Line Width 3

Line Color W £fo000
Font Size 1

Font Weight Hormal
Text Color W £fo000
Transparent Background True

Background Color [] ££E££F
T

Lenzth 0°
# Calculation 20°
= Coordinates BT
EES

Start. X
Start. ¥ 365

The Scale Bar can be rotated on the Measurement Sidebar as shown above.

14.19 Arrow A

Draw an Arrow on the image to specify the key or interest point on the image or video.

14.20 Z Order

The Z Order submenu is shown on the right side. B [Top

44 Bottom

Top: Modify the selected Object's relative position to the uppermost place of all ...,
Objects on the Current layer; 4 Move down

Bottom: Modify the selected Object's relative position to the lowest place of all Objects on the Current
layer;

Move Up: Modify the selected Object's relative position to the higher place of the two on the Current layer;

Move Down: Modify the selected Object's relative position to the lower place of the two on the Current
layer.
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15 Options

15.1 Preferenceseee - Shift+P

There are 8 pages for the Preference dialog, they are Quick Save, Quick Record, File, Report, Grids,
Capture, Metadata and Misc pages.

The File>Quick Savesss menu or the Quick Save icon A on the toolbar will be enabled when a) a new
image window snapped from the camera; b) an image window by choosing File>Paste as New File
command created.

The File>Quick Savesee command can save the file at quick way with no need to specify file directory,
name & format. All are specified in Options> Preferencese+*, Quick Save property page as shown below:

Preferences X
Directory:
Quick Save Base: |D: \Test Image\Sample &) |
Cuick Record Sub: Mone ~
File File:
Mame Format: nnnn {sequence) ~
Report
File Prefix: |test
Grids
File type: ipa (IFEG) ~
Capture A1 5how the rename dialog
Metadat:
adata Sample: [D\Test Image \Sampie!testo00 L.jpg
Misc 1. The above settings will be applied to "Quick Save” menu and the carrespanding
button in the toolbar. When calling "Quick Save®, images wil be saved quickly according
to the above settings in the spedfied directory.
2. IFRGB48 format is selected, the image will always be saved as a tif file because only
tif file could support RGE4S format.
Date(yYMMDD)
Cancel Aoply
Year (VYY) \Month(MM)\Day(DD)

Directory: Enter the name of the drive and directory where the new image will be saved. User may either
type the path information, or use the Browse button'&¥ to locate it from a standard Browse Folder dialog;

Sub: The sub directory for the Quick Save under the Base directory. The Sub can be Noneg,
Date(YYYYMMDD) or Year(YYYY)\WMonth(MM)\Day(DD). The default is None;

Name Format: The year, month, date, hour, minute and second or nnnn (sequence) are used as part of the
file name. If more files are saved with in a second, a nnnn suffix is attached to the end of Name Format to
avoid the possible name confliction. For the nnnn (sequence) Name Format, no suffix is needed:;

File Prefix: Enter a file name prefix for Quick Save when generating files names for a series of images.
This Prefix will be combined with Name Format to form a final file name naming paradigm;

File Type: In this list box, select the format in which you want the image to be saved (can be JPG, PNG, TIF
or BMP). If RGB48 format is selected, the image will be saved as a tif file because only tif file supports
RGB48 format; About the BMP format, it will be available only when the item in Options>Preference...
Misc page, File Format’s Add BMP... item is checked. See Sec.15.1.8.5 for details.

Sample: The final file name is shown at the right of the Sample label for reference;

Show the rename file dialog: The file name can be renamed
according to this item. When this item is checked, a Rename
dialog will pop up after choosing File>Quick Save command

Rename X

[ pon't show the rename dialog later

or click the Quick Save icon = on the toolbar. The new
Cancel

name can be specified again according to the requirement.

Quick Record is a method that allow users to take video records with the preset options, including the codec
method, video records names, etc. With Quick Record enabled, users do not have to input the recording
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related options every time.

Choose Options>Preference menu will QuickSave | [Jenable
invoke the Preferences property page, | uickRecom | o i=renane oo
Click the QUiCk Record item in the File Fiie Name Optians... Directory Options...
Preferences property page and the Report
Quick Record page is shown as on the Grids
right side. Copture
Enable: When Enable is checked, the | M |y quckrecrais coaid,the recor e ot e sron, hen s i
record wizard will not be ShOWﬂ; Misc Z:‘?I:EE%E br;;n% :gg ndsirrjecnury will be auto generated according to “File Name Options”
Show the rename dialog: If this item is S R S
checked, and the Record button on the
Capture & Resolution group is clicked, —
the Rename dialog will be invoked as feneme %
shown on the right side. User can enter (1212215403
the name wanted in this dialog; [Jon': show the rename didog lser
Cancel

Options x

Name Format: |yymmddHHMM55 v| Opticns

Fie Prefix: [wAl | Base: [DrTest image\sample | |

Sample: [vr181212215719 | s s =

oK Cancel
Cancel

File Name Optionse«e: It including the Name Format, File Prefix and the name Sample for reference;

Directory Optionseee: The Directory Options including Base and Sub directory defined by the user. The Sub
directory can be None, Date (YYYYMMDD) or Year(YYYY)\WMonth(MM) \Day(DD). The default is

None;

When Quick Record is started, the file name and directory will be generated _
automatically according to the File Name Options and Directory Options. | acspture & Reselution
The Bitrate is equal to the default Bitrate (calculated based on video width, '
height, and frame rate) multiplied by the Bitrate scaling percentage used for
the last recording; The others (such as the codec, time-lapse, etc.) will be the

same with the last one used.

»

Snap D Record

Resoluton:  [1824 x 1215

Click Record on the Capture & Resolution group to start quick recording.

One can check a file Extension for the
specified file Format and its Abbreviation,
to determine whether or not it will be
displayed in the Browse window (The
checked Format can be displayed in the
Browse window).

Extension: Used to identify the file
extension;

Format: English full name of file formats;
Abbreviation: File Format’s abbreviation;

Format: |RGB 24 - ‘
Preferences x
Quick Save Extension Format Abbreviation  Browse = * Options...
ot
bmp Windows Bitmap BMP
‘ File ‘ dib Windows Bitmap BMP
rle Windows Bitmap BMP
Report ipa JPEG IPEG
. ipeg IPEG IPEG
Grids i
ipe JPEG IPEG
Capture jif JPEG JPEG
ifif JPEG JPEG
Metadata png Portable Network Graphics PNG
i f Tag Image File Format TIFF
Misc tiff Tag Image File Format TIFF
ip2 JPEG 2000 Standard JPEG2000
ik JPEG 2000 Codestream IPEG2000 v
. o - —
Cancel Apply
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Browse: Check/uncheck to determine whether or not the file Format can be displayed in the Browse
window;

Optionsee=: To configure the image file Save As Option for tft, jpg, jpeg, jpe, jif, jfif, png, tif, tiff, jp2, j2k,
webp, gif and dng. For details, please refer to the Option button explanation in the File>Save As dialog(See
Sec.5.5 for details).

Choosing Options>Preferencesss menu will invoke the Preferences property page, Clicking the Report item
in the Preferences property page, the Report page is shown as below:

Template: The report template use placeholders to represent various content to be replaced,;

Edit: Click the Edit button to open the |, oo %
Template to edit;

. Template
Cuick Save smee

CAUsers\User\AppData\Loca\CompanyMName\AppName\MyTemplets. docx i

Clone: Click Clone button to clone the | auickRecon

Edit Clone. .. Delete Reset
current Template; Fie
Tips
. H Report 1. The report template use placeholders to represent various content to be replaced.
Delete . CI |Ck DE I ete bUttOﬂ tO de I Ete the 2, 400y mm DD R MM {55} is a time placeholder which represent Year, Month, Day,
Grids Hour, Minute, Second respectively, {{LD}}{{SD}} respectively represents a long date and a short date.
Cu rrent Tem p I ate’ 3. The image in this template whose title or description of alternative textis {{IP}} will be regarded as
the image placehalder.
. Capture 4. A table with one row and one column filled with content of {{MT}} will be regarded as the
. measurement table placeholder. The properties of the measurement table are the same as the
Reset . C I I C k Reset b Utto n to e rase the Metadata placeholder, induding border color, alignment mode, etc, The width of every columnis equal to the width

of the placeholder divided by the number of the columns. The height of the measurement table is equal
to the height of placeholder.

content of the selected template and |
. . 1s¢ 5. When the WORD report is generated, image placeholders will be replaced by corresponding content.
rep I aced |t Wlth the defau It Tem p I ate . The replacement of multiple pictures will depend on the image selection order in the thumbnail UL,

6. Word version must be 2007 or above.

In the Template, there are following
items described below: Cancel

{YYYYIH{MM}H{DD} H{HH}H{MM}}{{SS}} is a time placeholder which represent Year, Month,
Day, Hour, Minute and Second respectively;

{{LD}}{{SD}}: {{LD}}{{SD}} represents long and short date respectively, DD can be LD or SD;

{{IP}}: The image in this template whose title or description of alternative text is {{IP}} which will be
regarded as the image placeholder;

{{MT}}: A table with one row and one column filled with content of {{MT}} will be regarded as the
Measurement table placeholder. The properties of the Measurement table are the same as the placeholder,
including border color, alignment mode, etc. The width of every column is equal to the width of the
placeholder divided by the number of the columns. The height of the Measurement table is equal to the
height of placeholder.

When the Word Report is generated, the image placeholders will be replaced by corresponding content. The
replacement of multiple pictures will depend on the image selection order in the Thumbnail window.

The Word version must be 2007 or above. See File> Microsoft Word Reporteee (F10) for how to use the
Word Report function.
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Preferences x

Choosing View>Grid> Settingess command, :

or choosing Preference>sse command and | ““™ | s .

clicking the Grids page can set the Grid line | ““™™ | c. |m oo s
Style, and Line Color for the Grid overlaidon | ™

the video and image window can also be set.

Report

Grids

Grid Line Style: The Line Style for the grid | c.oue e
can be Solid, Dash, Dot or DashDot et al. | jeiiee
Default is Solid; Misc

Grid Line Color: The color of the grid line.
Default is Red (255,0,0);

Cancel Apply
Preset Management: Click the Preset Management button will invoke the Management dialog to manager
Manual Grids items that have been set before.

Management H

To manage the saved Preset options, Export or Import | e wame S
the grids to or from file, click the Preset Management | 1 wreca: —
button will pop up a Management dialog to manage

the saved Manual Grids. The Rename, Remove, Up
and Down button will be enabled only when a item is
selected. Tmport...

Export...

If the item order is changed or the item is deleted, the
submenu under the View>Grids>Preset will also be
mOdiflEd. Cancel

=]

If one wish to capture an image with many Objects overlaid on the video window, the following settings
should be defined first.

Choosing Options>Preferencessss command and clicking Capture page, the Capture page will be shown as
below:

Capture with Marker and Watermark:
Checking Capture with Marker and
Watermark will capture image with
Marker and Watermark on the video
window;

Preferences X

Quick Save Capture with Marker and Watermark

Quick Record [ Capture with grids

File Capture with Measurement

Report Set the DPI of the captured image to: E >
Capture with Grids: Checking Capture with | e
Grids will capture image with Grids on the [ cue |
video window; Vietadata

Capture with Measurement: Checking | Vs
Capture with Measurement will capture
image with Measurement Objects on the
video window; Cancel pre

Set the DPI of the captured image to: The DPI can be used to the display or print operation, if one keep
using the Calibrated Resolution of the microscope image captured with the camera, the large Calibrated
Resolution will make the image in small size in the Word file or on the paper printed. The value in the DPI
dialog can be set to 150, 300,600 or 1200 for the print or display application.

Click Ok to end the setup, the Apply to apply the setup, or Cancel to cancel the setup.
After the above steps are finished, if there are Marker, Watermark, Grids or Objects overlaid above the
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video, choosing Capture>Capture Image or clicking on the Camera Sidebar will capture the
image with Marker, Watermark, Grids or Objects overlaid on the video.

Choosing Options>Preferencesse command, and clicking Metadata page, a dialog called Preferences will
be brought up as shown below;

This Metadata property page is used to set the property values of different file formats, including jpg, png or
tiff format after the image is captured.

EXIF: Exchangeable image file format (officially EXIF, according to JEIDA/JEITA/CIPA specifications) is
a standard that specifies the formats for images, sound, and ancillary tags used by digital cameras
(including smartphones), scanners and other systems handling image and sound files;

Preferences X
Enable: Check the corresponding items ) : — "
. . - - . Cuick Save EXIF Enable Value Description
will save the items in the image file; cickrecond | |1 [Auto] Camers Model
uiek hecor SerialMumber [Aute] Camera Id
Value: [Auto] in the value column means | re DateTmeOrgnal [Auto] date of the observation
. . DateTimeDigitized [Auto]
th e SOftWB.re WiI I I fl I I the Val Ue Report ExposureTime [Auto] Exposure Time
automatically. For the other items that the | s comat e
value column is blank, User can double | ... serComment Comment
- - - ImageDescription Description
click the items and set the value in the " | e Lt Rarge (900,900, s s 15785, 157150, 1572
pop Up dlalog, " Longitude Longitude, Range = [-180.0, 180.0], such as 15.715, 15.745W, 1!~
< >
DESCI’i pti onS The eXp I anati ons Of the This property sheet is used to set the property v._a\ues of gliFFerent_ﬁIe fnrmats_, induding jpg, pna, _tiff. etc.
. [Auto] in the value column means the software will fill the information automatically. For the other items that
EX I F Items . the value column is not [Auto], you can double dick the items and set the value,

Cancel Anply

The Misc page is mainly used for the control of the App’s basic setup as shown below:

Preferences X

Quick Save Show the splash screen on startup: A

Prevent screensaver when video preview f capture
Quick Record L‘ White Balance (Take effect after restarting App)
(®) Color Temperature/Tint

File O RGE Gain
@ Auto Exposure
Report i1 Policy
(7 Exposure Only
Grids (®) Exposure Preferred (Default)
() Analog Gain Only
Capture (O Analog Gain Preferred
ﬂ Maximum Exposure Time (Range:[10, 5000], Default: 350ms): 350
Metadata Maximum Analog Gain (Range:[100, 5000], Default: 500%:): 500
Il File Format
‘ Misc ‘ Remind me when the file format doesn't support measurement objects

Add BMP format to file type selection for "Quick Save™, "Batch Save”, etc (BMP format does not st
[ Using UTF& charsetin CSV
I nits of temperature

=

£ >

Cancel Apply
All of the Misc page functions are described in the following subsection.

15.1.8.1 Show the splash window on startup
Check ] Show the splash screen on startup \yj|| show the splash screen at the start up of the App.

15.1.8.2 Prevent screensaver when video preview / capture

When camera video is started/recorded or the the capture is in the process, check this item will prevent the
computer screensaver operation( Prevent screensaver when video preview [ capture )

15.1.8.3 White Balance(Take effect after restarting the App)

User can select Color Temperature/Tint or RGB gain for White Balance operation in the White Balance
group on the Camera Sidebar according to his requirement or personal interest.
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l_‘ White Balance (Take effect after restarting App)
(® Color Temperature, Tint

(O RGB Gain
[

l.‘ White Balance L‘ White Balance
Color Temperature: 6503 Red: 0

1
Tint: 1000

Green; a

1
Move the ROI {Marked by a red rectangle) to a pure white .
or gray object and dick "White Balance™ to establish the Blue: a
white balance for future video.

$hite Balance Tefaults
White Balance Defaults

15.1.8.4 Auto Exposure

User can set the Auto Exposure Policy for the camera to optimize the camera Auto Exposure performance
in the Exposure & Gain group on the Camera Sidebar.

[ Exposure & Gain A
|:|Autu Exposure

Exposure Target: 120

E Auto Exposure Exposure Time:
o Paolicy
() Exposure Only {
(®) Exposure Preferred (Defaults) Gain:
(O Analog Gain Only
(O Analog Gain Preferred 0]

M Al o g1, S0, e S00%0: 500 |
Policy>Exposure Only: If this item is selected, the App will only adjust the Exposure Time automatically,
no Analog Gain adjustment will be considered. But user can adjust the Analog Gain manually;

Policy>Exposure Preferred (Defaults): If this item is selected, the App will adjust the Exposure Time at
first. If the Exposure Time reaches to its Maximum Exposure Time value, but the video still does not
reach to the Exposure Target value, then the Analog Gain adjustment will be performed along with the
Exposure Time automatically;

Policy>Analog Gain Only: If this item is selected, the App will only adjust the Analog Gain automatically,
no Exposure Time adjustment will be considered. But user can adjust the Exposure Time manually;

Policy>Analog Gain Preferred: If this item is selected, the App will adjust the Analog Gain at first. If the
Analog Gain reaches to its Maximum Analog Gain value, but the video still does not reach to Exposure

Target value, then the Exposure Time adjustment will be performed along with the Analog Gain
automatically;

Maximum Exposure Time (range: [10, 5000], Default: 350ms):350: Click to enter the Maximum
Exposure Time wanted in the range of [10, 5000];

Maximum Analog Gain (range: [100, 5000], Default: 500%):500: Click to enter the Maximum Analog
Gain wanted in the range of [100, 5000].

15.1.8.5 File Format

B Fle Format
Remind me when the file format doesn't support measurement objects
Add BMP format to file type selection for "Quick Save”™, "Batch Save”, etc (BMP format does not st
[] Using UTFa charsetin C5V

Remind me when the file format doesn’t support
- - - - The format you selected don't support layer and measurement. If you want save
measurement ObJeCt ChECk thlS bUttOn WI” remlnd the USGI’ |ayJE;ég?Et_n¥eaiu_rem?Qt_wiﬂfiq}agi%glegse select these form;trf: ! :
+JPQ; T JPed; T pe; I )
that the selected format doesn’t support Measurement | #cCea o

Objects save operation. The remind dialog is shown on the i‘?ffé&’g:&‘.;ﬁz’
. - TFT (.
right side. o

1.00

tft Format X

The current formats supporting Layer Objects are JPEG, | D=
PNG, TIFF, JPEG2000,WebP and TFT. T - —

Add BMP format to file type selection for “Quick Save”, “Batch Save”, etc (BMP format does not support
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calibration and measurement: Check this item will allow the BMP format available in the File> Quick
Save and File> Batch Save commands’ format list box (See Sec.5.6, 5.7, 15.1.1 for details).

Using UTF8 charset in CSV: Check this item to prevent the messy code in the CSV file (See Sec.7.3.3
and 7.3.4 for details).

15.1.8.6 Units of temperature

I Units of temperature
- . . . @) Celsius (°C) .
User can select either Celsius(°C) or Fahrenheit(°F) unit  Orereten for the cooling camera.

15.1.8.7 Sidebars
Used to ensure the corresponding action will activate the corresponding Sidebar

[Tl sidebars
Automatically activate the measurement sidebar when measuring
Automatically activate the folders sidebar when opening the browse window
Automatically show the browse window when double dicking the folders
Automatically activate the camera sidebar when startup

15.1.8.8 Stitch(Video)
This item is used for the Live Stitch(Video) only.

AUtO C rO p Whe n St I tC h iS fl n I S h ed (O Uter bOU n d I n g E biu(:i:daezi when stitch is finished (Outer bounding rectangle)
Automatically disable Auto Exposure during stitching

reCtang I e) ChECki ng th iS Item Wi I I Crop the StitChed Automatically applies the calibration resolution of the current video to the stitched resuitimage. 1
image including its maximum effective pixel size; oo rede

@ Aggressive
O Passive

Automatically disable Automatic Exposure during stitching: When Live Stitch starts, to ensure the image
consistency at different position, Auto Exposure on the Exposure & Gain group will be unchecked if this
item is checked,

Automatically applies the calibration resolution of the current video to the stitched result image. The
accuracy of this value depends on many factors: Checking this item will added the video window’s
Calibration Resolution to the current stitched image for the Measurement application. The App can not
ensure the accuracy of this Calibration Resolution.

Scroll Mode: Aggressive and Passive describe the behaviors of the scroll bars (vertical and horizontal)
during stitching;

For Aggressive mode, the scroll bars are adjusted automatically to make the video frame always lying in the
center of the window while the stitched result moving in the reverse direction;

For Passive mode, the video frame moves along the direction of the moving stage until it reaches to the edge
of the window and at that time the corresponded scroll bar will be adjusted to let the video frame scroll to
the center;

15.1.8.9 EDF(Video)

The Options>Preference>Miscees page’s EDF(Video) items are used to setup for the video
Process>EDFees command.

Automatically disable automatic exposure during EDF: When EDF(Video) starts, to ensure the image
consistency at different position, Auto Exposure on the Exposure & Gain group will be unchecked if this
item is checked,

Automatically applies the calibration resolution of the current video to the EDF result image. The accuracy
of this value depends on many factors: Checking this item will added the video window’s Calibration
Resolution to the current stitched image for the Measurement application. The App can not ensure the
accuracy of this Calibration Resolution.
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Three methods are provided for EDF(Video), = . quws
inCIUding MaXimum Cor_]traSt’ Weighted Average and :EE:::E:::: ::i;‘ljelz ;Zﬁj:;?:::rneri:;ﬂgh::zfﬂwe current video to the EDF resultimage. The
Stack method. The Maximum Contract method is the :

Select Method:
@ Maximum Contrast

default one. Q Wegped v
The Video area size could be changed from 10% to §§§3
40% and the EDF results window size could be O w0
adjusted easily by middle mouse button or the zoom S

list box on the toolbar. 8 o

15.1.8.10 Export & Merge

If this item is checked, a dialog called Export Options will be pup up to set the Label font size and Label
font weight. This setup is mainly used to adjust the font size and weight and let it keeping a nice ratio
between the image and the Measurement Object Labels in Word, Print and other application.

Export Options *
Label font default size: 14
Label font size: 14
Cancel
25% 400%
[ Defaults
Export & Merge Label font weight: Bold ~
Show the "Export Options™ dialog when export

15.1.8.11 External Application

[ External Application
Program: C: \WINDOWS\system32mnspaint.exe

This item is used to specify the 3rd party software for the File>External Application command to open the
current window image. Some standard program has this interface, such as Photoshop or mspaint.

15.1.8.12 Show or hide control in the camera sidebar
Check/uncheck to customize(Show/hide) the Camera Sidebar’s group.
15.1.8.13 Print

The Options>Preference>Misc page’s print items are used to setup the print format for the File>Printeee or
File Print Previewese command. When printing the image and the measurement results, one can set the Page
Header and Page Footer in following format:

Page Header: Page:&p/&P: The page header, click to define the new format; e
; B ﬂ Page Header: Page: &p/&P

Page Footer: &f Date:%Y-%m-%d: The page footer format, click to define the Eiﬁi;ﬂ;ﬁfiﬁlmﬂ%
neW format’ E;i;;?:angﬁ:asurementtable

. - . (®) Always use another paper
Print the measurement table: If there are measurement item overlaid on the 82“; o
. - . . . - Don't use another paper
image, check it will print these objects’ Measurement Sheet on the page with; Ermsms

Page Usage>Always use another paper: Print the Measurement Sheet data on a separate page;

Page Usage>Auto: Print the Measurement Sheet data just behind the image (if the image and data can be
arrange in a single page) of on a separate page (if not);

Page Usage>Do not use another paper: Print the Measurement Sheet data just behind the image page;
For example:

Choosing &f Date:%Y-%m-%d will print the file name and Date with yyyy-mm-dd format on the page
header.

Choosing Page: &p/&P will print Page: 01/11 on the page footer (Suppose the current page is page 1 and
the total pages is 11).

The following options can be used for reference:
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&f File Name

&p Current Page

&P Total Pages

%A Full weekday name

%Db Abbreviated month name

%B Full month name

%0C Date and time representation appropriate for locale

%d Day of month as decimal number (01 - 31)

%H Hour in 24-hour format (00 - 23)

%] Hour in 12-hour format (01 -12)

%)] Day of year as decimal number (001 - 366)

%M Month as decimal number (01 -12)

%M Minute as decimal number (00 - 59)

%p Current local times A.M./P.M. indicator for 12-hour clock

%S second as decimal number (00 - 59)

%U week of year as decimal number, with Sunday as first day of week(00-53)
%w Weekday as decimal number (0 - 6; Sunday is 0)

%W Week of year as decimal number, with Monday as first day of week(00-53)
%X Date representation for current locale

%X Time representation for current locale

%y Year without century, as decimal number (00 - 99)

%Y Year with century, as decimal number

%2z %Z Time-zone name or abbreviation; no characters if time zone is unknown
%% Percent sign

15.1.8.14 Cursor
This command will set the mouse Cursor for the video and image window operations.

Tz, Cursor
# Cross
@ Mone
) single
() Double (1 Pixel)
() Double (3 Pixels)
(O Double {5 Pixels) /Cross:double lines with g
() Double (7 Pixels) pixelsin both directions
() Double (2 Pixels)
0}0 Type
@ Cross
() Cross Hair Cursor: Cross
() Paint
) Null

Select the Cross in:

None (window default), Single (single line), Double(1 Pixel), Double(3 Pixels), Double(5 Pixels),
Double(7 Pixels), and Double(9 Pixels) formats.

Single means single line. Double means two parallel lines. 1 Pixel means the line space between the two
lines is 1 pixel in distance. The other size also has the same meaning.

Select the cursor shape from Cross, Cross Hair, Point, and Null.

In the figure above on the right side, a cursor with Double horizontal and vertical lines with 9 Pixels cross
(for the alignment application, the longer one) and the Cursor as a Cross was defined.

15.1.8.15 UI Style
Select the favorite Ul style for the application.
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HH ur style
(® Windows
() Windows 7
() Visual Studio 2008
() Luna Blue
(O) Obsidian Black
O Agqua
() Silver
() visual Studio 2005
() Office 2003
() Office XP
() visual Studio 97

15.1.8.16 Language (Take effect after restarting the App)
Select the Language for the application. The App now supports 15 languages.

@ Language (Take effect after restarting App)

(O Default

(@) English

(O catalan (Catald)

() French (Francais)

(0) German (Deutsch)

() Indonesian (Bahasa Indonesia)
() Italian (Italiano)

O Japanese (H#58)

() Korean (EH=0)

(O Polish (Polski)

() Russian (Pycauii)

() simplified Chinese (j&i 37
() Spanish (Espafiol)

() Thai (lve)

() Traditional Chinese (ZH37)
(O Turkish (Torkce)

15.1.8.17 Enable GPU accelerated image processing(Take effect after
restarting the App)

Select the GPU of the display card to accelerate the video or

image processing . The App Wi I I I ist the possi ble d isplay Cards A EC:)aE: GPU accelerated image processing {Take effect after restarting App)

according to the computer and user can select different display O =
. - . . ‘fes (Intel(R) HD Graphics 530)
card according to his requirement. Default is No.

15.1.8.18 Privacy
The maximum number of Recent Files can be modified by choosing .
Options>Preferencesess command and clicking the Misc page as Shown on [z e maxmum number of Recent ries: ¢

[] clear the Recent Files when exit the application

the ri g ht S | de . [ restore the current directory when startup

Here, clicking the 4 (default) edit box will allow you to enter the number of the Recent Files submenus that
you want. The value ranges from 0 to 8, the default is 4;

One can also check the Clear the Recent Files when exit the application to clear the Recent Files after exit
the App.

Restore the current directory when startup: Check this item will save the current directory and restore it
after the next startup.

15.2 Measurementsees Shift+M
This sheet has many pages, they are:

15.2.1 General page
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The General page is shown below:

The calculation results keep: The list box
allows you to set the calculation results
accuracy among 1 decimal and 6 decimals.

Default is 2 decimals;

Label font size: The Label is used to display
the Objects dimensions. the Label font size is

among 5 and 15; Default is 15;

Label Color: The Label Color for the Objects
dimensions; Default is red;

Measurement

General ‘

Length Unit
Angle Unit
Sheet

Object

The calculation results keep:

| 2 decimals ~ |

Label font size:

B

Label color: l:

Tefault v

I Dimensions with unit
[ Label with name
Mame the measurement object automatically

Export segment length to: Clipboard

Cancel

Dimensions with unit: If this box is checked, the Dimension will be

displayed together with the unit for the Objects. If unchecked, only the

Dimension will be displayed with the Objects.

Label with name: Checking Label with name will add a Prefix before the
Objects number. The Prefix for the different Object can be specified in the
Measurement Sidebar where there is an item called: Name. Here, we show
an example for Line Object with and without Prefix L1 as shown on the

right side.

Export segment length to: Clipboard, CSV file or Microsoft Excel.

Label with name checked

Label with name unchecked

Length Unit page: One can select the Length Unit for the Measurements menu’s Objects on the Layer

Measurement operation;

Unit: The system unit defined by the App. It cannot be deleted;

Current: The Unit selected or checked;

Type: Type of unit. It can be System (Defined by the App) or User (Defined by the user) type;

Scale: Represents the ratio of "Meter by unit". For example, if the unit is pm, then "Meter by pm™ should be
1000000, the Scale should be 1e+6;

Measurement

General Unit

Pixel
Meter
Centimeter
Millmeter

Length Unit

Angle Unit
Sheet Micrometer
Inch

Object
mil

Current

gorgood

Symbol

px

m
cn
mm
um

in
mil

Type
System
System
System
System
System
System
System

Scale

NA

100
1000
1e+06
39,3701
39370.1

Add Unit

X

MName:

|Dedmeber

| OK |

Scale Factor: | 10

Symbal: |dm|

| Cancel

Meter by kilometer is 0.001, which is

Add... Delete

Cancel

2. Symbol: such as "m” for meter, “om’

1. Scale factor is the ratio between meter and the spedific unit. For example:
Meter by milimeter is 1000 which can also be expressed as sdentific notation 1e3.

* for centimetre.

roted as 1e-3.

Addeee: User can also define his own Unit. Clicking Adde<« button and the Add Unit dialog will be brought
up as above on the right side;
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User can enter the Unit Name and Symbol in
their fields. Here, we enter a name called
Decimeter and its Symbol is dm, its Scale for
Meter by Decimeter is 10. Click OK to end
the Add Unit operation, or Cancel to cancel
the Add Unit operation.

The final Length Unit list looks like the figure
shown on the right side.

You can find the Type is now named User.
This means that this Unit is not defined by the
System, but by the User and can be deleted.

On the Angle Unit page, one can select Radian, Degree, or Pl as the Angle Unit.

Measurement

General

Length Unit ‘

Angle Unit
Sheet

Object

Unit

Pixel

Meter
Centimeter
Milimeter
Micrometer
Inch

mil

Current

Symbal

Type
System
System
System
System
System
System
System

Scale

MNA

100
1000
le+08
39,3701
39370.1

Decmeter

OoorOOoono

User

10 |

Measurement

General

Length Unit

Angle Unit

Degree ~

Show all the angle units in the measurement sidebar.

Sheet

Object

Show all the angle units in the measurement sidebar will list all the Object Units in the Measurement

Sidebar as shown above on the right side for reference.

See the View>Measurement Sheeteee menu to understand its functions.

1. To modify the Measurement Sheet’s item
order, click the item to highlight it, the Up or
Down buttons will be enabled (If the item is
in the third position, the Up button will be
disabled, if the item is in the last position, the
Down button will be disabled). Click the Up
or Down buttons to modify the item position;

Note: The item Index and Name are always
in grayed states, this means these two items
cannot be modified (Both their hide/show
states and their positions).

2. Checking/unchecking the item will
show/hide the item in the Measurement
Sheet;

OK Cancel Apply
X =]
Name -
Label Type Length
Line ¥Width 0
Line Color W ££0000
Line Style
Arrowl
Arrowz
=
Start (27. 94, T.42)
End (14.50, 18.75)
Length 17,27
Slope 0. B7
ingle (Radian)  0.72
inzle (Degree) 40, 99
tngle (Pi) 0.23
El
Start. X hEd
Start. T 152
End. X 297
Cancel Apply End. ¥ 384

Measurement

General
Length Unit

Angle Unit

‘ Sheet ‘

Object

Define the columns of the measurement sheet:

index

Center
Diameter
Area
Length
Angle
Start
End
Distance
Width
Height
Eccentricity

EIREEREEEERIEEE

Up

Default

Cancel Apply

3. Clicking Default will return to the App's default settings;

4. Both the name and order for Item 1(Index) and item 2(Name) cannot be changed.
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The Object page list all Of the ObJCIS’ | oo sruspommic srom e
characteristics. Their characteristics can be | ™ N
modified in this page according to the | "™ | i Conrdinates
requirement. Different Object has different | ™™ | i cilr B oot
characteristics. et Label Tive Lungth
The setups for the Objects are global. User [0 | Lo e | e
can still modify the setup for the specific in vt
the Measurement Sidebar’s Appearance " Label Type Length
items. e tetor -
Line Style
Click Defaults can return the all the =3
modifications to the Default one. Label Type Segnent Lensth v
QK Cancel v

15.3 Magnificationseee Ctrl+M
Choose Options>Magnificationess command to manage

the calibrated Magnification. Magnification X
If one has defined the 4X, 10X and 40X Magnifications, | " Feshton I
the Magnification dialog should look like the figure on the o s Cancrl
1. Highlight the Magnification item and the Decleteeee Clear Al

button will be enabled. Click Deleteees to delete the
selected item;

2. Highlight the Magnification item, click the Up or Down
button to modify the Magnification list order; The Up or =
Down button will be disabled when the highlight item is Import...
at the first or last position;

3. Click Clear All«+- to delete all of the Magnification items; If one wishes to use the Magnification late, a
backup should be made first;

4. Click Exporteee to back up the Magnification in a safe media. The file extension is *.magn;

5. After the new installation is finished, the Magnification can be import by choosing Options>
Magnificationees command and click Importee* to load the previously saved *.magn file;

6. If everything is ok, press OK to end the Magnification dialog.

15.4 Calibrateees =

The detailed calibration steps are as follows:

1. Run the App;

2. Connect the camera to the computer and microscope;
3. Start the camera (Here, it is yyyyy);

4. Switch the microscope object to 10X and put the TS-M1
micrometer in the middle of the microscope field and try to
adjust the ruler clearly. Set the Unit to Pixel and the video
Resolution to the maximum one (2048X1534 for yyyyy) and O
Zoom ratio to 100%.

Calibration Slide

T5-M17 106071
Ruler 1093 0.01mms 1mm

(See Pizel * Ni  100% - ),
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5. Choosing Options>Calibratesss command or clicking  on the toolbar, a red line with pixels number
and 0.000um length is overlaid on the video window. At the same time, a dialog called Calibrate will be
displayed over the video window;

6. Try to align the two ends of the red line with the video ruler
scale (Try to pull the red line as long as possible to keep the
calibration accuracy);

7. Enter or select the current microscope objective lens
Magnification in the Magnification field. The current
Magnification is 10X;

40X
100X

—
—
—
)
K4
3
&
g
3
F
2
=)
g
<\
Y
B5%
g

8. Read the overlaid (by the red line) micro-ruler actual length

and fill it in the Actual Length field, the current Actual
Length is 450um. This Actual Length will also be displayed
in the middle of the red line just behind the pixel number. At
the same time, the Calibration Resolution will be calculated
and displayed simultaneously in the Resolution field;

Actual Length |
Pixel

Resolution

Micrometer (pm) v

1088.000

I rnmwmumuwﬁ?ﬁw,nm]m!mmm

9. If everything is ok, click Ok to end the calibration. The
Magnification 10X (This is the number you entered in the
Magnification edit box) will be available in the Magnification
dropdown combobox on the video window toolbar

§74. 001 Jxezs 450. 000 l |

- = =
Calibrate

Magnification
@ Micrometer (ym) v
Cancel

574.000

_\

10.
Magnification, choose 10X in the above Magnification list
box first and then choose Unit in the Unit dropdown list

If one wishes to make the Measurement under this

oK

Actual Length

Pixel

End Point w

Resolution 1275556 Pixel/Meter

") which is just in the left | |||
of the Magnification’s list box (User can also choose Unit I‘”'l””{””ﬂ”'
through the Option>Measurementsess menu, a dialog called
Measurement will be brought up. Click Length Unit page to
display the Length Unit page and and checking Unit in the
Current item;

bOX( nicron (um) * 10X = 100%

uwuﬁ{ﬁﬁmmnnumpuum

Actual Length

Now, you can measure the objects with the selected Unit at ease.

11. The selected Resolution can be saved for the future image Measurement operations. If the
Measurements are performed on the video, the Objects and Resolution can be saved in the image with the
jpg , png,tif,jp2,webp or tft files for the future applications (See Sec.5.5 for details);

12.The other microscope Magnification such as 4X, 40X,100X can also be defined just as the above steps.
Thus when you switch the microscope objective lens, you just need to select the Magnification

( for example) on the toolbar to perform the Measurement operations.
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Measurement X

General Unit Current Symbal Type Scale
Length Unit Pisxcel [ px System MA
Meter I:‘ m System 1
Angle Unit Centimeter [ o System 100
Millimeter O mm System 1000 Bum
Sheet Micrometer um System le+08
Object Inch O in System 39,3701
mil O

999 _ 4
mil System 39370.1 |||||||||

Add...

I

Cancel Apply

15.5 Edit Dye Listees

The Dye List can be used for the Process>Color Composite operation. The new Dye List feature in the App
allows you to select from a list of dyes, or add your custom dyes to the list. The list of dyes (App.dye) is
stored under C:\Program Files\Company\App directory.

When you choose Options>Edit Dye Listeee command, you

will see the Edit Dye List dialog box: Ecit Dye List X
The list includes any dye definitions found in the current :M s |;56‘“E°““5 =
location. When this feature is used to prompt for a specific E\Hg; e

dye, the list indicates the currently selected dye, or you may | ——
select a dye from the drop-down list. 8

Name: This list includes all dye definitions found in the | coor Red: 000, Greeni 214, Bhe: 255 |
current dye file. You may select a different dye from the New.. Dekcte
drop-down list, and all the remaining controls will be Reset Reoac Al

updated to show the characteristics of the new dye;

Emissions Wavelength: This field displays the emissions wavelength for the dye you have chosen. You can
adjust he emissions wavelength by entering a new value. The default color will change in response to
changes in the emissions wavelength;

Excitation wavelength: The default wavelength for your dye is displayed here. You can adjust the
wavelength by entering a new value;

Color: Use the slider to adjust the emissions wavelength for your dye, which also sets the default display

color. (You can also use the Color button to select a specific color using a standard Windows color
selection dialog) The color will change in response to changes in the emissions wavelength. Here you can
change the color associated with the selected dye, or define a custom color. The color default is linked to the
selection of a wavelength for your dye. If you change the Emissions Wavelength, the color displayed will be
the standard color for that wavelength. To set a custom color, first you should set the wavelength and then
edit the color;

New: Clicking New will setup a new dye, this will invoke a dialog called New Dye. Input your New Dye
name and click Ok to end the dialog and click Cancel to cancel the input. This will return to the Edit Dye
List again and the new name will be the default on in the Name list box. Try to set the Emissions
wavelength, Excitation wavelength, Color for your new dye;

MNew Dye X

Save: Click Save on Edit Dye List to save your dye selection;
Close: Click the Close button to end the Edit Dye List dialog.

Mew Dye 1

ancel

15.6 Auto Correctioneee
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Set the low and high ranges for the Image>Adjust>Auto Level and Image>Adjust>Auto Contrast menus.
The default value is 0.5% for both, but the App suggests this value be smaller than 1%.

See Image>Adjust>Auto Level and Image>Adjust>Auto Contrast for details (Sec.11.2.10 and
Sec.11.2.11).
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16 Window

16.1 Activate Video Window U F6

A video window activating function, which could help to switch to the video window immediately when it
IS not easy to find it among all the opened image windows.

16.2 Close All

Choosing Closes All command to close all of the pictures opened or captured inside the App frame. If user
has made any modifications to the pictures or if you have captured some pictures from the camera,
choosing Close All will let you finish the saving operations quickly.

Video [ Camera XXX | 0001 0002*  0003*  0004* | greencelljpg

video window images captured opened

If the above image windows exist, choosing Window>Close All command will bring up a Save Files dialog
as below:

Save Files X

File has been modified. Do you want to save changes?

Yes No Cancel

Yes to All No to All Batch Save

1. Clicking Yes on the Save Files dialog will close the Video , Browse, Image windows directly that are not
changed without ask anything. If there are newly created Image windows, the App will bring up a Save As
dialog to prompt user to enter the File name to save file (See Sec.5.5 for detail).

If Save or Cancel is clicked in the Save As dialog, the App will return to the Save Files dialog to continue
the next file close operation;

2. Clicking No on Save Files dialog will close the current image window without saving operation and
return to the Save Files dialog to continue the next file operation;

3. Clicking Cancel will cancel the Save Files dialog without doing anything;

4. Clicking Yes to All on Save Files dialog will always bring up a Save As dialog to let you enter the File
name to save files one by one until all of the files are saved,;

5. Clicking No to All on Save Files dialog will close all of the image windows without saving them;

6. Clicking Batch Save on Save Files dialog will transfer the save process to File>Batch Saveess command.
Please check the File>Batch Saveess menu for details.

Note: If you have a lot of images opened and have made some modifications on them and want to close
them quickly without saving anything, you may uses this command and choose Step 5. All the images will
be closed instantly, no warning will be given.

16.3 Reset Window Layout

Choosing Window>Reset Window Layout will reset the App window layout to the original one. The reset
will be effective after restart.

App *

| The window layout will be reset after restart The App

16.4 Windowseee =
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Choosing Window>Windowse** will open a dialog that lets user manage the currently opened windows.

The Windows dialog allows user to manage large lists of open windows by assigning them into groups. Let
us say user has 4 windows opened, but want to close 2 of them scattered through the list.

Windows

X
Select window:

= 0001*
= 0002° OK
= 0003°

Save

Close Window(s)

1. Choose Window>Windowsees command;

2. Select the windows you want to close. Hold Ctrl or Shift key to select more than one at a time. Here, 2
items are selected;

Windows

Select window:

Activate
= 0002 OK
Moo~
\u\{lden [Integrated Webcam] Save

Close Window(s)

3. Click Close Window(s) button, those 2 selected windows will be closed, leaving the other files or
captures available for editing;

4. User can use this command to switch to the selected window on a list by hitting Activate (or "bring up"
from multiple an icon windows).
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17 Help

K
17.1 Help Contents - F1
Choose Help>Help Contents command to load the App help file. The help file is in Portable Document
Format (PDF).

PDF is a file format used to represent documents in a manner independent of application software,
hardware, and operating systems. Each PDF file encapsulates a complete description of a fixed-layout flat
document, including the text, fonts, graphics, and other information needed to display it. In 1991, Adobe
Systems co-founder John Warnock outlined a system called "Camelot" that evolved into PDF.

While the PDF specification has been available free of charge since at least 2001, PDF was originally a
proprietary format controlled by Adobe. It was officially released as an open standard on July 1, 2008, and
published by the International Organization for Standardization as 1ISO 32000-1:2008. In 2008, Adobe
published a Public Patent License to 1SO 32000-1 granting royalty-free rights for all patents owned by
Adobe that are necessary to make, use, sell and distribute PDF compliant implementations.

If your computer still does not install the PDF reader, please try to download it from:
http://www.adobe.com/downloads/

17.2 Diagnosesse )

The Diagnose command is used to diagnose the user’s computer configuration for the analysis of the
compatibility of the OS, the App version, and the installed camera characteristics.

"' Diagnose X
Froperty Value ILI
Computer Dell Inc, XPS 15 9550
0s Windows 10 Pro Cormputer Copy
Version 1303 17134 Characteristics
cpU Intel{R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Cores 4
Threads 3
Memory 166G
| Display GDI, Rec, 703, sRGE, 8 Bits Application
Softuara App Mame and Its
‘ersion 3.7.13593.201812156
Device Name WYYy version
Camera Id TP18082308413447CCF24B3F 13435DC
Production Date 20180823
Revision 1
Hardware Version 1.0
Firmware Version 1.4.1.20161129
FPGA Version 11
Pixel Size (2.400, 2.400) pm
Still Image Capture Yes
5till Image Width 5440
5till Image Height 3648
Video Width 5440
Video Height 3643
Frame a7
Frame Rate 29
Exposure Time 350.000ms Camera
Analog Gain 5.00 Characteristics
Pixel Format RAWE
ROI Mo
Auto Exposure Yes
Exposure Target 120
White Balance 6503, 1000
Black Balance 0,0,0
Hue 0, [-180, 0, 180]
Saturation 123, [0, 128, 255]
Brightness 0, [-64, 0, 64]
Gamma 100, [20, 100, 180]
Contrast 0, [-100, 0, 100]
Frame Speed 2, [0,7
Power Frequency (Anti-flicker) Dc
Flat Field Correction No
Dark Field Correction No
Sharpen 0%

Click the Copy button to copy the Diagnose items to the clipboard for further application such as send it to
the supplier for analysis ital.
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17.3 Aboutese

Display the related information about the App, including the App version, Compatible OS, Built date and
its developer’s www etc.

Infe PROVIEW X

ﬂ
FE omarown

Copyright (C) 2003 - 2017

Versione: x64, 3.7.10649.20171220
Compatibile: Windows XP Vista/7/8/10
Versione: Dec 20 2017 15:15:43

hitp //www optikamicroscopes.com

Clicking on the URL link will direct user to the www address of the camera supplier. If user has any
problem with the camera or application, please feel free to contact your supplier.
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